Announcement

Collapse
No announcement yet.

4.18 Control volume of Media Sound component?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4.18 Control volume of Media Sound component?

    I have a video setup using the new media framework from 4.18, including a Media Sound component in an actor BP. Everything is working as expected. However, I cannot figure out how to control the volume of the Media Sound.

    Is there any documentation on how to control a Media Sound's volume?

  • #2
    Hey Ken! Does the attenuate work or does it play the sound all over the level? NOTE: The attenuation will work if the video is in the center of the map, if you move the video from the center then the attenuated sound will still be playing from the middle.

    Comment


    • #3
      Hi Ken_Brueck, did you try using Set Volume Multiplier?

      Media Sound Component just wraps the Synth Component, so it should have access to all the basic Synth Component BP API functions.
      Dan Reynolds
      Technical Sound Designer || Unreal Audio Engine Dev Team

      Comment


      • #4
        This is strange — I don't even have an option for Set Volume Multiplier.

        For what it's worth, when I uncheck 'Context Sensitive' and browse Synth > Components > Audio, I don't see a Set Volume Multiplier there, either.

        Comment


        • #5
          Hmmm, weird. Try activating the Synthesis plugin. Maybe the API lives there?
          Dan Reynolds
          Technical Sound Designer || Unreal Audio Engine Dev Team

          Comment


          • #6
            Thanks Dan, unfortunately it's already enabled in my project. Here's a screenshot of all my activated audio plugins.

            Comment


            • #7
              Weird! Are you on the latest version?
              Dan Reynolds
              Technical Sound Designer || Unreal Audio Engine Dev Team

              Comment


              • #8
                I'm on 4.18.2 and even verified my install yesterday as a sanity check. Your reaction tells me something is really wrong... haha.

                Comment


                • #9
                  Well this is unfortunate. I still don't have a volume multiplier API after I:
                  - Uninstalled/reinstalled 4.18.2
                  - Created a new project
                  - Enabled the synthesis plugin
                  - Created a new blueprint and added a Media Sound component

                  To be overly verbose about my steps in case I'm doing something wrong, after opening the new BP I clicked the green "+ Add Component" button, typed "Media Sound" and selected that item. I then dragged that component into the event graph and dragged off its pin. When I type in 'volume' I see nothing related to audio (I do see some physics volume options).

                  Any ideas what else I could try?

                  Comment


                  • #10
                    Hmmmm. Try turning on the New Audio Engine. It's in Early Access right now. You can open the Editor with command line -audiomixer or any of the other methods described in the sticky thread.
                    Dan Reynolds
                    Technical Sound Designer || Unreal Audio Engine Dev Team

                    Comment


                    • #11
                      I think I have it enabled. Is there a way to know for sure if it's turned on?

                      Comment


                      • #12
                        Hi Ken_brueck,

                        You can check your output log by searching for the term "audiomixer" and you should see logs indicating the AudioMixer module has been used.

                        If you do not have the new Audio Engine enabled, then nothing will show up in the search.

                        Dan Reynolds
                        Technical Sound Designer || Unreal Audio Engine Dev Team

                        Comment


                        • #13
                          Thanks again Dan. It looks like audiomixer is enabled unless you see anything wrong with this:

                          LogAudioMixer: Display: Sample Rate: 48000
                          LogAudioMixer: Display: Callback Buffer Frame Size Requested: 1024
                          LogAudioMixer: Display: Callback Buffer Frame Size To Use: 1024
                          LogAudioMixer: Display: Number of buffers to queue: 1
                          LogAudioMixer: Display: Max Channels (voices): 0
                          LogAudioMixer: Display: Number of Async Source Workers: 4
                          LogAudioMixer: Display: Initializing audio mixer.

                          Comment


                          • #14
                            I am having the same issue. Trying to set the playback volume of a Media Sound component but nothing mentioned seems to work. Anything else to try?
                            CTO | Head of VR Development - Visit us at http://humanxr.com
                            My UE4 Tutorials (mostly VR): https://goo.gl/GUvDyV

                            Comment


                            • #15
                              I was never able to get a SetVolume command to appear, even on entirely different machines with entirely different 4.18 projects. If Dan hadn't been trying so hard to help in this thread I'd be convinced it just wasn't possible.

                              In the end, I stumbled through an awkward workaround using a SoundMix, a SoundClass, and a SoundMixClassOverride. SetSoundMixClassOverride has a volume input. I'm convinced it's all wrong, but I can at least change the volume of video now!

                              Comment

                              Working...
                              X