Announcement

Collapse
No announcement yet.

New Audio Engine: Quick-Start Guide

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hi Dan,

    Is there a way to control levels of submixes? I don't see any options on the submix itself and could not find any submix effect preset that would be able to do this too. It seems like very simple thing, I'm probably missing something. Please, any help would be much appreciated!!!

    'm actually trying to mute the sound coming from Audio Capture after recording it using submix recording. I've also tried to use Output to Bus Only option and setup Post/Pre effect bus sends but the sound doesn't seem to be getting to the submix attached to the sound source bus and the submix recording doesn't get anything.

    I'm also not really clear on how submixes are routing. Do I understand it correctly that if a sumbix is a child of another sumbix it will be routed through the parent one but if not then it goes directly to the master one?

    Thank you!

    Leave a comment:


  • replied
    It's been a while since I've worked with UE4 audio code, I'm surprised to see that the new mixer is still not enabled by default in 4.20. Can someone give or point to a brief status update on the system?
    I'm updating a plugin and wondering if it's safe at this point to assume that all future projects that will use it will be able to enable the mixer without issue. Has the mixer been implemented for all UE4 supported platforms now, including consoles?

    Leave a comment:


  • replied
    Has anyone had any luck with saving .wav files using Audio Capture in 4.20? I can get it to save as Sound Wave files, but just changing the export type (see attached) from Sound Wave to Wav doesn't work.

    Leave a comment:


  • replied
    Hi, is there any word on fixes for the new audio mixer freezing the editor? Or known solutions/causes? currently working in 4.19 on a 2017 MacBook Pro. I currently have the problem of freezing when i'm travelling between levels that utilise the modular synth components.

    Leave a comment:


  • replied
    Is there any way I could get the Audio Capture Component to work on Android? I would like to record my voice by SubMix from my phone/tablet, which I got working on PC but I can not get the Audio Capture to work on Android.

    Leave a comment:


  • replied
    Originally posted by JamesR View Post
    What are the current solutions to opening with -audiomixer, reading above didn't quite give me a process. I can Open the project from the folder the project is in using powershell with 'start projectname.uproject' but it doesn't like the immediate flag after. Can you set it in one of the .ini config files, it wasn't stated how. Thanks
    If you set up the ini file then you don't need to use the -audiomixer command line.

    You will also need to set up the ini file for packaging as the -audiomixer is only for auditioning within the Editor session.

    The ini file is platform dependent, so you'll need to look at the configuration referenced at the top of the Quick-Start instructions on how to set it up for your platform.

    Leave a comment:


  • replied
    What are the current solutions to opening with -audiomixer, reading above didn't quite give me a process. I can Open the project from the folder the project is in using powershell with 'start projectname.uproject' but it doesn't like the immediate flag after. Can you set it in one of the .ini config files, it wasn't stated how. Thanks

    Leave a comment:


  • replied
    Originally posted by dan.reynolds View Post

    Um, wow! That's a lot! Cool!



    If you go to your Project Settings and locate your Platform Settings, you'll find an Audio section. You'll want to increase the Max Number of Channels which is 32 by default.
    Dan THANK YOU! You're the greatest. LOVE the plugin so much

    Leave a comment:


  • replied
    Hi again,
    I still made a 2. synth project, just to be sure i made noting wrong.
    I get some weird issues, if i change the presets.

    Example: preset 1 is a simply synth without LFO or any patch used. Preset 2 i saved as preset with lfo patch to the filter. Preset 3 is a preset with LFO patch set to OSC1.
    Now, if i restart the synth, and go directly to a preset without play a note, then all 3 presets sounds like i made it and saved it.
    But if i play on preset 1, then switch to preset 2, and back to preset 1, the filter is messed up. If i switch to preset 3, and back to preset 1, the osc1 is messed up.
    Also the polyphon get lost, if i switch presets, then i hear noting, if i switch on the polyphony.

    It looks, like the synth need a reset or something, after switching the preset to an other one. I realy checket all the parameters, and code, and i cant find a issue i did. At least, the preset sound right, after restart the synth and going to the preset. Is there some thing i made wrong, or need to know, if i change presets while run time?

    If you want, i could make a download link for you, so you could test the synth with my project,
    Last edited by GAME3D; 08-02-2018, 10:45 AM.

    Leave a comment:


  • replied
    Originally posted by dan.reynolds View Post
    GAME3D, that looks great! Awesome!

    I'm not sure what's up with the Synth Knob. I would try wrapping it in its own Size Box or something.
    If you place this knop into a widget, you will see what i mean. It seems the ring get a wrong turn axis point. I tried out everything, but unfortunatly, i get it not working, how it should be.

    There hapen also other weird things, like if you have polyphon setup, and then switch between presets, it stop to generate sounds, if the polyphon is enabled. If you switch off polyphon then, it sounds again. I just make an other synth, to be sure i made noting wrong, and to see, if the issue occure again. But need to finish this, before i can test it again.

    Leave a comment:


  • replied
    GAME3D, that looks great! Awesome!

    I'm not sure what's up with the Synth Knob. I would try wrapping it in its own Size Box or something.

    Leave a comment:


  • replied
    Hi Dan, very much thanks for this synth tools and docu.
    I just created a mini synth with a virtual keyboard, and midi in so you can play the synth trough a keayboard. It is possible to setup all parameters into a widget much userfriendly and it is possible to play it like a real synth. I'm so happy how this thing is working and also how it sounds. The idea is, that you can play the synth like real, and also have a tool to make the sound banks and presets, so it can be used in games, or what ever you want.

    I had one week to create this synth widget and actor, just about all the sliders and all this. Too bad the the synth knop is broken. the middle ring move some where , but just not in the middle So i used sliders for the knops. Just a question. Is this a bug on the synth knop in widget's, or did i some thing wrong?
    Attached Files
    Last edited by GAME3D; 07-27-2018, 11:58 PM.

    Leave a comment:


  • replied
    Originally posted by Shempii View Post
    dan.reynolds Hi there Dan! I've been having a lot of fun with this system and I just wanted to say thanks. Really cool work, I'm working on a really neat project with it in VR, I'd love to show you some day

    I just ran into a little hiccup and I'm wondering if you have an answer. This project requires that I am able to have many different synth components in a level. I was pleasantly surprised by how performant they seem all things considered!

    My issue is that, when I have 38+ synth components playing periodically (38 is ballpark, and it might not be the same every time, this was a cursory test to give you an estimate) it seems that with each subsequent component I spawn, it pushes the oldest one out. Like a First In/First Out situation. I hope that makes sense. I have set them to play in a loop, and right around once I've added the 38th synth component, the 1st synth component will stop playing. The 39th new synth component will cause the 2nd to stop playing and so on...

    I recognize that 38 sounds like a LOT but without getting too in the weeds on what my project is, it requires the ability to spawn and have many synths existing (and potentially playing) at once.

    Is there some variable that can be changed in a config to remove this limit? Or is this not an intentional limit? I'd like to know more about it because while I am still able to fully test and play with this tool I'm making currently, in a perfect world there would be no limit to the number of synth components I could have playing at once (besides my poor computer's limit of course).

    Thanks again for all the hard work that went into this. I can't wait to start seeing the creative ways that people use your plugin!

    - arj
    Um, wow! That's a lot! Cool!



    If you go to your Project Settings and locate your Platform Settings, you'll find an Audio section. You'll want to increase the Max Number of Channels which is 32 by default.

    Leave a comment:


  • replied
    dan.reynolds Hi there Dan! I've been having a lot of fun with this system and I just wanted to say thanks. Really cool work, I'm working on a really neat project with it in VR, I'd love to show you some day

    I just ran into a little hiccup and I'm wondering if you have an answer. This project requires that I am able to have many different synth components in a level. I was pleasantly surprised by how performant they seem all things considered!

    My issue is that, when I have 38+ synth components playing periodically (38 is ballpark, and it might not be the same every time, this was a cursory test to give you an estimate) it seems that with each subsequent component I spawn, it pushes the oldest one out. Like a First In/First Out situation. I hope that makes sense. I have set them to play in a loop, and right around once I've added the 38th synth component, the 1st synth component will stop playing. The 39th new synth component will cause the 2nd to stop playing and so on...

    I recognize that 38 sounds like a LOT but without getting too in the weeds on what my project is, it requires the ability to spawn and have many synths existing (and potentially playing) at once.

    Is there some variable that can be changed in a config to remove this limit? Or is this not an intentional limit? I'd like to know more about it because while I am still able to fully test and play with this tool I'm making currently, in a perfect world there would be no limit to the number of synth components I could have playing at once (besides my poor computer's limit of course).

    Thanks again for all the hard work that went into this. I can't wait to start seeing the creative ways that people use your plugin!

    - arj

    Leave a comment:


  • replied
    Great! I'll take a look at that =)! Thanks

    Leave a comment:

Working...
X