Announcement

Collapse
No announcement yet.

New Audio Engine: Quick-Start Guide

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    It's worth noting that for me the component did not have "auto activate" on by default, so no sound played.

    Comment


      Hi, I am trying to dynamically change the source effect settings with blueprints and the set settings node doesn't seem to be working for me. It seems that someone else has experienced a problem with this but I couldn't seem to find an answer. https://answers.unrealengine.com/que...dToView=925369

      any help or information is greatly appreciated
      Attached Files

      Comment


        Originally posted by RianStephens View Post
        Hi, I am trying to dynamically change the source effect settings with blueprints and the set settings node doesn't seem to be working for me. It seems that someone else has experienced a problem with this but I couldn't seem to find an answer. https://answers.unrealengine.com/que...dToView=925369

        any help or information is greatly appreciated
        What engine version is it? There was a temporary bug about this around 4.21 or so, but it's been fixed for a few versions!
        Try my procedural music tools: Arthurs Audio BPs

        Comment


          Hi, I'm trying to build a basic system to animate the mouth of my characters using the envelope follower.

          If I just have one character in a scene it works well, but if I have more than one then they all move their mouths together because they all use the same envelope follower preset.

          Is there a way I can automatically create a new envelope follower for each character? There's no limit to how many characters can be in a scene so all I can think of is to create a new one for each character like I am trying to do in this image, but it doesn't work at all!


          Click image for larger version

Name:	Annotation-20191106-141810.jpg
Views:	512
Size:	274.6 KB
ID:	1683399

          Comment


            Originally posted by anti_zer0 View Post
            Hi, I'm trying to build a basic system to animate the mouth of my characters using the envelope follower.

            If I just have one character in a scene it works well, but if I have more than one then they all move their mouths together because they all use the same envelope follower preset.

            Is there a way I can automatically create a new envelope follower for each character? There's no limit to how many characters can be in a scene so all I can think of is to create a new one for each character like I am trying to do in this image, but it doesn't work at all!


            Click image for larger version

Name:	Annotation-20191106-141810.jpg
Views:	512
Size:	274.6 KB
ID:	1683399
            Instead of using the Envelope Follower Source Effect, you can use the Envelope Follower Delegate that is available on each Audio Component. Your two characters just need to be speaking on separate Audio Components. For lip-flap implementation, you can just put an Audio Component on the head/face/mouth of each of your characters and use that Audio Component to drive your lip-flap. Then just make sure you play all your dialog sounds on that Audio Component.
            Dan Reynolds
            Technical Sound Designer || Unreal Audio Engine Dev Team

            Comment


              Originally posted by dan.reynolds View Post

              Instead of using the Envelope Follower Source Effect, you can use the Envelope Follower Delegate that is available on each Audio Component. Your two characters just need to be speaking on separate Audio Components. For lip-flap implementation, you can just put an Audio Component on the head/face/mouth of each of your characters and use that Audio Component to drive your lip-flap. Then just make sure you play all your dialog sounds on that Audio Component.
              That's exactly the answer I needed, thank you so much!! I didn't realise it was possible to use the envelope follower this way.

              Comment


                has this changed? I enabled both sound utilities and the synthesis plugins, restarted, and I have no option to create sound submix files

                Comment


                  Originally posted by crossmr View Post
                  has this changed? I enabled both sound utilities and the synthesis plugins, restarted, and I have no option to create sound submix files
                  Which Engine Version?
                  Dan Reynolds
                  Technical Sound Designer || Unreal Audio Engine Dev Team

                  Comment


                    Originally posted by mhnoni View Post
                    Hello @dan.reynolds ,
                    I noticed when you use the new audio engine you get another section on CPU profiling called "audioMixerRenderThread(1)" and this section takes a lot of ms, it takes ~ 7 ms on android but somehow its not affecting the performance does that mean they made audio engine work on different thread?

                    Another question, how can I disable Master Reverb and Master EQ on the new audio engine? as you can see its taking 6 ms even though I checked the box for "disable EQ" on project setting and I unchecked the box for effect and Reverb on my audio master sound class.
                    3rd and last question, what is "apply effects" on attached image regarding master sound class?
                    Thanks
                    Anyone know how to fix this? I've run into the same problem.

                    I've tried disabling it in the Audio section of Project Settings
                    I've unchecking Use Reverb in World Settings for each level and sublevel
                    I've looked at the master submix and other submixes, unchecking reverb.
                    I've tried au.DisableReverbSubmix

                    nothing seems to disable it

                    I just want to completely disable the Master Reverb since we're not using it
                    (This is on 4.22)
                    Last edited by Jesse.LeBlanc; 07-15-2020, 03:49 AM.

                    Comment


                      Originally posted by Jesse.LeBlanc View Post

                      Anyone know how to fix this? I've run into the same problem.

                      I've tried disabling it in the Audio section of Project Settings
                      I've unchecking Use Reverb in World Settings for each level and sublevel
                      I've looked at the master submix and other submixes, unchecking reverb.
                      I've tried au.DisableReverbSubmix

                      nothing seems to disable it

                      I just want to completely disable the Master Reverb since we're not using it
                      (This is on 4.22)
                      Hi Jesse,

                      au.DisableReverbSubmix is a cvar which can be valued at 0 (false) or 1 (true).

                      I suggest setting au.DisableReverbSubmix to 1 like so:

                      Code:
                      au.DisableReverbSubmix 1
                      You can learn more about cvars here:
                      https://docs.unrealengine.com/en-US/...ger/index.html
                      Dan Reynolds
                      Technical Sound Designer || Unreal Audio Engine Dev Team

                      Comment

                      Working...
                      X