Announcement

Collapse
No announcement yet.

New Audio Engine: Early Access Quick-Start Guide

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by dan.reynolds View Post
    GAME3D, that looks great! Awesome!

    I'm not sure what's up with the Synth Knob. I would try wrapping it in its own Size Box or something.
    If you place this knop into a widget, you will see what i mean. It seems the ring get a wrong turn axis point. I tried out everything, but unfortunatly, i get it not working, how it should be.

    There hapen also other weird things, like if you have polyphon setup, and then switch between presets, it stop to generate sounds, if the polyphon is enabled. If you switch off polyphon then, it sounds again. I just make an other synth, to be sure i made noting wrong, and to see, if the issue occure again. But need to finish this, before i can test it again.

    Comment


      Hi again,
      I still made a 2. synth project, just to be sure i made noting wrong.
      I get some weird issues, if i change the presets.

      Example: preset 1 is a simply synth without LFO or any patch used. Preset 2 i saved as preset with lfo patch to the filter. Preset 3 is a preset with LFO patch set to OSC1.
      Now, if i restart the synth, and go directly to a preset without play a note, then all 3 presets sounds like i made it and saved it.
      But if i play on preset 1, then switch to preset 2, and back to preset 1, the filter is messed up. If i switch to preset 3, and back to preset 1, the osc1 is messed up.
      Also the polyphon get lost, if i switch presets, then i hear noting, if i switch on the polyphony.

      It looks, like the synth need a reset or something, after switching the preset to an other one. I realy checket all the parameters, and code, and i cant find a issue i did. At least, the preset sound right, after restart the synth and going to the preset. Is there some thing i made wrong, or need to know, if i change presets while run time?

      If you want, i could make a download link for you, so you could test the synth with my project,
      Last edited by GAME3D; 08-02-2018, 10:45 AM.

      Comment


        Originally posted by dan.reynolds View Post

        Um, wow! That's a lot! Cool!



        If you go to your Project Settings and locate your Platform Settings, you'll find an Audio section. You'll want to increase the Max Number of Channels which is 32 by default.
        Dan THANK YOU! You're the greatest. LOVE the plugin so much

        Comment


          What are the current solutions to opening with -audiomixer, reading above didn't quite give me a process. I can Open the project from the folder the project is in using powershell with 'start projectname.uproject' but it doesn't like the immediate flag after. Can you set it in one of the .ini config files, it wasn't stated how. Thanks

          Comment


            Originally posted by JamesR View Post
            What are the current solutions to opening with -audiomixer, reading above didn't quite give me a process. I can Open the project from the folder the project is in using powershell with 'start projectname.uproject' but it doesn't like the immediate flag after. Can you set it in one of the .ini config files, it wasn't stated how. Thanks
            If you set up the ini file then you don't need to use the -audiomixer command line.

            You will also need to set up the ini file for packaging as the -audiomixer is only for auditioning within the Editor session.

            The ini file is platform dependent, so you'll need to look at the configuration referenced at the top of the Quick-Start instructions on how to set it up for your platform.
            Dan Reynolds
            Technical Sound Designer || Unreal Audio Engine Dev Team

            Comment


              Is there any way I could get the Audio Capture Component to work on Android? I would like to record my voice by SubMix from my phone/tablet, which I got working on PC but I can not get the Audio Capture to work on Android.

              Comment


                Hi, is there any word on fixes for the new audio mixer freezing the editor? Or known solutions/causes? currently working in 4.19 on a 2017 MacBook Pro. I currently have the problem of freezing when i'm travelling between levels that utilise the modular synth components.

                Comment


                  Has anyone had any luck with saving .wav files using Audio Capture in 4.20? I can get it to save as Sound Wave files, but just changing the export type (see attached) from Sound Wave to Wav doesn't work.

                  Comment


                    It's been a while since I've worked with UE4 audio code, I'm surprised to see that the new mixer is still not enabled by default in 4.20. Can someone give or point to a brief status update on the system?
                    I'm updating a plugin and wondering if it's safe at this point to assume that all future projects that will use it will be able to enable the mixer without issue. Has the mixer been implemented for all UE4 supported platforms now, including consoles?

                    Comment


                      Hi Dan,

                      Is there a way to control levels of submixes? I don't see any options on the submix itself and could not find any submix effect preset that would be able to do this too. It seems like very simple thing, I'm probably missing something. Please, any help would be much appreciated!!!

                      'm actually trying to mute the sound coming from Audio Capture after recording it using submix recording. I've also tried to use Output to Bus Only option and setup Post/Pre effect bus sends but the sound doesn't seem to be getting to the submix attached to the sound source bus and the submix recording doesn't get anything.

                      I'm also not really clear on how submixes are routing. Do I understand it correctly that if a sumbix is a child of another sumbix it will be routed through the parent one but if not then it goes directly to the master one?

                      Thank you!

                      Comment


                        Originally posted by Illia Statkevych View Post
                        a way to control levels of submixes?
                        An EQ submix preset with just the single default band and settings below should do it!

                        freq = doesn't matter
                        bandwith = max(10)
                        gain = min(-90)

                        Using a dynamics processor-submix, you could also set it to gate mode, and tune your threshold so nothing ever gets past it.

                        edit: oh and when I was last setting up source buses and sends, there was sometimes some stuff that needed an editor restart to work(i think). So maybe don't try too much bughunting, rather do it by the book, then restart before final tests. I got it all working in 4.20.3.
                        Last edited by ArthurBarthur; 10-05-2018, 07:35 AM.

                        Comment


                          Originally posted by GAME3D View Post
                          Hi again,
                          I still made a 2. synth project, just to be sure i made noting wrong.
                          I get some weird issues, if i change the presets.
                          (...)
                          Is there some thing i made wrong, or need to know, if i change presets while run time?
                          What does your code or BPs look like? How and where are you feeding the synth with current/new presets? I usually do it on tick, since that's needed for dynamic gliding parameter changes.

                          Comment


                            Originally posted by ArthurBarthur View Post

                            An EQ submix preset with just the single default band and settings below should do it!

                            freq = doesn't matter
                            bandwith = max(10)
                            gain = min(-90)
                            Thank you Arthur!

                            My mistake was that I was using Sends but I wasn't setting submix so EQ preset with the settings was making it quieter but I could still hear myself as it was sending the capture to the master I assume. Setting up both Sound Submix and Sound Submix Sends on Audio Capture seems to do the job.

                            Comment


                              Illia Statkevych, I would not recommend using Submixes to do volume adjustment because there are several optimizations already done for logical volume adjustments on sources. So using a more traditional approach will probably be a more useful/cheaper method.

                              With that said, if you are working in a C++ project, and you say Add New C++ Class and add a new Submix Effect, then the template codegen for the starter Submix Effect actually generates a simple Volume Gain scale effect.
                              Dan Reynolds
                              Technical Sound Designer || Unreal Audio Engine Dev Team

                              Comment


                                Originally posted by Lachlan Powell View Post
                                Hi, is there any word on fixes for the new audio mixer freezing the editor? Or known solutions/causes? currently working in 4.19 on a 2017 MacBook Pro. I currently have the problem of freezing when i'm travelling between levels that utilise the modular synth components.
                                Hi Lachlan, I believe this bug was fixed in 4.20.
                                Dan Reynolds
                                Technical Sound Designer || Unreal Audio Engine Dev Team

                                Comment

                                Working...
                                X