Announcement

Collapse
No announcement yet.

Hidden actor + Hidden Shadow on translucent material not working?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I'm not on my computer but there are 2 settings you can try as I remember: Cast hidden shadow and cast shadow as being opaque. I can try to find this tomorrow. Btw if it is hidden in game, why does it need to be translucent? Can't it be opaque and hidden?

    Leave a comment:


  • replied
    Sorry to resurrect this, but it's the top relevant link that came up when I was googling the exact same issue. When the translucent object is visible, it casts translucent shadows just fine, and if I swap the material to be opaque, it casts hidden shadows fine as well, but translucent shadows + hidden in game fails to create any shadows.

    I'm not sure if translucent shadows being unable to work with the 'cast hidden shadows' and 'hidden in game' features enabled is a fixable bug or a rendering limitation that can't be rectified.

    Leave a comment:


  • Hidden actor + Hidden Shadow on translucent material not working?

    Hey,

    I have this object that I want to hide, but I want it's shadow to remain visible. I wanted to use a translucent material on this (to give it a nice soft shadow). I have done the following:

    On object: Hidden Shadow and Volumetric translucent shadow (with VMS on or off it still doesn't work)
    Actor hidden in game: True

    When I load a non-translucent material on it it works when it's flagged as hidden in game with hidden shadow on it. Is there a way to get this to work, or can this feature be added to UE4? We need this for window shading/screens to be rendered nicely in-game. Or is there another way to do this?

    Thanks!
    - Wesley
Working...
X