Announcement

Collapse
No announcement yet.

Shadow casting onto translucent objects?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadow casting onto translucent objects?

    Hey,

    I've made some solar screens using a translucent material setup, 2 sided, that can be placed onto windows. But my translucent material doesn't receive any shadowing. It works to make it cast shows, that's not the issue. I quickly made a test level and screenshot to visualize what I'm after. Basically I want the nice shadow to be on the screen as well if that's possible or not? Now it looks weird to see a dynamic shadow go over the building facade but the solar screen doesn't show that shadow line either. When I turn on the option "volumetric translucent shadow" I get the result seen in the screenshot below. The red lines show what the chair shows would be if it were working accurately. Can anyone help out with this, is it even possible?

    Thanks!

    Click image for larger version

Name:	tranlucency_shadows.jpg
Views:	1
Size:	94.2 KB
ID:	1196495

    #2
    Is it possible to do this even? Anyone, or is my question not explained well enough? I'm a bit stuck on this atm, if it's not possible I'll remove my window screen

    Comment


      #3
      Did you ever found a solution for this? 2019 and shadows on translucent Objects is still impossible?

      Comment


        #4
        Originally posted by SebaSopp View Post
        Did you ever found a solution for this? 2019 and shadows on translucent Objects is still impossible?
        Hey,
        I haven't looked into this since I posted it, we never found a solution for this no :/
        I guess it's a limitation of the software at this point? Perhaps this post should be sent to Epic to investigate?

        - Wesley

        Comment


          #5
          Translucent materials use a different render pipeline than opaque materials. You should only use translucent materials when it is really necessary because they are relative expensive to render and have limitations. I don't see your material being translucent. So maybe use a standard material for this. This also would make the object receive shadows.

          I'm not sure if translucent objects receive any shadows in the real world. It also depends on your roughness. If it is very low it might just reflect everything back so effectively appears to not receive any shadow.

          I'm not the super guru when it comes to materials. But with unreal you need to do some tricks to get some things look better. You can't always try to replicate reality like you do in standard arch viz. Sometimes you need to use a bit of creativity to get the same look. It doesn't matter how you get there as long as the result looks similar to reality.

          You can get pretty good looking translucent objects with these settings. - Please ignore the "Use Material Attributes" flag in the image:

          Click image for larger version

Name:	translucentmaterial03.JPG
Views:	58
Size:	42.6 KB
ID:	1612334

          Here is a bowl in a scene I made. - Please ignore the low res shadow on the walls and cupboard

          Click image for larger version

Name:	translucentmaterial01.JPG
Views:	57
Size:	89.5 KB
ID:	1612335

          translucent objects by default don't cast any shadow. I added a copy of the bowl and set it to "hidden in game". The copy has a standard material and casts a shadow for the translucent object. In the editor it looks like that unless you switch to game mode. Then the beige bowl disappears.

          Click image for larger version

Name:	translucentmaterial02.JPG
Views:	58
Size:	152.0 KB
ID:	1612336
          www.s-dot.de/viz
          ArchViz User Interface :: UE4 Marketplace.

          Comment

          Working...
          X