Announcement

Collapse
No announcement yet.

UE4 not responding during bake with "high" settings (.ini tweak)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4 not responding during bake with "high" settings (.ini tweak)

    Hello everyone!

    I hope this is the proper place to post this issue, since it's very related to ArchViz and specific tweaks in the .ini file.

    I'm working on a project and I'm getting very close to finishing, and I wanted to improve the light quality, so I decided to tweak the .ini file following Raghu's feedback , no, I did not increment the values, I used a bit of brute force.

    PC Specs:
    i7-5960X
    64GB Ram
    2x GTX 980 Ti

    The computer is in the office and I leave it on during the night for the long bakes, and for the second time now, when I go afk, UE4 stops responding during these bakes, it doesn't crash, it just stops responding. Not swarm however, it keeps working with no problem, but of course, in the end, it was all wasted time, UE4 doesn't recover and closes itself.

    The scene could be optimized. I have some 4k maps that could become 2k, and some 2k maps that could become 1k, I have a total of 4.3M polygons. The largest lightmap is 2048, everything else is 1024 and bellow. I don't even know where to begin addressing this issue and it would be nice to know if someone had this problem and found a solution for it, or detect its origin.

    Please let me know if I can provide more information.

    Thanks in advance
    - John


    Edit: Forgot to mention, I have tested 2 or 3 times in preview settings, keeping Static Lghting Level Scale at 0.25 and also at 1 with no problem. I'm testing medium settings and it always crashed with production settings.
    Last edited by Valthrudnir; 09-20-2016, 04:32 AM.

    #2
    Are you running out of ram during the baking process (is your coumputer using 64GB out of 64GB when it crashes)?

    Comment


      #3
      No, it uses a small fraction of the total amount of Ram, if I recall correctly, it doesn't even get to 12GB

      Comment


        #4
        Alright, it happened again without tweaking the .ini file, in production quality.

        I'm using one computer and Swarm displayed a reapeating message saying "Swarm coordinator is not coordinating", while UE4 remained in a "not responding" state.

        So, I'm wondering if UE4 stops responding when the light bake is finished and it tries to import the new maps, I'll look into it.

        Comment


          #5
          I don't know if it's related, but did you perhaps deactivate texture streaming? I had a similar problem, reactivating it only in baking process solved my problem.

          Comment


            #6
            So you are using a swarm coordinator to distribute the bake to other computers? What does it say in the log tab? (Double click the swarm agent icon in the system tray).
            You can also try to ping the coordinator and the blades in the menu -> Network there. Check it in the log tab again.
            When ever something weird happens it sometimes helps to clean out the cache. Go to Cache -> Clean.

            Most likely it might just be too much data and too big light maps. I had it hanging when we just had too big light maps everywhere. Have you got any messages before the light build kicks off? See if there is something in the list that might stop it from baking. I personally never change the settings in the ini file and I don't get bad results. Production is already a high setting so probably try to start a "Production bake" with normal ini settings and see how it looks.

            In my projects I hardly ever set any light map higher than 1024. For furniture pieces probably never higher than 256. It's more about the quality of the light map. If you have connected charts "around a corner" setting the light map to 4096 will not fix it. You need to fix the light map itself.

            Finally another thought: Are you using 4.11? There was a bug where the editor would crash after building the lighting when you had a level hidden.
            www.s-dot.de/viz
            ArchViz User Interface :: UE4 Marketplace.

            Comment


              #7
              Originally posted by Koolhass View Post
              I don't know if it's related, but did you perhaps deactivate texture streaming? I had a similar problem, reactivating it only in baking process solved my problem.
              I don't think it's related, where's that option besides in matinee? I had to increase the texture streaming pool size for matinee, but I'd say it's irrelevant for the light baking, as I only touched those settings after "giving up" and doing a High quality bake for 3.5H.


              Originally posted by S-Dot View Post
              So you are using a swarm coordinator to distribute the bake to other computers? What does it say in the log tab? (Double click the swarm agent icon in the system tray).
              You can also try to ping the coordinator and the blades in the menu -> Network there. Check it in the log tab again.
              When ever something weird happens it sometimes helps to clean out the cache. Go to Cache -> Clean.

              Most likely it might just be too much data and too big light maps. I had it hanging when we just had too big light maps everywhere. Have you got any messages before the light build kicks off? See if there is something in the list that might stop it from baking. I personally never change the settings in the ini file and I don't get bad results. Production is already a high setting so probably try to start a "Production bake" with normal ini settings and see how it looks.

              In my projects I hardly ever set any light map higher than 1024. For furniture pieces probably never higher than 256. It's more about the quality of the light map. If you have connected charts "around a corner" setting the light map to 4096 will not fix it. You need to fix the light map itself.

              Finally another thought: Are you using 4.11? There was a bug where the editor would crash after building the lighting when you had a level hidden.

              I'm sorry if I wasn't clear about this. I'm using a single computer, the "coordinator" thing is just because of the message Swarm was displaying, because UE4 was not responding, I assume it's its way of saying it doesn't have instructions on how to finish the process apply the lightmaps and so on. I was using 4.12.5 and this week I'm doing the same with 4.13.

              I forgot a bit about this post, but let me give you an update, I reverted the changes on the .ini file (default settings), the problem remains, AND it happened again when I simply left the computer idle during lunch time (it wasn't baking or anything), and the same thing happened, UE4.exe was not responding (everything else was fine, autocad, photoshop, browser, etc.). I can't know for sure that the problem is related to UE4. It happens when the computer stays idle, even with the proper energy settings, no sleeping mode, etc.

              Right now I'm thinking about doing a clean OS install (inclined to windows 7) and hoping for the problem to go away.


              Edit: I have 2x 2048 maps for the floor, those are the highest.


              Edit 2: This post is no longer relevant as it doesn't illustrate the problem I'm having correctly. The problem is "UE4 stops responding if the computer goes idle".
              Last edited by Valthrudnir; 09-26-2016, 09:01 AM.

              Comment


                #8
                Try cleaning the cache in lightmass if you haven't already. That might help. If lightmass crashes or hangs. The first thing you do is cleaning the cache. I'm pretty sure it's a lightmass thing and not a general unreal problem.

                If cleaning the cache doesn't work then try building level by level (if you have sublevels) to find out which level is that causing a problem.
                Or go delete half of your meshes and try to build and then try to build the other half until you find the asset that causes the problem. It can be hideous.

                We had someone here scaling a high polygon bed throw (300.000 verts) down to 0.01 so he could use it as a tissue. That caused lightmass to crash surprisingly - What I am trying to say is that lightmass does work in general. So you may need to find out which of your assets causing it to not work for this scene. If it works in other scenes for you.

                Comment


                  #9
                  Also, write yourself (or buy) the plugin that scales the lightmap resolution based on the scene size/UV size to maintain your sanity.
                  George Rolfe.
                  Technical Coordinator at Orbit Solutions Pty Ltd.

                  Comment

                  Working...
                  X