Announcement

Collapse
No announcement yet.

Issue with lights (build light)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issue with lights (build light)

    Hi guys,

    I'm kind of a newbie with this and I'm having some problems with the lights in the scene. All the lights are static (otherwise some wouldn't work), and the build is only a preview, however in a production build the result is the same.

    I would like to know why these lights aren't calculated and why the light spread disappears. I'm posting screenshots so you can understand better the issues I'm dealing with.

    This is before the build (or bake)
    Click image for larger version

Name:	before_buildlights.jpg
Views:	1
Size:	264.0 KB
ID:	1182763

    This is after.
    Click image for larger version

Name:	after_buildlights.jpg
Views:	1
Size:	215.7 KB
ID:	1182764

    I appreciate all the feedback I can get, so thanks

    #2
    Did you try cranking up the light level and build the lighting? They look like they're on. I think 4.11 has some big bugs in my tests.

    Comment


      #3
      I'm guessing either your lightmap resolution is too low, or the lightmap UV's need to be reworked.

      Comment


        #4
        I tried all of that and the lightmap resolution is up to 512.

        Regarding the lightmap UV's it seems strange cause there are a lot of different objects and none of them calculates the light correctly.

        However there is an error that happens and that constantly requires that I clear the lightmaps, but that only happens if I do two builds in a row. In mapcheck I get "WorldSettings_1 Maps need lighting rebuilt", which I do. I clear the lightmaps and I build the lights again... and the problem disappears... until the next time .

        Comment


          #5
          One thing I noticed which may be a bug is when I had ambient occlusion on my entire scene was very dark. Do you have it on?

          Comment


            #6
            Yes I have it on, but it's only at 0.3.

            Less than this and it probably won't calculate anything. But I tried it with 0.1 and the result was the same.

            The thing that is bugging me is that it seems that the light isn't baking correctly in the textures. The spotlights loses their highlights and subsequent shadows. I even increased the spotlights values because I was considering the dimming of the light in the bake, but it still doesn't stick.

            Comment


              #7
              Turn off AO completely and try again? Can you post your Lightmass settings for people to see?

              Comment


                #8
                Sure,

                This is my current Lightmass settings.

                Click image for larger version

Name:	Lightmass_settings.jpg
Views:	1
Size:	125.1 KB
ID:	1106942

                I had to reduce the indirect bounces because the metalic grid and the light bouncing in it generated a red glow.

                Thx

                Comment


                  #9
                  Hey guys,

                  This isnĀ“t getting any better. It's getting worse. I tried no occlusion, and it got eve worse. And the spotlights/lights aren't baking. Is there a limit to the number of static spotlights in a scene?

                  Click image for larger version

Name:	build.JPG
Views:	1
Size:	162.9 KB
ID:	1106953


                  And something strange happened. I gave this to a friend to create a build for Vive and with him the light bake worked.

                  Comment


                    #10
                    Have you tried copying your scene to a new project? I'm not sure exactly how to do it at the moment because I'm not at my UE4 PC, but it seems like it might be a good solution if your friend was able to build the lighting without problem. There has to be some forum posts explaining how to do it.
                    James Gallagher

                    Architectural Technologist, P3Architecture Partnership

                    Comment


                      #11
                      I haven't completed the migration, but I've copied the content and tried out some objects and the map check errors still continues and it seems that some of my objects aren't building the shadows correctly.

                      I've managed to complete a correct light build by lowering the lightmap resolution of the objects, and tweaking with some properties like "indirect lighting smoothness" and bounces. May this have anything to do with my rig? I have an old I7 with 8 threads at 3.4Ghz and a 970 GTX.

                      I would to polish the shadows and the lights but since this is so unstable I'm reluctant.

                      Comment


                        #12
                        maybe try upgrading to 4.11.2 if you haven't already? it might be worth a shot

                        Comment


                          #13
                          I think I would strip out all of the lights and put just one in and build the lighting, then add another and build. Once you have established it's building okay try adding the rest.

                          Comment


                            #14
                            It's worth a try. I'll get back to you with some results.

                            I guess it will work to a degree but what if I need more lights.

                            Comment


                              #15
                              Originally posted by PDantas View Post
                              It's worth a try. I'll get back to you with some results.

                              I guess it will work to a degree but what if I need more lights.
                              I don't think there is a limit to static lights? Correct me if I'm wrong. Right now this should be about trouble shooting your scene then you can reach out to Epic for help once you hit the wall.

                              Comment

                              Working...
                              X