Announcement

Collapse
No announcement yet.

Problem with Archicad to Unreal Engine

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with Archicad to Unreal Engine

    so, i have done an archicad project and i exported it to cinema 4d and from cinema 4d with fbx to unreal engine...now all the things were okay but expect collisions...so for example i get the collisions of the house as a box... i tried removing the collisions and doing it again with the others way but always the same...so i cant get in the house as a problem that is a blocking volume... i know i can disable it and and create my own blocking volume...but isn't there a easy way to generate collisions inside the house without doing it by yourself because it takes a lot of time...i opened a video which said that it can be fixed if you seperate the objects like walls and doors...but he was doing that on a map and i am working on a high detailed house so i cant get 3000objetcs in one group (in cinema4d the objects are mixed with the others so you cant find them by name plus the names are numbers) so if you have any suggestion about my problem please help! plus this would make a easier work for all who use archicad

    article about archicad to 3ds
    http://helpcenter.graphisoft.com/tip...odesk-3ds-max/

    video that i found
    https://www.youtube.com/watch?v=TExix3wfICg

    Click image for larger version

Name:	problem1.png
Views:	1
Size:	719.3 KB
ID:	1179972
    this is how it appears on unreal engine

    archicad export options
    Click image for larger version

Name:	scr1.png
Views:	1
Size:	734.2 KB
ID:	1179970

    Click image for larger version

Name:	scr2.png
Views:	1
Size:	525.9 KB
ID:	1179971

    #2
    AFAIK there is no quick and easy way to do collision on groups of objects. Adding blocking volumes through the viewport is mostly likely the easiest way for you. I applied all my collision this way in my last project. Just make sure you check all of the walls and make sure you cannot walk through them after!
    | QuinnVR | Portfolio | Twitter |

    Comment


      #3
      And i am having some big problems like light issues and shadows issues...if I open shadows on low setting(THIS HAPPENS ONLY WITH SHADOWS, if i set shadows to none everything works fine even with other settings set to ultra) my whole projects starts to get laggy and its impossible to work meanwhile i have a heavy project made in UE4 and with high setting it runs smooth

      Comment


        #4
        You need to split that up into many pieces, and then if there's anything that's used multiple times you need to import them individually and place them in UE4 so that they can reduce the memory.

        Comment


          #5
          Yet alone having a model with over 1 million Vertices is insane.
          Archicad models are far from being gameready optimized and you should avoid using them without proper cleanup. Not even for ArchVis.

          Importing the whole scene as one Object makes it impossible to edit anything in UE4 and drastically reduces the effect of many automated performance optimisations of the engine.
          (Your chair could be a tad more to the right? Great exporting and importing again)
          Beside that it will always be static and don't have any possibilities of interaction even with a working collision model.
          Which would also have to consist of a far higher ammount of CM pieces for a half way decent collision.

          Automatic collission building will never work for such an object.
          Even with the highest possible precission and number of chunks, the CM bulder wouldn't know which geometry needs collision and which not or only basic primitives.
          So your best bet is to manually build collision or have such a simple shape that per vertex collision is also performance friendly.

          How to do that? You may ask.
          Luckly i allready have examples for this kind of stuff:
          http://www.mediafire.com/download/ii...usebuilder.zip
          Note that the fbx 6.1 (2010) exporter in C4D R17.048 is far better suited for transfering models to UE4, but this model was done way before i knew this, so it was exported with fbx 7.4 before the .048 update.
          If you wanna try the import yourself, maybe use the C4D file and export with fbx 6.1.

          And here's a Preview of this in UE 4.10.4:
          http://www.mediafire.com/download/ft...9y/TestEnv.zip
          Just a quick&dirty setup. If you allready have 4.11 try to place Portal actors in the windows.
          According to the feature list of 4.11 they improve lighting quality from skylights in indoor areas.

          Comment

          Working...
          X