Announcement

Collapse
No announcement yet.

some serious lightmass issues. 4.10 & 4.11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    some serious lightmass issues. 4.10 & 4.11

    so i haven't the faintest idea what's going on. i've been working on this scene on and off for more than 2 weeks. as of yesterday - lightmass resolution seems to come and go at its own will. in some cases - if i zoom close - it'll clean up - other times - no changes at all!

    is it the amount of geomtry added to the scene - lightmass comp times? just asking - because my scene has been building up in that regard. also - this is an arch-viz scene (i'm only stating that because i normally work with lo-poly baked assets where this hasn't been an issue)

    i'm running an intel 1-5-4690 @ 3.5 ghz
    16 gig ram
    nvidia geforce gtx 960

    my lightmass settings are below. i've been bumping up my lightmass resolution on various assets - but it seems to not make any difference. is it something i'm missing in lightmass settings?

    your input is greatly appreciated - i'll pulling my hair out!! i started this project in 4.10 - then moved it over to the latest build 4.11 - no improvement..

    Click image for larger version

Name:	ue4_lm_20160401_001.JPG
Views:	1
Size:	43.9 KB
ID:	1179494

    Click image for larger version

Name:	ue4_lm_20160401_002.JPG
Views:	1
Size:	117.4 KB
ID:	1179495

    here are some scene shots..

    Click image for larger version

Name:	HighresScreenshot00009.jpg
Views:	1
Size:	162.4 KB
ID:	1179496

    Click image for larger version

Name:	HighresScreenshot00006.jpg
Views:	1
Size:	508.9 KB
ID:	1179497

    Click image for larger version

Name:	HighresScreenshot00007.jpg
Views:	1
Size:	440.4 KB
ID:	1179498

    Click image for larger version

Name:	HighresScreenshot00010.jpg
Views:	1
Size:	482.3 KB
ID:	1179499

    Click image for larger version

Name:	HighresScreenshot00011.jpg
Views:	1
Size:	332.4 KB
ID:	1179500

    Click image for larger version

Name:	HighresScreenshot00007.jpg
Views:	1
Size:	440.4 KB
ID:	1179498

    #2
    That's really odd, there's no way you'd need 512 lightmap resolution on that door. How are they modeled? and what do the UVs look like?
    James Gallagher

    Architectural Technologist, P3Architecture Partnership

    Comment


      #3
      maybe your streaming memory pool is too low? That happened to me sometimes.

      try that command in your console/output log r.streaming.poolsize 4000 (for a 4gb video card for example)

      Comment


        #4
        thanks [MENTION=29491]James_Gallagher[/MENTION] & [MENTION=8112]heartlessphil[/MENTION] for the feedback. i'm really needing to resolve this - so your input is appreciated.

        so first - the door and closet doors share the same uv map. the default resolution is 64 of course - but i'm using the override @ 512. (should i making this setting per mesh? or is the override legit?) below are the uv's - rather than using steamroller script via 3ds max - i manually flattened them myself for both channels (so they're identical)

        i should add (not sure if it matters but.. it lists channels 0 and 1 - should it be 1 & 2?

        also - i initially exported the bedroom unit altogether - however, not all objects were exported from 0,0 coordinates obviously - does this matter?

        and all my meshes are set to static, fyi - which i believe is the default anyways..

        Click image for larger version

Name:	lm_0404_01.JPG
Views:	1
Size:	57.0 KB
ID:	1103828

        Click image for larger version

Name:	lm_0404_06.JPG
Views:	1
Size:	156.9 KB
ID:	1103829

        Click image for larger version

Name:	lm_0404_02.JPG
Views:	1
Size:	143.6 KB
ID:	1103830

        Click image for larger version

Name:	lm_0404_03.JPG
Views:	1
Size:	129.3 KB
ID:	1103831

        Click image for larger version

Name:	lm_0404_04.JPG
Views:	1
Size:	130.0 KB
ID:	1103832

        Click image for larger version

Name:	lm_0404_05.JPG
Views:	1
Size:	50.4 KB
ID:	1103833

        Comment


          #5
          Originally posted by heartlessphil View Post
          maybe your streaming memory pool is too low? That happened to me sometimes.

          try that command in your console/output log r.streaming.poolsize 4000 (for a 4gb video card for example)
          One more option to try is to Uncheck compress option in Packaging settings. I had the same problem especially with 32 bit OS packaged game.

          Comment


            #6
            Your UV's are really bad, using an automatic method will cause issues because things like the rounded corners will get split into tiny sections which won't show up in the lightmap because they're smaller than a pixel. To get better results you would need to do them by hand, which would allow you to put the UV seams in a way so that the small polygons will be attached to the larger polygons which will give better lighting.

            Comment


              #7
              Originally posted by JVStudebaker View Post
              thanks [MENTION=29491]James_Gallagher[/MENTION] & [MENTION=8112]heartlessphil[/MENTION] for the feedback. i'm really needing to resolve this - so your input is appreciated.

              so first - the door and closet doors share the same uv map. the default resolution is 64 of course - but i'm using the override @ 512. (should i making this setting per mesh? or is the override legit?) below are the uv's - rather than using steamroller script via 3ds max - i manually flattened them myself for both channels (so they're identical)

              i should add (not sure if it matters but.. it lists channels 0 and 1 - should it be 1 & 2?
              this is right: channel 1 in 3dsmax become 0 in unreal and channel 2 in 3dsmax became 1 in unreal, it's normal

              also - i initially exported the bedroom unit altogether - however, not all objects were exported from 0,0 coordinates obviously - does this matter?

              and all my meshes are set to static, fyi - which i believe is the default anyways..

              [ATTACH=CONFIG]86897[/ATTACH]

              [ATTACH=CONFIG]86898[/ATTACH]

              [ATTACH=CONFIG]86899[/ATTACH]

              [ATTACH=CONFIG]86900[/ATTACH]

              [ATTACH=CONFIG]86901[/ATTACH]

              [ATTACH=CONFIG]86902[/ATTACH]
              I'm surely not a pro but I'm not understanding why in the map there are so many tiny meshes neither why some rectangular meshes (which they should be very simple and just divided in 2 triangular pieces) are made by so many triangles: am I missing something about your geometry?

              Surely uncheck the "compress Lightmaps" in World Setting -> Lightmass Settings (way better quality even if slower on build lights)

              If you want to make "empiric" trials you could set the lightmap scale inside the setting of the static mesh and not override it, export/impor a single door (and without handle), and personally I'd add a simple collision box directly in unreal
              I know these are 2cents suggestions but as I was saying I'm not a pro and I'm still Learning!

              Comment


                #8
                I know Revit likes to add in a billion weird triangles like that after you convert it to an editable poly in 3ds.
                James Gallagher

                Architectural Technologist, P3Architecture Partnership

                Comment


                  #9
                  sorry for the latency on my end - deadline was intense!

                  so yes [MENTION=62]darthviper107[/MENTION] - uv's are are mess. there was some serious cleanup. and thanks [MENTION=28366]MSL[/MENTION] - unchecked 'compress lightmaps' - made improvement.

                  a big thanks to [MENTION=8112]heartlessphil[/MENTION] for taking the time to examine my scene and provide critique. i made several changes per his suggestions and it vastly cleaned up my scene. they are as follows:

                  my walls were a single mesh and had a resolution of 512 - ha, what the hell was i thinking anyways - split the walls into several pieces, updated both uv channels - and assigned 512 per mesh. the floor and ceiling were also singular meshes - which i decided to keep (as a single plane) but upped the lightmap res to 1024 each.

                  the finishing touch was an article by ue4arch - i followed this and it made all the difference. highly recommended!

                  i have to say - arch viz rules sure are different from creating game assets and environments (especially in the case of editing the baselightmass - which i've never needed to do prior to arch-viz work)

                  thanks again to everyone in the unreal community - you folks rock!

                  Click image for larger version

Name:	ssk_01_SM.jpg
Views:	1
Size:	539.6 KB
ID:	1104356

                  Click image for larger version

Name:	ssk_02_SM.jpg
Views:	1
Size:	792.3 KB
ID:	1104357

                  Click image for larger version

Name:	ssk_03_SM.jpg
Views:	1
Size:	832.9 KB
ID:	1104358

                  Click image for larger version

Name:	ssk_04_SM.jpg
Views:	1
Size:	631.7 KB
ID:	1104359

                  Click image for larger version

Name:	ssk_04_SM.jpg
Views:	1
Size:	631.7 KB
ID:	1104359

                  Click image for larger version

Name:	ssk_05_SM.jpg
Views:	1
Size:	877.7 KB
ID:	1104360

                  Comment


                    #10
                    Looks much better

                    I think for archviz, if you are only doing renders then it's worth the time to build the Nvidia VXGI source so that you can use dynamic global illumination--the quality isn't necessarily as good as baked lighting, but it can be pretty great and you can turn it up enough to get better quality and it won't matter if it takes a second to render a frame because it's still much faster than building static lights.

                    Comment


                      #11
                      thanks [MENTION=62]darthviper107[/MENTION] - man, now i've got homework! looks solid tho

                      Comment

                      Working...
                      X