Announcement

Collapse
No announcement yet.

Stereo Panorama Exporter Plugin 4.11

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Stereo Panorama Exporter Plugin 4.11

    How to use Export panorama plugin to capture 360 stereo images sequences .

    In 4.11 preview 7 , we could use some console commands to establish parameters and launch the capture process : They can be called using the console or by blueprint

    To launch the capture :
    SP.PanoramicMovie x y (defines frame range sequence, "x" sets the starting frame and "y" the final one ) and SP.PanoramicScreenshot (to capture a single frame ).

    To establish some parameters of the capture like :
    SP.OutputDir C:\ ( sets the output directory):
    SP.StepCaptureWidth: (resolution of the capture)
    and so on..

    SP.HorizontalAngularIncrement
    SP.VerticalAngularIncrement
    SP.CaptureHorizontalFOV
    SP.EyeSeparation:
    SP.ForceAlpha:
    SP.CaptureSlicePixelWidth:
    SP.EnableBilerp:
    SP.SuperSamplingMethod:
    SP.ConcurrentCaptures:
    SP.GenerateDebugImages:
    SP.ShouldOverrideInitialYaw:
    SP.ForcedInitialYaw:
    SP.FadeStereoToZeroAtSides:


    There were some failures , like right eye capture wont display dynamic shadows and oclution (did work with baked light) .
    Some artifacts and horizontal banding were found also (could fix some of them by playing around with VerticalAngularIncrement and HorizontalAngularIncrement values.
    Many Postprocess like bloom , sun shafts , eye adaptation did not got correctly captured


    Now, at preview 8 nothing seems to work or some new way to do this was settle and there is no info at all on how to make the capture.
    If anyone has tested this or knows how to use this plugin at preview 8 , please reply!

    Regards!

    #2
    Thanks Maxx3d but i think i am a bit confused with the Stereo Panorama Exporter Plugin in 4.11.1
    So i enable it in plugins but at the console when i type SP....none of the above methods come up
    if anybody could explain the usage i would greatly appreciate it.
    Many thanks

    Comment


      #3
      Looks like the plug only works on windows ...beware...

      Comment


        #4
        Hi, Maxx3d,
        Have you been able to figure this out yet?

        Comment


          #5
          Hi !

          I have some questions about this plugin.
          I admit I'm a very noob in C++ and I'm not a command line monster but, I succeed to render some sequences.

          However, I've got some issues.
          The main problem, the shadows not visible on both eyes... So I baked all lights and add a quad with a texture shadow placed under the moving objects... That make the job.

          Then, I don't really understand how to fix fps... I don't understand where to enter the following commands "-usefixedtimestep -fps=60 -notexturestreaming " and how to activate them...
          So I tested some configurations... The sequence seems to output at 60fps but, it's a bit slower than in regular PIE...
          That's not really a problem, I can adjust framerate in compositing but if I want a sequence at 30fps, I don't want extra frames that increase render time...
          How can I set a really fixed framerate for the capture?

          And at last, and that's a very big problem, the capture sequence seems not playing the skeletal meshes animations correctly.
          I mean that, some characters are moving along a spline path but their animation assets are not playing
          In another case, I've got some cars, following a spline too, they are skeletal meshes too with rotating bones for the wheels indefinitely.
          The cars not playing their wheels animation until a point in space and start playing wheels rotation... I don't understand why...? O_o !!!

          Have you some clues and/or advices to solve those problems?

          Many thanks guys!

          JC

          Comment


            #6
            To fix the playback rate, you need to click on the drop down for the 'Play' options in the menu above the editor window. Then open 'Advanced Settings...'. Then in the 'Additional Launch Parameters' enter the settings you need (-usedfixedtimestep -fps[X] -notexturestreaming). Example attached.

            It's important to note that the Stereo Capture plugin disables many post processing settings, including exposure and different things mentioned. Had to work with our software engineer internally to update the plugin (we're now using with 4.13) to fix shadow issues as well as enable us to use the settings from the post processing volume.

            Advanced Settings from mention above:
            Click image for larger version

Name:	AdvancedPlaySettings.jpg
Views:	1
Size:	183.0 KB
ID:	1116080

            Comment


              #7
              Hey guys, I am running into a fairly major problem with my panoramic exports...doing a long sequence (5000 frames) and it works fine up until about half way through and then the frame rate goes crazy and it completes the second half in about 200 frames. I have entered all of the fps timestep stuff as advised in this thread and have had success exporting panoramics before so this is really confusing. Any ideas what could be causing the issue?

              Comment


                #8
                Do you have any movies in the scene? Ive had troubles with movies and when i disabled them it works just fine.

                Comment


                  #9
                  Awesome thread guys!

                  I have been looking for a way to render stereo panos for a while now.

                  I really want to try this platform for making VR Tours from panos
                  see https://theViewer.co

                  Comment


                    #10
                    Hello,
                    I am trying to export some panoramic images from a VR scene that I already have setup for HTC VIVE. This script seems to work fine on other scenes but in this HTC VIVE scene, it doesn't work.
                    I am thinking it may have something to do with the VIE blueprints, but since I am not a coder I don't know where to start.
                    I used the default star project from unreal. your help is really appreciated.
                    Francisco Penaloza.
                    Sr. Visualization Artist
                    HMC Architects

                    Comment

                    Working...
                    X