Announcement

Collapse
No announcement yet.

4.11 preview 7 Stereo Panoramic export works!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Thank you lebek for the crash course in using the plugin. We created a sample video for one of our sample scenes. Had the similar exposure issue as heartlessphil with the frames rendering very dark. In unreal we boosted the exposure of the scene using the post-processing volume. My best guess is that these effects are disabled by the plugin when rendering. Not a very hard thing to fix in photoshop as pointed out, just adds to the list of little things required to actually get the video youtube ready. Our current workflow is to render the videos for both eyes individually and then merging with ffmpeg for a top and bottom stereo. I know that the top and bottom video could be created in after effects to suit youtube's 3840x2160p, however, we found that doing it through ffmpeg drastically reduces the filesize of the ouput - quicker for uploading and everything. I'm not sure how its possible but the final full size video was only 9MB.

    https://www.youtube.com/watch?v=kFyYAEUXQ4A384

    Comment


      #47
      Hello,How to set the picture format?

      Comment


        #48
        Originally posted by heartlessphil View Post
        Very cool feature. I have a problem tho.

        My stereo rendering is much darker than my actual viewport. Here's the difference. Do you know how to fix this? I mean I could adjust the exposure in photoshop but I'm not sure why it's rendered that dark.

        I've had the same, if not similar, problem. If you disable eye adaptation, does your scene look dark like in your screenshot as well? Those values are what it seems to be using- it looks like it captures the stereopano without any kind of eye adaptation settings. Even if you try to adjust with the exposure bias, the plugin seems to ignore those values. This seems like an issue with scenes that are HDRI lit, where you have to increase eye exposure bias to compensate for the default dark lighting you get with eye adaptation. I did a quick test by re-lighting my scene (without HDRI cubemap) after setting min/max to 1 to disable eye adaptation and it seemed okay after that. Not the ideal way to work around it, but hopefully the plugin gets updated to fix these kind of issues.
        Artstation - Portfolio

        Comment


          #49
          Hey , good job just a stupid question , how are you using these after? are you using them with google cardboard?

          Comment


            #50
            I can confirm that eye adaptation is disabled when recording. I added a skylight that doesn't cast shadows to brighten things up, but there is probably a better solution. Additionally I was getting the banding issues even at the recommended settings. I was able to get good results using the following:

            HorizontalAngularIncrement = 1
            VerticalAngularIncrement = 60
            CaptureHorizontalFOV = 60
            StepCaptureWidth = 3840 (youtube's maximum width for uploads)

            A compressed version: http://imgur.com/Jv5Jgbb

            Edit: Final render still has slight banding issues but it isn't too bad: https://www.youtube.com/watch?v=A370GqQVn6I
            Last edited by LethalMongoose; 04-22-2016, 02:53 AM.

            Comment


              #51
              I can successfully export everything however I'm having issue obtaining frame by frame render. I have a 3 minute VR piece that has a bunch of different animated elements including animated textures. When I set the frame rate to fixed at 60fps the stereo capture plugin doesn't render each frame, it only renders as fast as it can which usually results in big gaps between each frame so its unusable to play back as a video. I've tried setting different frame rates with no luck, is there a way to block the thread until each frame completes rendering?

              Comment


                #52
                Originally posted by papibeast View Post
                Hey , good job just a stupid question , how are you using these after? are you using them with google cardboard?
                I don't know about others, but I'm definitely trying to port to Google Cardboard.

                Comment


                  #53
                  Here's my most recent test: Stereo Test 3

                  In the UE editor, the cube moves across the pov, but I can't get it to animate in the 360 vid. Anyone have any ideas on how to fix it?
                  Thanks in advance.
                  -T

                  Comment


                    #54
                    Just a test with cardboard (right eye decals dissapear):
                    http://goo.gl/3m1hV4
                    And same problem with exposure in postprocessing:
                    http://goo.gl/QDgP6m

                    Comment


                      #55
                      Hi JoseLuis,

                      Can you explain the process to import your VRimage on the webViewer?

                      Thanks

                      Comment


                        #56
                        Hi, just used latest VR View from google with two Stereo stacked panos img.

                        Comment


                          #57
                          I'm also having trouble recording in real time. It seems that the plugin is spitting out 1 frame out of every 10, and as a result, when played back in After Effects, it is playing back incredibly fast. I need to find a way to pause > record the frame > advance to the next frame > pause > record frame, etc etc. Am i doing something wrong?

                          Comment


                            #58
                            Hi !

                            Is everyone know how to open a Panoramic picture on Windows / Mac ? Is there any player available?

                            Thanks

                            Comment


                              #59
                              I'm trying to figure out the commands on Mac. Doesn't seem to export anything. Thanks for the help!

                              Comment


                                #60
                                I'm using 4.11.2, and can't get the exporter to export anything at all. Nothing happens when I activate it. Any tips?
                                http://www.pixelpirates.se/
                                Architectural and product visualisations

                                Comment

                                Working...
                                X