Announcement

Collapse
No announcement yet.

Join lines where walls meet (obvious UV problem) but how do I approach it?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Join lines where walls meet (obvious UV problem) but how do I approach it?

    Hi guys,

    I have some questions I don't seem to be solving on my own.
    First question:
    I've got this dark black shadow line where the walls meet which I assume is an obvious UV issue, but I have no idea how to fix it. I've tried orienting the UV light maps so that the pieces are all in order to avoid this issue - but still no luck. I'm thinking I may have to weld either the solid walls together in 3Ds or weld the UVs? But I don't know how...
    http://imgur.com/UHIAH7s

    Which brings me to me next question:
    Can I select multiple objects (six walls here) and UVunwrap them all at once? Or should I be unwrapping them piece by piece?
    The example I've shown has been all unwrapped together after I originally tried unwrapping piece by piece like the rest of the project. I'm going to try and place the edges on the grid lines and see if that helps.

    http://imgur.com/qQz5COj
    http://imgur.com/DsUhOeZ

    <blockquote class="imgur-embed-pub" lang="en" data-id="YzdSY"><a href="//imgur.com/YzdSY">View post on imgur.com</a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>

    Also, is there any way to get rid of the crappy look my reflections have? They seem to be all splotchy and... yuk...

    #2
    It looks like you just need a higher lightmap resolution/higher light bake settings in order to get rid of those black lines!

    You can definitely unwrap them all at once and combine into a single object- I often do this for walls and floors that have little detail but need to be connected. Keep in mind that you will need to bump up the lightmap resolution if you do this- more faces = more detail needed for shadows!

    As for your reflections question- the reflections in UE4 are optimised to run well on many machines, so there is a trade off with performance and visual quality. You can bump up the quality using the "r.ssr.quality 4" commmand but you still won't get perfect results due to the fact that ue4 only renders what is on the screen and creates a noticeable falloff at the edges of the reflection, and also because it's still running in realtime, so those quality tradeoffs are still present. Ideally you'd never have a perfectly smooth floor that is reflecting like that- common ways to avoid this problem is to have detailed materials with roughness and normal maps breaking up the reflections, and meshes covering parts of the floor so the reflection quality isn't so apparent.
    ARTSTATION: https://www.artstation.com/artist/noisestorm

    Comment


      #3
      You need to adjust the model-for the walls, they should be joined at the corners instead of having surfaces that are right next to each other. When you do that, the surface that's blocked will receive shadow which will bleed to the visible area. So make the corners welded together instead of having a wall section.

      Comment


        #4
        Thanks for the reply guys. I'll look into all your advice.

        Comment

        Working...
        X