Announcement

Collapse
No announcement yet.

overlapping UV's and light map UV's

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    overlapping UV's and light map UV's

    hey folks -

    so i used the 'steamroller' script for 3ds max - and applied it to the UV 2. the layout looks to be fine.

    however, when i go to building my scene - i get an error of 'overlapping UV's by 50%'. what's up with that? the layout looks fine - and i also having to flatten the UV's on channel 1?

    thanks -

    JV

    Click image for larger version

Name:	lounge_unreal_001.JPG
Views:	1
Size:	328.4 KB
ID:	1171081

    Click image for larger version

Name:	lounge_unreal_002.JPG
Views:	1
Size:	237.1 KB
ID:	1171082

    #2
    I think ground mesh or sky sphere in that scene has overlapping UVs, don't worry about it, it's not your mesh. You could delete or replace the circle platform / sphere and it will go away. It should say in the error what mesh it's from.

    Comment


      #3
      Your lightmap resolution is too low, which means that pixels will overlap.

      also, there is no automatic method that will produce as good of results as doing lightmap UV's by hand. In your case, it separated things far too much and you have a bunch of really small islands in the UV's. Because of that, you would need a very high resolution lightmap. By doing it by hand, you reduce the amount of empty space and you can use a lower resolution lightmap since the small polygons would be attached to bigger polygons.

      Comment


        #4
        thanks guys. hmmm - interesting. i used the 'steamroller' script for max - is there a way for use it and also control the resolution of the UV texture?

        Comment


          #5
          and i don't think it's the sky sphere. the mesh 'unit_b_00' is my geometry. it looks evenly spaced. maybe the resolution is the issue - but overlapping doesn't seem to make sense. thanks tho

          Comment


            #6
            Oh, I was just looking at "i get an error of 'overlapping UV's by 50%'" That's from the Skybox, your mesh unit_b_00 has overlap by 18%, which could either be some of your UVs are stacked on top of each other, or some of your islands are too small

            Comment


              #7
              thanks zac - yea, not too sure. i used the steamroller script - and it's automatic. i generally create uv's myself - but this is test - and part of a large scene. just trying to adjust and understand the basics before i bring in the overall scene.

              i would assume that the script is no different from the automatic flattening option within max for creating uv's. i'll have to review those uv's and report back!

              Comment


                #8
                sooo how does one use 'steamroller' script and unwrap to a higher resolution?

                Comment


                  #9
                  Hmm that's a good question. Just looking in the script file there doesn't seem to be anything assigning that value? (someone else may want to double check that).
                  Is it this option that changes the resolution -
                  http://help.autodesk.com/cloudhelp/2...74EEC53133.png

                  If it is you can create 1 dummy UV Unwrap and then go into the UV Edit window then Options / Preferences
                  Change the Render Width x Height, click OK and then go back to Options and then Save Current Settings as Default
                  Then the next time you use Steamroller script all your UVs should be at that width x height
                  Last edited by QBert; 01-28-2016, 12:50 AM.

                  Comment


                    #10
                    hmmm -

                    before i do that -i just came across this. i need to jump into my scene and tweak this and rebuild lighting. maybe this is it!

                    Comment


                      #11
                      ha - forgot to attach - ****, it's still too early for me!

                      Click image for larger version

Name:	4.png
Views:	2
Size:	584.2 KB
ID:	1099505

                      Comment


                        #12
                        okay - update. it was the lightmap resolution setting as posted above. by default - it was at 64 - i bump it up to 512 - and the results looked great!

                        Click image for larger version

Name:	4.png
Views:	1
Size:	532.5 KB
ID:	1099513

                        Comment


                          #13
                          Right, but if you do better lightmap UV's then you could keep a lower lightmap resolution

                          Comment


                            #14
                            It's true nothings going to beat doing UVs by hand, but it is a long process and I do like the steamroller script in 3ds max especially when you have hundreds of objects
                            You could go half way like I do, steamroller it and then go into it and move/rotate some UVs that are sticking out and line some up etc.

                            Comment

                            Working...
                            X