Announcement

Collapse
No announcement yet.

newbie asking for some guidance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    newbie asking for some guidance

    Hi all,
    I am trying to get into archvis and i ran into a few problems, some of which i was able to solve but with very inflexible means and I'm worried I'll attain bad wisdom when it comes to asset creation.

    I made a simple house. I had weird shadowing with some walls as you can see in the image to the left. I read that I should delete faces that go up against a ceiling or floor which somewhat fixed it, but I'd rather not do that and I've seen some archvis projects in the market that don't do it. I also read that I should try my best to "attach" the walls together at the mesh level to avoid such problems. It did help but I'd still rather have my workflow organized so I can edit it easily later. I also read that I should increase the resolution of the shadow maps from the details panel. This I can do without worrying too much but I also read that I shouldn't overdo it. But how big is too big? What is the size of the shadow map if i set it to 1024? because if it's 1k by 1k, it shouldn't be that big but some sources say it is.

    I haven't ran into these problems obviously with ray-tracing so these are new to me.

    Can someone take time to give me some guidance and hints as to how to create a house with inner walls while minimizing lighting issues?

    thanks

    Click image for larger version

Name:	l1eWvi7.jpg
Views:	1
Size:	23.8 KB
ID:	1165688

    #2
    Try increasing your lightmap resolution for every mesh of the walls. Did you make your own UV mapping or did you auto generate it?

    Comment


      #3
      Originally posted by Sunnyseah View Post
      Try increasing your lightmap resolution for every mesh of the walls. Did you make your own UV mapping or did you auto generate it?
      The UV mapping is "auto-generated", meaning i used blender's UV mapping tools to create the UVs. The resolution of the walls is 2048

      this is what the UV map looks like

      Click image for larger version

Name:	QBAA3Iu.jpg
Views:	1
Size:	144.6 KB
ID:	1091902

      Comment


        #4
        It's alot of geometry for a lightmap. You should make one distinct lightmap for each walls, floors, ceillings, etc. and leave it a reasonable resolution. Something like 512-1024 max.

        Comment


          #5
          Correct me if I'm wrong, but can't a single mesh only have one lightmap UV channel? He would need to split his mesh into numerous separate pieces in order to do that, unless I'm missing something.

          Comment


            #6
            You are right. He needs to separate walls, floors, ceillings in individual meshes!

            Comment


              #7
              thanks for the replies everyone.
              I broke my mesh down to several pieces. I originally had one asset for the walls, one for the ceiling and another for the floor.
              After breaking them down, I unwrapped them manually and carefully to the best possible layout.

              Bad news is I still get light-leaking and splotches as seen here:
              (Most of my lightmaps are 128 and above)

              Click image for larger version

Name:	jhtKSOX.jpg
Views:	1
Size:	17.7 KB
ID:	1091958

              Here are the layouts of some of the walls:
              http://i.imgur.com/wNW9jPq.jpg
              http://i.imgur.com/UDmv7tM.jpg

              I've also attached the FBX files of the walls with this post. I'd appreciate if someone has the time to look through them to make sure the problem is not with my asset creation process.
              Here is a screenshot of the World Settings, which were inspired by this post:

              Click image for larger version

Name:	noGdkFr.jpg
Views:	1
Size:	32.6 KB
ID:	1091959

              Any ideas what I should tweak?
              Attached Files

              Comment


                #8
                Not sure about your problem but I have my lightmaps at 2048 for walls and floors.

                Comment


                  #9
                  It looks like you've only unwrapped the first UV channel.

                  Channel 1:

                  Click image for larger version

Name:	BDiZSjM.png
Views:	1
Size:	127.7 KB
ID:	1092002

                  Channel 2:

                  Click image for larger version

Name:	ZonaYgt.png
Views:	1
Size:	133.4 KB
ID:	1092003

                  Add another Unwrap UVW modifier, change it to channel 2 and then select 'Move' when the prompt comes up.

                  EDIT: I'm not sure if you're using 3ds Max but it shouldn't be too hard to do in another program.
                  James Gallagher

                  Architectural Technologist, P3Architecture Partnership

                  Comment


                    #10
                    @James_Gallagher, what I had in mind was to set the Light Map Coordinate Index to 0 as i'm just worried about lighting at the moment. the material is just white matte with no texture.
                    I went ahead and added a duplicate UV layout to all the meshes, but i still get leaking. This is one of the bathroom walls, it looks interesting but i don't want it obviously:

                    Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	16.3 KB
ID:	1092041

                    EDIT: a friend said having hollow walls can cause light leaking. does anyone know if that is actually the case?
                    Last edited by cora; 10-27-2015, 05:29 PM.

                    Comment


                      #11
                      So I figured something out.
                      I previously read that you should delete faces that will be completely black (like faces of a wall that go against the ceiling), so I made some of my walls hollow. This is supposed to help prevent the darkness from leaking to other UV islands but it also seems to have caused the light leaking problems I had.

                      so the piece of wisdom to take here is make your meshes closed and the UV islands padded. This is what I have so far which looks good so far:
                      Click image for larger version

Name:	rS4sTmS.jpg
Views:	1
Size:	20.2 KB
ID:	1092196

                      I got some splotchiness which was fixed when i raised the resolution of the light maps.

                      Also, the overall light maps were improved when i set NumHemisphereSamplesScale=100 in the BaseLightmap.ini file (which resides in C:\Program Files\Epic Games\4.7\Engine\Config). I have no idea why such an important setting is hidden in a .ini file. The file says that artists-oriented settings are supposed to be in the editor, but so far I haven't seen anybody on this forum refer to this particular parameter from the editor.

                      Comment


                        #12
                        I often detach each face of a wall an assign a lightmap according to the importance of the surface in the scene. What is visible is going to be on a clean uv island with a decent resolution, the rest is going in another lightmap with a very low res (cause we won't see those faces anyway)

                        Comment

                        Working...
                        X