Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    So, better not use fake lighting with bounce cards? Only sun and sky? I am afraid that its not enough to light a whole house only through the windows ...

    Comment


      #62
      Originally posted by feingeist88 View Post
      So, better not use fake lighting with bounce cards? Only sun and sky? I am afraid that its not enough to light a whole house only through the windows ...
      I personally think you put lights only where they exist in a real building. So, if lighting from windows isn't enough add light fixtures where needed - either down lights or lamps/sconces etc.

      Comment


        #63
        I agree with you man. Let's just open the **** lights haha!

        Comment


          #64
          I took a look at Raghu's original scene yesterday.

          The first thing I noticed was that all the walls were 1024. When you're iterating on lighting settings, it's better to start a bit low on the resolution side and then increase for a final render. I set them all to 256 and it looks the same after lighting built, and builds in only 2 minutes! 256 on everything is 16x faster than 1024!

          I'm focusing on skylight only right now but will look into splotchiness with spotlights later. The short summary is that photons from the skylight are going to be necessary to achieve high quality with reasonable build times. This is because the openings to the sky are tiny, the chance that a random ray will find the light are tiny, so lots of error. This is going to take me some time to implement (a few weeks) and it might not end up working.

          Comment


            #65
            Originally posted by DanielW View Post
            I took a look at Raghu's original scene yesterday.

            The first thing I noticed was that all the walls were 1024. When you're iterating on lighting settings, it's better to start a bit low on the resolution side and then increase for a final render. I set them all to 256 and it looks the same after lighting built, and builds in only 2 minutes! 256 on everything is 16x faster than 1024!

            I'm focusing on skylight only right now but will look into splotchiness with spotlights later. The short summary is that photons from the skylight are going to be necessary to achieve high quality with reasonable build times. This is because the openings to the sky are tiny, the chance that a random ray will find the light are tiny, so lots of error. This is going to take me some time to implement (a few weeks) and it might not end up working.
            I recall Modo came up with a solution to this called portals I believe. From what I remember it takes light and channels it through the window openings. Anyhow, maybe something to look at?

            Comment


              #66
              Hey guys, great talk on the settings. I hope I'm not too off topic, but I've setup a swarm render farm to help with the increased render times of these settings. It seems that the farmed jobs seem to stop/die (see gaps in screenshot) in the middle and then pick back up. Is this normal or do I have something configured wrong? Adding a bunch of additional CPUs to the farm only cuts my time by about 20%.

              Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	26.3 KB
ID:	1092034
              Last edited by C4SNLLC; 10-27-2015, 03:21 PM.

              Comment


                #67
                Originally posted by RI3DVIZ View Post
                I recall Modo came up with a solution to this called portals I believe. From what I remember it takes light and channels it through the window openings. Anyhow, maybe something to look at?
                I was thinking about portal lights also. I render and bake a lot in mental ray and portal lights on interior openings are really necesary for clean solution in reasonable time.

                Comment


                  #68
                  Is this normal or do I have something configured wrong? Adding a bunch of additional CPUs to the farm only cuts my time by about 20%.
                  Probably best for another thread to keep this one focused, but that distribution is what I would expect of a small scene. Basically, only separate components can be processed in parallel. Once all your local cores have been assigned components, and two of your remote machines were assigned components, there weren't any more to go around so the rest of the remote machines quit. In a bigger scene (duplicate the existing one a few times) they will all be utilized.

                  Comment


                    #69
                    quick question. I looked for the Lightmass.ini file and it seems to be in these weird locations:
                    Unreal Projects\[name]\Saved\Config\Windows
                    Unreal Projects\[name]\Intermediate\Config\CoalescedSourceConfigs

                    The file in the first location is empty so I assume it's not the one. I changed NumHemisphereSamplesScale to 100 in the second file and I didn't notice any difference so I'm wondering if it's the right .ini to modify. Where is the Lightmass.ini file located?

                    Edit: sorry I misread the file name. BaseLightmass.ini doesn't even exist anywhere in the project folder.
                    Thanks
                    Last edited by cora; 10-27-2015, 05:03 PM.

                    Comment


                      #70
                      BaseLightmass.ini is in the UE4 installation folder, it contains the default settings, the config files in your project folder are based on that and override the default.

                      Comment


                        #71
                        Originally posted by Nicolas3D View Post
                        you should increase the Indirect light intensity on the light itself, but that for me seems to be the main problem with light leaks.
                        that's what I also have found while searching for some information. too high Indirect Light Intensity most certainly introduces leaks. you could try increasing it a bit till the point when leaks appear and then increase camera sensitivity in PostProcess volume... this helped in my scene a lot...

                        Comment


                          #72
                          I've made my own tests. I used to rely too much on lightmap resolution to get rid of the splotches. But this time I tried to mess with the values in the ini and managed to get something better, with lower lightmaps. These renderings are not final quality but it looks decent for ''untextured'' geometry.

                          Click image for larger version

Name:	HighresScreenshot00000.jpg
Views:	1
Size:	500.3 KB
ID:	1092070
                          Click image for larger version

Name:	HighresScreenshot00002.jpg
Views:	1
Size:	295.5 KB
ID:	1092071
                          Click image for larger version

Name:	HighresScreenshot00001.jpg
Views:	1
Size:	343.8 KB
ID:	1092072

                          This thing is an unoptimized section of the Salk institute made by Evermotion. It's 100 pieces (lol) and the walls have extruded lines, each tile of the flooring is geometry, etc. I still only used flatten mapping with steamroller and set the resolution to each mesh to 256! These would not be final render settings but it's already not too bad for 256 Lightmaps.

                          Settings :

                          skylight with Epic courtyard hdri. intensity 8. static.
                          basic wall material from the started content

                          scale .15
                          bounces 100
                          quality 10
                          smoothness .66

                          in the baselightmass.ini I changed : (based on what Rafareis123 suggested, but apparently he deleted his test post he made earlier...)

                          NumHemisphereSamplesScale=128
                          IndirectPhotonDensity=1200 (I doubled the default value)
                          IndirectIrradiancePhotonDensity=600 (I doubled the default value)

                          Compress lightmaps is set to false.

                          took 2 hours to build.
                          Last edited by heartlessphil; 10-27-2015, 11:38 PM.

                          Comment


                            #73
                            Don't understand why rafael deleted his post, that was good information!

                            @heartlessphil: despite being 256 resolution the lighting looks pretty good!

                            This evening I'll test some scenes with those settings and check if the results are much better then what I got, hopefully spending less time while rendering
                            ENTER REALITY

                            VR Solutions

                            Contact us for more informations

                            Comment


                              #74
                              Sorry guys, I'm just planning a final guide for this topic. There is a lot of disconnected informations here.
                              http://www.ue4arch.com

                              https://www.youtube.com/channel/UCjp...pois6WVG6hqXNQ
                              Latest projects

                              Comment


                                #75
                                Ok cool Rafareis!

                                Comment

                                Working...
                                X