Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Marlo View Post
    Can anybody help me what is the problem with my scene? I try a lot of things which in the topic too, but none of them solve my problem. Thanks for the help!
    This is what is happening, it's bug that isn't fixed yet:

    Originally posted by DanielW View Post
    The black shadow in corners is due to too much biasing by Lightmass when tracing gather rays. With point and spot lights, only the first bounce uses a gather and is affected by this bug, while the rest of the bounces come from photon mapping which is not affected. With multibounce skylight, all bounces are gathers and are affected by this bug so the artifact is much more noticeable.

    This is completely solvable but I just ran out of time for 4.18. It's high on my priority list.

    ​​​​​​​

    Comment


      I have a big problem. When I follow all tutorials on how to achieve photorealistic architecture in unreal I don’t get it. It can’t get the soft lightning and shadows. If I have sun light pointing trough the window I got light casting on wall but not reflecting the whole room as it does in real time. Can you help to achieve photo realism.

      Comment


        Originally posted by Daciansolgen View Post
        I have a big problem. When I follow all tutorials on how to achieve photorealistic architecture in unreal I don’t get it. It can’t get the soft lightning and shadows. If I have sun light pointing trough the window I got light casting on wall but not reflecting the whole room as it does in real time. Can you help to achieve photo realism.
        Post a screen shot. No one can tell what issues you are facing from a simple description.

        Comment


          **SOLVED: I found out my mesh receiving the shadow was scaled and thus causing the bad shadows. Hope this is helpful to anyone else who makes that mistake.


          Hi All,

          I posted this in answer hub but thought I would try my luck here as well.

          I've been diving deeper into baked lighting and I'm seeing very low quality shadows produced by static lights. I've searched the forums far and wide, I've tried all the usual tweaks to remedy them but I'm running out of ideas. My settings seem like they should produce higher quality shadows so I'm wondering if I'm missing something obvious or if it's a bug.

          I made a simple test level using starter and built-in engine content. I'm using 4.18.3, forward renderer on a Mac. Building at higher quality seems to have no effect on the shadow quality. Lightmap compression is off. All the meshes seem to have enough lightmap resolution. Raising it only increases the quality marginally. Raising it too high (to 2048 for the floor) seems to break the light map (it just turns into a smudgy mess).

          Hopefully someone may have some ideas for anyone having the same issue as me.

          Here are my lightmass settings...
          Click image for larger version  Name:	Screen-Shot-2018-02-19-at-2.56.21-PM.jpg Views:	1 Size:	54.0 KB ID:	1431256

          Stationary light lightmap resolution and baked result...
          Click image for larger version  Name:	Screen-Shot-2018-02-19-at-2.20.31-PM.jpg Views:	1 Size:	101.4 KB ID:	1431258
          Click image for larger version  Name:	Screen-Shot-2018-02-19-at-2.20.39-PM.jpg Views:	1 Size:	42.6 KB ID:	1431257

          Spotlight lightmap resolution and baked result...
          Click image for larger version  Name:	Screen-Shot-2018-02-19-at-2.50.10-PM.jpg Views:	1 Size:	83.9 KB ID:	1431259
          Click image for larger version  Name:	Screen-Shot-2018-02-19-at-2.49.53-PM.jpg Views:	1 Size:	57.6 KB ID:	1431260
          Last edited by thejturner; 02-19-2018, 05:45 PM.

          Comment


            Have you tried to give the light source a "source radius" larger than zero? - This looks pretty bad. Should be better. There is also a pretty visible aliasing on the geometry. I wonder if it is your video card or your general settings.
            www.s-dot.de/viz
            ArchViz User Interface :: UE4 Marketplace.

            Comment


              Test VLM + Sky Lighting Bounces
              Use only emmisive textures (50 bounces)
              VLM(5;30) + Volume fog
              Spheres - moves objects
              Attached Files

              Comment


                Test VLM + fog
                Attached Files

                Comment


                  Originally posted by
                  Unreal Engine Project (4.15) for the above test scene - [URL="https://www.dropbox.com/s/lbug8pufwo4a0ju/Lightmass_test.7z?dl=0"
                  Dropbox Link[/URL].

                  Will be doing some more tests soon with complex projects.
                  Hello guys, anybody have this file yet?
                  Caue Rodrigues
                  Owner
                  Caue Rodrigues Archviz

                  Comment


                    Originally posted by Crawlewis View Post

                    Hello guys, anybody have this file yet?
                    Click image for larger version  Name:	Onlyskylight3.jpg Views:	2 Size:	313.1 KB ID:	1115451


                    GoogleDrive
                    https://docs.google.com/uc?id=0B3wYK...xport=download

                    Dropbox
                    https://www.dropbox.com/s/0ljra2l3h0...dNaji.zip?dl=0

                    Microsoft OneDrive
                    https://1drv.ms/u/s!Ar7INFDcXdscgnWMCXW4AKFmf0Sa

                    Mediafire
                    http://www.mediafire.com/download/9x...arshidNaji.zip

                    4shared
                    http://www.4shared.com/zip/8ARByBcice/FarshidNaji.html

                    Uptobox
                    http://uptobox.com/s6m3icy2uknu

                    Comment


                      Originally posted by Norman3D View Post

                      This is what is happening, it's bug that isn't fixed yet:



                      I still get that error on 4.19.2

                      I guess it has yet to be fixed...

                      Comment


                        Originally posted by Marlo View Post
                        Can anybody help me what is the problem with my scene? I try a lot of things which in the topic too, but none of them solve my problem. Thanks for the help!
                        I have the same problem.

                        Comment

                        Working...
                        X