Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    **** that's a lot, but during those 22 hours you cannot work on anything else, unless you have more pc hehe!!!

    Leave a comment:


  • replied
    Originally posted by heartlessphil View Post
    Interesting tests. Right now we may know the settings, but these are very simple scenes. When you have a big scene (my salk institute has about 2000 meshes/lightmaps) it takes FOREVER to build and that's with 2 core i7. Think i'm going to have to let my pc run for the whole week-end lol.
    My scene Unreal take on classic has 2300 meshes with all walls, roof and floor @ 1024 Resolution with other meshes at 256 resolution minimum. It took 22 hours on 2 x i7 4930K 32 GB RAM each. When you think what you are getting in the end - Unlimited camera angles for still images and animation, 22 Hours seems like a breeze.

    You have to experiment with different values, and avoid Indirect Lighting Quality = 10 (For me it always worked between 4 - 6).

    That's what we are targeting here - Balance between quality and rendering time.

    Leave a comment:


  • replied
    Interesting tests. Right now we may know the settings, but these are very simple scenes. When you have a big scene (my salk institute has about 2000 meshes/lightmaps) it takes FOREVER to build and that's with 2 core i7. Think i'm going to have to let my pc run for the whole week-end lol.

    Leave a comment:


  • replied
    Light Leaks

    Hi friends,

    So until now we had two different situations that required different approach to tackle them -

    Situation 1 - Using only skylight with HDRI as cube map to lit the interiors

    We face problem of light splotches on the walls which are not coming in direct contact of first bounce. But fortunately community members were able to provide easy solution to this problem through changing some values in Baselightmass.ini.

    Solution - Increasing NumHemisphereSamples value to 512 (rafareis123) or NumHemisphereSamplesScale value to 128 (Koola) will get you the clean GI results without changing anything in Baselightmass.ini (Don't change both values together, they are the same values just on different location, Use either one of them but not both).

    Lightmass Settings -

    Static lighting scale = .1
    Num indirect lighting bounces = 100
    indirect lighting quality = 10
    Indirect lighting smoothness = 1


    Situation 2 - Using Point, Spot or mesh lights in conjunction with Skylight.

    We face infamous problem of light leaks, Unfortunately there is no concrete solution provided as of yet.

    Solution - Not provided as of now.


    I have already lost three commercial projects due to problem of light leaks, because clients are referring to Unreal Paris for quality and to achieve that I have to lower the "Static Lighting Level Scale" between .1 to .4 and on those values putting spot light or point light ruins the whole scene. I have managed to put out some decent work form Unreal lately by playing with BaseLightmass.ini, but still there is so much to learn.

    @DanielW - Critically need solution to problem of light leaks. @Rafareis123 and @Koola already have overcome this in there scenes (So solution is already there somewhere in BaseLightmass.ini, UV workflow or anything else).

    @DanielW - You are free to investigate problems on developer level or implementing new things, but meanwhile Kindly tell us the workflow to remove these light leaks.


    Meanwhile I have also found something very interesting while experimenting with BaseLightmass.ini file (On same uploaded scene) -


    Static lighting scale = .1
    Num indirect lighting bounces = 100
    indirect lighting quality = 4
    Indirect lighting smoothness = 1

    Values Changed in Baselightmass.ini

    IndirectPhotonEmitConeAngle = 2
    NumHemisphereSamples = 512

    Lightmass Resolution of walls - 256
    Lighgtmass Resolution Roof and Floor = 1024

    On Medium Preset

    Render Time = 19 Mins on single i7-4930K Overclocked at 4.6 GHz

    Here are the results -







    Same scene Rendered without changing IndirectPhotonEmitConeAngle = 2 (Keeping it on default value i.e 30), all other settings are same (Render Time = 19 Mins).








    I am loosing some indirect lighting while using IndirectPhotonEmitConeAngle = 2, other then that I don't see any mojor differnce. May be I am 100 % wrong on this approach, but who knows.

    @DaneilW - Don't know what I am doing here, is this even a solution?






    Attached Files
    Last edited by Raghu; 10-29-2015, 09:50 AM. Reason: Rendering Time added

    Leave a comment:


  • replied
    I tried to bake the whole salk institute with the settings in my previous test. After 11 hours it was still at 11%. And that's with 2 core i7 :-(

    Leave a comment:


  • replied
    Originally posted by cora View Post
    Thanks.
    In my installation folder, it's named BaseLightmass.ini.old.ver
    I copied its content to my "project folder\Config" and renamed it to BaseLightmass.ini. I still see splotches everywhere. How do i know if it's taking effect? should i reopen the project or is rebuilding the lighting enough? (i already tried both)

    I have UE 4.7.6 and 4.8.3 installed
    There are lots of threads on the location of baselightmass.ini, you shouldn't have to move its location.

    https://forums.unrealengine.com/show...eLightmass-ini

    Leave a comment:


  • replied
    Originally posted by darthviper107 View Post
    BaseLightmass.ini is in the UE4 installation folder, it contains the default settings, the config files in your project folder are based on that and override the default.
    Thanks.
    In my installation folder, it's named BaseLightmass.ini.old.ver
    I copied its content to my "project folder\Config" and renamed it to BaseLightmass.ini. I still see splotches everywhere. How do i know if it's taking effect? should i reopen the project or is rebuilding the lighting enough? (i already tried both)

    I have UE 4.7.6 and 4.8.3 installed

    Leave a comment:


  • replied
    nice result heartlessphil

    Leave a comment:


  • replied
    Ok cool Rafareis!

    Leave a comment:


  • replied
    Sorry guys, I'm just planning a final guide for this topic. There is a lot of disconnected informations here.

    Leave a comment:


  • replied
    Don't understand why rafael deleted his post, that was good information!

    @heartlessphil: despite being 256 resolution the lighting looks pretty good!

    This evening I'll test some scenes with those settings and check if the results are much better then what I got, hopefully spending less time while rendering

    Leave a comment:


  • replied
    I've made my own tests. I used to rely too much on lightmap resolution to get rid of the splotches. But this time I tried to mess with the values in the ini and managed to get something better, with lower lightmaps. These renderings are not final quality but it looks decent for ''untextured'' geometry.

    Click image for larger version

Name:	HighresScreenshot00000.jpg
Views:	1
Size:	500.3 KB
ID:	1092070
    Click image for larger version

Name:	HighresScreenshot00002.jpg
Views:	1
Size:	295.5 KB
ID:	1092071
    Click image for larger version

Name:	HighresScreenshot00001.jpg
Views:	1
Size:	343.8 KB
ID:	1092072

    This thing is an unoptimized section of the Salk institute made by Evermotion. It's 100 pieces (lol) and the walls have extruded lines, each tile of the flooring is geometry, etc. I still only used flatten mapping with steamroller and set the resolution to each mesh to 256! These would not be final render settings but it's already not too bad for 256 Lightmaps.

    Settings :

    skylight with Epic courtyard hdri. intensity 8. static.
    basic wall material from the started content

    scale .15
    bounces 100
    quality 10
    smoothness .66

    in the baselightmass.ini I changed : (based on what Rafareis123 suggested, but apparently he deleted his test post he made earlier...)

    NumHemisphereSamplesScale=128
    IndirectPhotonDensity=1200 (I doubled the default value)
    IndirectIrradiancePhotonDensity=600 (I doubled the default value)

    Compress lightmaps is set to false.

    took 2 hours to build.
    Last edited by heartlessphil; 10-27-2015, 11:38 PM.

    Leave a comment:


  • replied
    Originally posted by Nicolas3D View Post
    you should increase the Indirect light intensity on the light itself, but that for me seems to be the main problem with light leaks.
    that's what I also have found while searching for some information. too high Indirect Light Intensity most certainly introduces leaks. you could try increasing it a bit till the point when leaks appear and then increase camera sensitivity in PostProcess volume... this helped in my scene a lot...

    Leave a comment:


  • replied
    BaseLightmass.ini is in the UE4 installation folder, it contains the default settings, the config files in your project folder are based on that and override the default.

    Leave a comment:


  • replied
    quick question. I looked for the Lightmass.ini file and it seems to be in these weird locations:
    Unreal Projects\[name]\Saved\Config\Windows
    Unreal Projects\[name]\Intermediate\Config\CoalescedSourceConfigs

    The file in the first location is empty so I assume it's not the one. I changed NumHemisphereSamplesScale to 100 in the second file and I didn't notice any difference so I'm wondering if it's the right .ini to modify. Where is the Lightmass.ini file located?

    Edit: sorry I misread the file name. BaseLightmass.ini doesn't even exist anywhere in the project folder.
    Thanks
    Last edited by cora; 10-27-2015, 05:03 PM.

    Leave a comment:

Working...
X