Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Thanks for the reply, and sorry, if it was a lame question... I am starting to learn UE4 two days ago.

    Leave a comment:


  • replied
    Badly laid lightmaps and they are also too low res!!
    ...it doesn't cause the artifacts but with indirect lighting quailty 1 you won't get high quality bakes...

    Leave a comment:


  • replied
    Can anybody help me what is the problem with my scene? I try a lot of things which in the topic too, but none of them solve my problem. Thanks for the help!
    Attached Files
    Last edited by Marlo; 12-14-2017, 09:07 AM.

    Leave a comment:


  • replied
    Originally posted by mihanix View Post
    My experiments:
    [ATTACH=CONFIG]62743[/ATTACH]
    [ATTACH=CONFIG]62744[/ATTACH]
    [ATTACH=CONFIG]62745[/ATTACH]
    [ATTACH=CONFIG]62746[/ATTACH]
    [ATTACH=CONFIG]62747[/ATTACH]

    Scene: https://mega.nz/#!rtQ3XLzT!7BR5v95YW...uFEJHDxljR_jqM

    File BaseLightmass.ini: https://mega.nz/#!n5xGSLiT!ZmOMwf69N...Krv6KTkfp9WfJU

    change settings:

    DirectPhotonDensity=100000000

    And parameters koola:

    [DevOptions.StaticLightingProductionQuality]
    NumShadowRaysScale=32
    NumPenumbraShadowRaysScale=64
    ApproximateHighResTexelsPerMaxTransitionDistanceScale=9
    MinDistanceFieldUpsampleFactor=7
    NumHemisphereSamplesScale=64
    NumImportanceSearchPhotonsScale=6
    NumDirectPhotonsScale=32
    ; Decrease direct photon search distance so that we will have more accurate shadow transitions. This requires a higher density of direct photons.
    DirectPhotonSearchDistanceScale=.5
    NumIndirectPhotonPathsScale=32
    ; Need a lot of indirect photons since we have increased the number of first bounce photons to use for final gathering with NumImportanceSearchPhotonsScale
    NumIndirectPhotonsScale=64
    NumIndirectIrradiancePhotonsScale=32
    ; Decreasing the record radius results in more records, which increases quality
    RecordRadiusScaleScale=.45
    InterpolationMaxAngleScale=.75
    IrradianceCacheSmoothFactor=.75
    NumAdaptiveRefinementLevels=3
    AdaptiveBrightnessThresholdScale=.25
    AdaptiveFirstBouncePhotonConeAngleScale=2.5

    Render time: 4 hours
    On machine with i7 950 3.07 GHz RAM 24 Gb

    I'm afraid to imagine what will happen to the big apartment!!!

    I do not understand these parameters. Just do not have time to study the photon mapping. He began to study and my head was going to explode soon. It is a science. Examples would be the settings for daytime sunlight, cloudy, evening. Why not make the presets. How well do creative work, not to study the photon map. I really liked the graphics in Unreal Engin 4, but once started architectural visualization, faced with the mysterious file BaseLightmass.ini
    Given Links are broken.Can you please give us a new link?

    Leave a comment:


  • replied
    Thanks this topic tutorials helps lot of lighmass.

    Leave a comment:


  • replied
    Can anybody have source project file? Given link is expired.

    Leave a comment:


  • replied
    Originally posted by visualcortex View Post
    It depends. The lower values help to get more details in shadows and to smooth shading differences with indirect lighting. But can cause other shading artifacts so it really depends on the final goal. I also feel like the lighting is more vibrant with the lower scaling but it may be subjective.

    This link was posted earlier: Practical usage of Lightmass in Architectural Visualization (UE4 Lightmass Deep Dive). Check the pages 84-89 for more details.
    Nice. Will read into it. Thxs

    Leave a comment:


  • replied
    Originally posted by duke22 View Post
    I'm working on a masterplan with 7 big buildings and surrounding context.
    Oh... hehr. Thats heavy for sure.

    Leave a comment:


  • replied
    Originally posted by syrom View Post
    Also.. my scene is scaled to real life. So do i really need to change it?
    It depends. The lower values help to get more details in shadows and to smooth shading differences with indirect lighting. But can cause other shading artifacts so it really depends on the final goal. I also feel like the lighting is more vibrant with the lower scaling but it may be subjective.

    This link was posted earlier: Practical usage of Lightmass in Architectural Visualization (UE4 Lightmass Deep Dive). Check the pages 84-89 for more details.
    Last edited by visualcortex; 08-18-2017, 05:58 PM.

    Leave a comment:


  • replied
    Well here's an update. I threw a spare 250gb SSD in my machine and assigned the whole thing to virtual memory and it worked.

    Leave a comment:


  • replied
    Originally posted by syrom View Post
    How big is your scene? I am working on a 1 living room, 2 bedroom, 1 bathroom apartment and a small kitchen. All furnished. Mines loads the lightmaps well and I am using a fliptop laptop with a 940m gpu 2gb vram with 16gb ram. Never had a issue so far. Im keeping my lightmaps at a max of 512 on the larger meshes. Everything else is at 256.
    I'm working on a masterplan with 7 big buildings and surrounding context.

    Leave a comment:


  • replied
    Originally posted by syrom View Post
    BTW... Static Lighting Scale... what exactly does it improve if you lower it. I keep mines at default.
    Also.. my scene is scaled to real life. So do i really need to change it?

    Leave a comment:


  • replied
    BTW... Static Lighting Scale... what exactly does it improve if you lower it. I keep mines at default.

    Leave a comment:


  • replied
    Originally posted by duke22 View Post
    64gb ram, but only 8gb on c:\, and UnrealLightmass.exe gets nowhere near 30gb even before it gives up. If we can't get over this hurdle UE4 is no longer an option for us which would be sad.
    How big is your scene? I am working on a 1 living room, 2 bedroom, 1 bathroom apartment and a small kitchen. All furnished. Mines loads the lightmaps well and I am using a fliptop laptop with a 940m gpu 2gb vram with 16gb ram. Never had a issue so far. Im keeping my lightmaps at a max of 512 on the larger meshes. Everything else is at 256.

    Leave a comment:


  • replied
    Originally posted by dvd.kh
    check your ram + pagefile [in windows os] capacity ... seems that is not good enough for loading and processing lightmas data
    64gb ram, but only 8gb on c:\, and UnrealLightmass.exe gets nowhere near 30gb even before it gives up. If we can't get over this hurdle UE4 is no longer an option for us which would be sad.
    Last edited by duke22; 08-17-2017, 06:39 AM.

    Leave a comment:

Working...
X