Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ue4arch is down D: just when I was going to try out those ini settings.

    edit: it's back now
    Last edited by Tryedz; 02-14-2016, 04:52 PM.

    Comment


      I get safety warnings no matter what browser i try to access the ue4arch forum from.

      Comment


        I tried to bake a 4600 objects scene. Quite an adventure lol!

        Comment


          Hi, I've been doing some tests with 4.11, and unfortunately I'm getting some weird stuff in my results, I wouldn't say they're light leaks so far, but they're anomalies in the lighting nertheless.

          Click image for larger version

Name:	LVTmj9J.png
Views:	1
Size:	548.5 KB
ID:	1100574

          As you can see, the shadows suddenly 'choke' in some spots near the edges.

          I'm using the medium preset.
          These are my lightmass settings:
          Click image for larger version

Name:	no8K2mP.png
Views:	1
Size:	32.4 KB
ID:	1100575
          And the .ini changes are only these:
          NumHemisphereSamples=64
          IndirectPhotonDensity=2000
          IndirectIrradiancePhotonDensity=1000
          IndirectPhotonSearchDistance=180
          RecordRadiusScale = 0.12



          Besides the artificial lights that were already in the scene, the only change I made was swapping the skylight with a directional light that shines diagonally down into the opening.
          Also, adding a portal to the opening where light shines in from changed nothing, apart from making the baking time 3x longer :0

          Also, the contact shadows are kinda... weird? At every corner they are there, looking like outlines, making the scene look cartoonish, it definitely doesnt look like something I would get from a vray render, for instance. Is there a way to fix this?

          Click image for larger version

Name:	hTyOapN.png
Views:	1
Size:	428.4 KB
ID:	1100583
          Last edited by Tryedz; 02-15-2016, 04:34 PM.

          Comment


            It's probably the AO from the post process volume, turn it off.

            Comment


              No luck with that :/
              How about the other issue? I can overlook the last one, but that one might be a real problem in the future

              Comment


                Do your walls have thickness like 6" thick with polys on both sides and do they overlap the ceiling (also with thickness)?

                Comment


                  This scene isn't mine, it's one of Raghu's, he used it in the first few pages of this thread. Though the walls are one-sided planes, there are ones on the outside too, so I don't know if that counts as having thickness. But they don't overlap with the ceiling.

                  Comment


                    Did you try a high lightmap rez like 1024 or 2048?

                    Comment


                      Originally posted by Tryedz View Post
                      Hi, I've been doing some tests with 4.11, and unfortunately I'm getting some weird stuff in my results, I wouldn't say they're light leaks so far, but they're anomalies in the lighting nertheless.

                      [ATTACH=CONFIG]78795[/ATTACH]

                      As you can see, the shadows suddenly 'choke' in some spots near the edges.

                      I'm using the medium preset.
                      These are my lightmass settings:
                      [ATTACH=CONFIG]78796[/ATTACH]
                      And the .ini changes are only these:
                      NumHemisphereSamples=64
                      IndirectPhotonDensity=2000
                      IndirectIrradiancePhotonDensity=1000
                      IndirectPhotonSearchDistance=180
                      RecordRadiusScale = 0.12



                      Besides the artificial lights that were already in the scene, the only change I made was swapping the skylight with a directional light that shines diagonally down into the opening.
                      Also, adding a portal to the opening where light shines in from changed nothing, apart from making the baking time 3x longer :0

                      Also, the contact shadows are kinda... weird? At every corner they are there, looking like outlines, making the scene look cartoonish, it definitely doesnt look like something I would get from a vray render, for instance. Is there a way to fix this?

                      [ATTACH=CONFIG]78805[/ATTACH]
                      You are supposed to reduce the smoothness if you raise the quality (especially to 10) not raise it. Try with .75 smoothness.

                      Comment


                        I set the lightmaps to 1024 resolution and tried reducing the smoothness with no luck.

                        Here's some more spots where that happens

                        Click image for larger version

Name:	0ER27IK.png
Views:	1
Size:	173.3 KB
ID:	1100649

                        Click image for larger version

Name:	XnM8q6t.png
Views:	1
Size:	388.1 KB
ID:	1100650

                        Comment


                          Maybe I would try to use the default ini settings and the default prod quality... instead of using medium preset with a custom ini. I have no problem with with 4.11 with default ini and prod.

                          Comment


                            Hmm, that reduced the problem a bit, but it's still there in some places. Well, I think I'm done filling up this page with my issue, I'll keep experimenting here, thanks for the help y'all

                            Comment


                              Am I the only one who is not having proper quality with portals?

                              Comment


                                Portals help but they really need more controls, at the moment they don't even appear to have any directionality.

                                Comment

                                Working...
                                X