Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Do people leave on texture streaming for arch viz ? I turned it off completely as it was becoming very annoying, i figured it's only needed for people making large games ?
    Edit>project settings>rendering>texture streaming = un-ticked.

    Comment


      Originally posted by DanielW View Post
      Sure thing, glad we could make some improvements, and the form in which you presented the problems made it very easy for me to investigate (simple scene with download, clear demonstration of serious problems). Thanks to everyone who helped in this thread.

      This is just a step in the right direction. Once you guys get 4.11 we'd like to know what the new primary limiting factors are for Archviz. We won't necessarily be able to solve them all due to time constraints, but at least we'll know what's most important.
      Daniel, what would be nice is if you guys could unlock the max resolution (2048x2048 iirc) of the rendertargetcube texture. Some of us are using that to fake better reflections for our windows and even if the performance drop is huge it's not big deal because we'll use it to make stills or 360 pano!!! I know some forum members have done it themselves with the engine source code but it would be nice to have it already unlocked!!! Thanks and good job on lightmass!

      Comment


        Originally posted by Mentholblue View Post
        Do people leave on texture streaming for arch viz ? I turned it off completely as it was becoming very annoying, i figured it's only needed for people making large games ?
        Edit>project settings>rendering>texture streaming = un-ticked.
        Yep... it's better to leave them on, with additional command r.streaming.poolsize 4096 to give you more room than the default 1000.

        Unless you know exactly how many and how big the total texture size will be for your project. Don't forget to put light maps and shadow maps into calculation as well.
        Swarm Agent and Lightmass Troubleshooting

        Comment


          If you turn it off completely I find that the initial loading time can be very long tho. With a good streaming pool it works well imo.

          Comment


            I see, my projects are such that if i run out of gpu memory it means i need a new graphics card not a poolsize rethink :-)
            In all seriousness i was getting odd effects. I would increase pool size to 4000 after looking at relevant threads on this site, stats were showing a lot less than the limits but i was still getting problems so i turned it off. I launched the culprit project with texture streaming turned off and didn't notice any long loading times (3 rooms few items of furniture) only have a gtx 960 4gb. Maybe it's good to keep in mind what you pointed out as my scenes increase in size heartlessphil.
            Cheers

            Comment


              Usually your method is ideal but I had a scene where it would take more than 1 minute to load because of -notexturestreaming. It's a bit long! Maybe my project wasn't optimized enough. Very possible.

              Comment


                Originally posted by heartlessphil View Post
                It's just the texture streaming lacking memory.
                use the command r.streaming.poolsize 4000 (it's 4000mb versus the default 1000)

                By the way your scene looks good (lighting)
                How do you access the window to paste the command? Thanks!

                Comment


                  Originally posted by RI3DVIZ View Post
                  How do you access the window to paste the command? Thanks!
                  In Editor press tilde(~) and type "r.streaming.poolsize 4096"
                  For packaged game, in Level blueprint add node Execute console command after Event begin play and type the above command in it

                  Comment


                    Thanks, is that command needed for each project or does it effect the engine for all projects?

                    Comment


                      It's basically a "console command", so it only affecting project that use this command, not the whole engine. Put it in a blueprint is a good practice especially if you are going to give the final result to your clients.
                      Swarm Agent and Lightmass Troubleshooting

                      Comment


                        Click image for larger version

Name:	1451633131941.jpg
Views:	1
Size:	574.2 KB
ID:	1097816Click image for larger version

Name:	1451633202523.jpg
Views:	1
Size:	490.6 KB
ID:	1097817Click image for larger version

Name:	1451632851786.jpg
Views:	1
Size:	314.1 KB
ID:	1097818

                        4.11 lightmass portal , just preview mode
                        is better than 4.9
                        Tcimage3d Studio
                        Unreal Artist & Developer in archi & interior Visual
                        Real Estate VR Tutor: http://tcimage3d.wixsite.com/3dvr

                        Request a quote today:tcimage3d@gmail.com
                        Follow us on Facebook: https://www.facebook.com/TCimage/

                        Comment


                          Can't wait to test it out... Gotta reformat and install win10 before, it HAS to be done at some point anyway! Looks very clean!

                          Comment


                            tc22, looks great! What is your lighting set up, just hdri?

                            Comment


                              Nice, tc22. Non blurry mirror like reflections too, not seen that before (maybe that's just me)
                              Can you give your hardware spec, settings and render time ?

                              Comment


                                hi there,

                                regarding the newset preview 4.11 build, i have a question.
                                how to enable embree? i downloaded the newest library from intel, and i tested it with embree on and off in the ini file and actually, i had a slightly faster build time without embree (2% faster) so my guess is its not using it even if its enabled in the ini file and the build times are pretty much the same. and yes, i have a intel processor.

                                any words of advice?
                                Last edited by jazvec; 01-03-2016, 07:57 AM.

                                Comment

                                Working...
                                X