Announcement

Collapse
No announcement yet.

Lets make Lightmass EPIC (and understandable)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by ZacD View Post
    I'm dumb, forgot to turn off post process AO.
    Yes, yes you are. Hahahaha

    Comment


      Hi guys,
      I'm trying to build a little project with all the data I've been able to collect in this thread who is absolutely amazing.

      I have a big issue though, and I can't really explain it better than with this preview I made :
      https://youtu.be/R70WXAv1Ig8

      Basically everything works from outside the house, (appart from few light leaks and wrong mapped objects) but once I get in, all the maps wigs out.
      Would it be because I tried to push too much quality into it? I still have bleading maps and think I should push the quality even higher, or divide them more to get more quality per area.

      ATM, I overwrote all the maps to 2048 and rendered out (render took about 60h on my i7 3930k OC 3.9Ghtz)
      FYI : My video-card is only using 1.6Gb or ram out of the 4Gb available of my GTX 970

      Any ideas would be welcome

      Cheers
      Stan

      Comment


        It's just the texture streaming lacking memory.
        use the command r.streaming.poolsize 4000 (it's 4000mb versus the default 1000)

        By the way your scene looks good (lighting)
        Last edited by heartlessphil; 12-27-2015, 02:11 AM.

        Comment


          Also you probably don't need to set every lightmap to 2048, be reasonable. Books, the TV, pillows, etc, don't need the same resolution as your walls and floor.

          Comment


            4.11 support VR ???

            Comment


              Amazing improvements, I was endlessly testing build settings on a large building with many rooms that had a load of light leaks that I thought were down to poor lightmaps, but this new update fixed them nicely + greatly improved build speed times! Definitely my favorite engine update yet!
              ARTSTATION: https://www.artstation.com/artist/noisestorm

              Comment


                Originally posted by Stan Brusse View Post
                Hi guys,
                I'm trying to build a little project with all the data I've been able to collect in this thread who is absolutely amazing.

                I have a big issue though, and I can't really explain it better than with this preview I made :
                https://youtu.be/R70WXAv1Ig8

                Basically everything works from outside the house, (appart from few light leaks and wrong mapped objects) but once I get in, all the maps wigs out.
                Would it be because I tried to push too much quality into it? I still have bleading maps and think I should push the quality even higher, or divide them more to get more quality per area.

                ATM, I overwrote all the maps to 2048 and rendered out (render took about 60h on my i7 3930k OC 3.9Ghtz)
                FYI : My video-card is only using 1.6Gb or ram out of the 4Gb available of my GTX 970

                Any ideas would be welcome

                Cheers
                Stan
                You can solve it using one of 2 options.
                Option 1: as @heartlessphil said increase streaming pool size.
                (unfortunately, this option didn't work for one of my projects, especially if I package it for 32 bit os. For 64 bit it worked.)
                Option 2: Uncheck compress option in Packaging settings.

                Comment


                  Do people leave on texture streaming for arch viz ? I turned it off completely as it was becoming very annoying, i figured it's only needed for people making large games ?
                  Edit>project settings>rendering>texture streaming = un-ticked.

                  Comment


                    Originally posted by DanielW View Post
                    Sure thing, glad we could make some improvements, and the form in which you presented the problems made it very easy for me to investigate (simple scene with download, clear demonstration of serious problems). Thanks to everyone who helped in this thread.

                    This is just a step in the right direction. Once you guys get 4.11 we'd like to know what the new primary limiting factors are for Archviz. We won't necessarily be able to solve them all due to time constraints, but at least we'll know what's most important.
                    Daniel, what would be nice is if you guys could unlock the max resolution (2048x2048 iirc) of the rendertargetcube texture. Some of us are using that to fake better reflections for our windows and even if the performance drop is huge it's not big deal because we'll use it to make stills or 360 pano!!! I know some forum members have done it themselves with the engine source code but it would be nice to have it already unlocked!!! Thanks and good job on lightmass!

                    Comment


                      Originally posted by Mentholblue View Post
                      Do people leave on texture streaming for arch viz ? I turned it off completely as it was becoming very annoying, i figured it's only needed for people making large games ?
                      Edit>project settings>rendering>texture streaming = un-ticked.
                      Yep... it's better to leave them on, with additional command r.streaming.poolsize 4096 to give you more room than the default 1000.

                      Unless you know exactly how many and how big the total texture size will be for your project. Don't forget to put light maps and shadow maps into calculation as well.
                      Swarm Agent and Lightmass Troubleshooting

                      Comment


                        If you turn it off completely I find that the initial loading time can be very long tho. With a good streaming pool it works well imo.

                        Comment


                          I see, my projects are such that if i run out of gpu memory it means i need a new graphics card not a poolsize rethink :-)
                          In all seriousness i was getting odd effects. I would increase pool size to 4000 after looking at relevant threads on this site, stats were showing a lot less than the limits but i was still getting problems so i turned it off. I launched the culprit project with texture streaming turned off and didn't notice any long loading times (3 rooms few items of furniture) only have a gtx 960 4gb. Maybe it's good to keep in mind what you pointed out as my scenes increase in size heartlessphil.
                          Cheers

                          Comment


                            Usually your method is ideal but I had a scene where it would take more than 1 minute to load because of -notexturestreaming. It's a bit long! Maybe my project wasn't optimized enough. Very possible.

                            Comment


                              Originally posted by heartlessphil View Post
                              It's just the texture streaming lacking memory.
                              use the command r.streaming.poolsize 4000 (it's 4000mb versus the default 1000)

                              By the way your scene looks good (lighting)
                              How do you access the window to paste the command? Thanks!

                              Comment


                                Originally posted by RI3DVIZ View Post
                                How do you access the window to paste the command? Thanks!
                                In Editor press tilde(~) and type "r.streaming.poolsize 4096"
                                For packaged game, in Level blueprint add node Execute console command after Event begin play and type the above command in it

                                Comment

                                Working...
                                X