Announcement

Collapse
No announcement yet.

Lighting - lightmap issue/question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting - lightmap issue/question

    Hi all,

    I'm working my way through a archviz scene I converted for UE4. So far, so good, but I'm having trouble with some of the final lighting bits.
    The scene is lit with a basic direct lightsource emitting as a sunlight, and "Koola style" area light setups for the windows.

    Most of the scene looks pretty nice, but I have some artifact as shown below. I already split up the ceiling geo into mutliple parts for smaller lightmaps, and added 'lightspill' blockers outside on the wall/floor/ceiling parets of the scene.

    Strange thing is that in the lower quality build this isn't showing up for some reason. Ands I don't really inderstand the more or less radial spread of the artifacts. Material is a very simple off-white with a basic normal map.

    Settings are pretty much as most of the people here use (as far as I can find) , and the lightmap resolution should be enough? I didn't tweak any .ini files or alike btw.
    So if anyone can help me into the right direction to get rid of this last bit, that would be great! :-)

    artifacts:

    Click image for larger version

Name:	lighting_issue.jpg
Views:	1
Size:	105.5 KB
ID:	1160557

    #2
    Did you try without the normal map?

    Comment


      #3
      Hi,

      Yes, I added the normal map to see if this would break up the surface a bit to get rid of the artifacts. It didn't really help unfortunately. :-(

      thanks!

      rob

      Comment


        #4
        I would try and replace the ceiling geometry. Model it as a separate piece and import it. Or you could take some of the starter content geometry and use that scaled to size then drop it down a few mm below the existing geometry so you don't get coplanar artifacts.

        Comment


          #5
          HI,

          I tried to cut the mesh up into two pieces and see what that did. Smaller pieces = better UV's for lightmaps....
          But I get the same artifacts. I'll try a basic cube from UE and see what that does. Weird stuff.... ;-)

          Comment

          Working...
          X