Announcement

Collapse
No announcement yet.

Help needed - Vectorworks workflow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Grouping did the trick! still won't work as low as 256 though, the exterior walls end up dark.
    The map check still shows some errors but i cant see any problem

    I should be good for a while. Will keep you posted.

    Thanks guys!

    Leave a comment:


  • replied
    You shouldn't really ever need to go above 1024, 4096 is just overkill.

    I dumped the model from Vectorworks into Sketchup as is. Then I separate my pieces in Sketchup. Eg, selecting one wall and grouping it. Selecting the one floor and grouping it. As a rough estimate I bet you could divide your house maybe 7-10 groups.

    You achieve better results with 10 objects at 256 lightmap resolution, than you do with 1 object at 2048.

    If you separate your house into smaller pieces, you'll find those odd shadows will disappear.

    Leave a comment:


  • replied
    Thanks Heartlessphil, that helped a lot.

    Ok, so I'm getting excited now . I tried the various resolutions on the same model (imported as one object) and got somewhat workable results. JLO, did you export the model from vectorworks in parts or separate them in Sketchup? If you did it in SU how is it done?

    I tried all three res (1024,2048,4096). The 4096 took forever to build with my system so thats not an option for me right now.

    The 1024 built fine with no UV map overlap error messages but it has some funky shadows or something in the corners of the interior.
    Click image for larger version

Name:	Capture2.PNG
Views:	1
Size:	706.0 KB
ID:	1081099
    Click image for larger version

Name:	Capture1024.PNG
Views:	1
Size:	659.7 KB
ID:	1081100

    The 2096 took a bit longer to build and did give me an error message. The interior shadow thing is slightly less and there are some color distortions on the edges of the roof. the shadows seem a little sharper on the building though.
    Click image for larger version

Name:	Capture2096 exterior.PNG
Views:	1
Size:	745.5 KB
ID:	1081101
    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	649.7 KB
ID:	1081102

    Thoughts?

    Thanks guys, I really feel like I'm getting somewhere now.

    Leave a comment:


  • replied
    The islands on the lightmap are realy small. Try raising the resolution to 1024, then 2048 (or even 4096) and see if it's better. Usually it's better to have the house broken in multiple objects and assign a lightmap to each object.

    Leave a comment:


  • replied
    Imported as one object.

    Here is channel 0
    Click image for larger version

Name:	CaptureUV0.PNG
Views:	1
Size:	646.8 KB
ID:	1081056

    Channel 1
    Click image for larger version

Name:	CaptureUV1.PNG
Views:	1
Size:	622.0 KB
ID:	1081057

    Leave a comment:


  • replied
    Did you split that house up into smaller 'pieces'? Or did you just import it as one object?

    Upload a picture of what the lightmap looks like too. A little bit of overlapping is okay from time to time but 60% overlap tells me something went wrong

    Leave a comment:


  • replied
    Ok, I am not getting anywhere with Blender. I just don't know the program well enough. ...So, I figured I would try to go the sketchup way. I was only able to import via .3ds format as collada kept failing import. I played around until i was able to get the model to export to fbx at the right scale (by scaling it down in sketchup to .1) . Without doing anything further I export to FBX and import to UE4. It ends up with 2 UV channels and seems fine in the scene until I build lighting where I get some errors. (below)
    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	463.5 KB
ID:	1080988
    Click image for larger version

Name:	Capture2.PNG
Views:	1
Size:	531.3 KB
ID:	1080989
    Click image for larger version

Name:	Capture3.PNG
Views:	1
Size:	403.6 KB
ID:	1080990
    (last image is with built lighting)

    JLO, could you help me with your sketchup work flow?
    Are there any unwrapping or map fixing tools or functions that I am missing in my process? What version Sketchup did you use?
    Attached Files

    Leave a comment:


  • replied
    No I definitely did not remap each object, that's the beauty of the Sketchup -> UE4 workflow. You just direct import and use "UE4's automatic lightmap on import" and it makes excellent lightmaps.

    Once I separate all my walls, ceilings, roof elements, doors, floors, skirting boards and whatever else I have into their own groups in Sketchup, I just mass import.

    I'm sure you can do the same with Blender.

    Leave a comment:


  • replied
    Thanks heartless. That may be the way the model comes into Blender as each element has its own map. If I do not combine the meshes in the model it renders like this in blender.
    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	778.4 KB
ID:	1080712
    I thought at first there were only 8 maps listed when I ctrl-joined the model but that is only because only 8 can fit in the information window.
    There are actually hundreds of maps! Each rafter for example has its own map, the door trim and each door panel etc.

    This is a small house I am using to figure out a workflow to export from VW into UE4. The actual model I am trying to archviz is 10,000sf and far more complex. It would be impractical to try to map each item.

    Lumion has got this stuff scripted pretty well in their system, they are basically a similar gaming engine so I figured it shouldn't be that impossible. So I was encouraged when I saw JLO's project. Can't imagine he re mapped each object. (?)

    Leave a comment:


  • replied
    1 uv map for the whole building is not good. Make one for each walls, the roof, the floor, the frames, etc. Each material mapped to a specific object.

    Leave a comment:


  • replied
    ..did just as you said JLO, can't seem to get past the same results. Was the 'tutorial method' you mentioned above the same as the video you sent or a different tutorial?

    I can see where it starts going wrong in blender, I just don't know what to do about it. If I render the textures on the faces in the UV map I can see that it is not going to work out. (see image)
    Click image for larger version

Name:	Capture UV3.PNG
Views:	1
Size:	612.4 KB
ID:	1080652

    If I zoom in to the faces that will be the walls and rooftop and Bottom, you can see what the slat wall will look like.
    Click image for larger version

Name:	Capture UV4.PNG
Views:	1
Size:	263.7 KB
ID:	1080653

    I am obviously missing a step here. Perhaps some instruction or setting to tile the texture image or scale it appropriately?
    Do you have to go through all of this (creating UV maps)in sketchup? What do you think?

    Leave a comment:


  • replied
    Originally posted by URARCH View Post
    Thanks JLO, that really helped!

    I'm still having issues with the scale or layout of the textures on the maps when imported but it seems UE4 no longer has a problem with the light map side of things.

    I followed that video to the T except added a join function found in another tutorial to map the building as one entity. When checking out the original model in blender it shows that it has a list of maps but no content in them (below)
    [ATTACH=CONFIG]44401[/ATTACH]
    So I tried several variations; selecting one of the existing and adding maps, deleting all and adding two new with variations in adding maps to both channels or one only and so on...

    I seem to get the model into UE4 and build ok but the materials are now wonky. (below)
    [ATTACH=CONFIG]44404[/ATTACH]
    [ATTACH=CONFIG]44405[/ATTACH]

    I have tried to research a solution to this and tried several variations before responding hoping to have a 'mission accomplished' post but no luck.

    Any thoughts?
    Ahh I remember this too.

    I also got the multiple UV map thing which screwed everything up since the texture map was split into like...7 or more maps/channels. UE4 prefers to have just the one texture map. So what I did was delete ALL of the maps in blender and create 2 fresh ones. 1st one for the texture map and 2nd for the lightmap. I used the tutorial method to make both of them (flatten), so you end up with 2 identical maps. Try that out.

    Leave a comment:


  • replied
    A screen shot of the house above in Vectorworks
    Click image for larger version

Name:	Capture VW.PNG
Views:	1
Size:	358.3 KB
ID:	1080191
    Attached Files

    Leave a comment:


  • replied
    Thanks JLO, that really helped!

    I'm still having issues with the scale or layout of the textures on the maps when imported but it seems UE4 no longer has a problem with the light map side of things.

    I followed that video to the T except added a join function found in another tutorial to map the building as one entity. When checking out the original model in blender it shows that it has a list of maps but no content in them (below)
    Click image for larger version

Name:	Capture UV.PNG
Views:	1
Size:	37.0 KB
ID:	1080183
    So I tried several variations; selecting one of the existing and adding maps, deleting all and adding two new with variations in adding maps to both channels or one only and so on...

    I seem to get the model into UE4 and build ok but the materials are now wonky. (below)
    Click image for larger version

Name:	Built Lighting4.PNG
Views:	1
Size:	842.5 KB
ID:	1080186
    Click image for larger version

Name:	Built.PNG
Views:	1
Size:	786.5 KB
ID:	1080187

    I have tried to research a solution to this and tried several variations before responding hoping to have a 'mission accomplished' post but no luck.

    Any thoughts?
    Attached Files

    Leave a comment:


  • replied
    Hey URARCH, I saw your post in my thread but I'll respond here so as to not clutter it up.

    As you probably know, my workflow is essentially: Vectorworks -> Sketchup -> Unreal Engine 4. But Blender should be more than adequate so there's no need to change if you don't want to.

    The reason your surfaces are going all funky when you build lighting is most likely because of bad light-mapping (or even non-existent light-mapping). To double check, go to the static mesh editor and have a look to see if you have at least 2 UV channels. If you do have 2, check what the 2nd channel looks like. If it's blank, or you don't even HAVE a 2nd UV channel, then you have no lightmap which is your culprit. By default, UE4 looks to the 2nd UV channel for lightmaps.

    Example:

    Click image for larger version

Name:	BlankUV.PNG
Views:	1
Size:	722.5 KB
ID:	1079988
    Click image for larger version

Name:	NotBlankUV.PNG
Views:	1
Size:	747.3 KB
ID:	1079989

    (In this example, 1st UV channel is blank which is okay. 2nd UV channel has the proper map which is what you need.)


    I'm 99% sure you don't have a lightmap at all. I remember my own geometry doing the same freaky thing when I first started out (which was caused by not having a lightmap)

    In any case there's a lightmap tutorial for Blender specifically for UE4 on Youtube here: https://www.youtube.com/watch?v=z5yc-bKbHyc

    That should help get the ball rolling.

    Leave a comment:

Working...
X