Announcement

Collapse
No announcement yet.

Walk through Animation - Not Realistic Enough

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Walk through Animation - Not Realistic Enough

    Hi All,

    I've been working on this model for about a week now. Never used a video game engine before this so everything I've learned is from youtube videos and these forums. It's a Revit model exported to FBX into 3ds Max, then I unwrapped everything using 3ds Max script called Steamroller and exported to FBX into UE4. The main focus of this model is to visualize the space with the correct Interior Lighting. No sunlight contributions allowed. I seem to get weird shadows, poor reflections, light leaks, and to be honest the water materials just look very bad. For comparison here is a rendering from 3ds Max using Corona compared to a screenshot from my UE4 model. Any ideas on how to improve the realism on this model? I'm trying to convince my boss UE4 is the way to go but my model is unable to backup what's capable with this engine.

    Corona
    Click image for larger version

Name:	Corona.JPG
Views:	1
Size:	158.9 KB
ID:	1148069

    UE4
    Click image for larger version

Name:	UE4.JPG
Views:	1
Size:	204.9 KB
ID:	1148070

    #2
    Hello,

    I think the lightMap of your model is not perfect at the moment and the lightmap resolution of your model is quiet low, this is why you have bleeding shadows/ lightning. So you need to improve and correct it. Here are some the Link about LightMaps :
    https://docs.unrealengine.com/latest...ing/index.html
    (old but still good) : http://www.worldofleveldesign.com/ca...-lightmaps.php

    Could you post a screenshot of your scene in the editor with actors ? this way we could be able to see in a better way how lights are placed. And tell us settings of lights please, type, values etc.

    To have good reflections you need to tune the roughness value of your materials, place some box or sphere reflection capture actor. Here are some link for this :
    https://docs.unrealengine.com/latest...sed/index.html
    https://docs.unrealengine.com/latest...flections/1_4/
    https://docs.unrealengine.com/latest...ent/index.html

    Then you can change some values in world settings (then lightmass) and having some post process, to boost Ambient occlusion per example. For realistic render I use 100 (be careful some computer can't handle this and may crash lightmass) for "Num Indirect Lightning Bounces", and I tick Ambient occlusion's box in the lightmass settings. And if you want the light to diffuse the color of the materials, you will need to increase the value of "Diffuse Boost" at the same place.

    And you need to improve the water shader, here is a link (I never tested it, but it should work) : https://wiki.unrealengine.com/Water_Shader_Tutorial

    Comment


      #3
      Thank you very much!

      I've adjusted some of the object groups light map resolution but I am not sure what is a good number for each object? The roughness has been fixed on most of the materials now. And my indirect was already at 100, i raised the diffuse boost to 4. I took the water from the sample library and it looks much better!

      I think all I need is to tinker with my light map resolutions. Here is a screen shot, can you suggest a number for each surface? I have the floors, the walls, the ceilings, and then all the wooden beams which are in 4 foot sections.

      Click image for larger version

Name:	UE42.JPG
Views:	1
Size:	258.9 KB
ID:	1074470

      Comment


        #4
        Originally posted by awtivy View Post
        Thank you very much!

        I've adjusted some of the object groups light map resolution but I am not sure what is a good number for each object? The roughness has been fixed on most of the materials now. And my indirect was already at 100, i raised the diffuse boost to 4. I took the water from the sample library and it looks much better!

        I think all I need is to tinker with my light map resolutions. Here is a screen shot, can you suggest a number for each surface? I have the floors, the walls, the ceilings, and then all the wooden beams which are in 4 foot sections.

        [ATTACH=CONFIG]35067[/ATTACH]
        wow there are ALOT of lights there! I usually use 512, 1024 or 2048 for my lightmaps. You could try to reduce the number of lights. Even if the slider of each light stops at 5000 (power) you can manually enter bigger values. I'm sure you can reduce the number of lights! It must be a bit laggy no? good luck

        Comment


          #5
          Yes, this model is being used for lighting visualization, so the realism in the distribution of the lighting is the most important aspect. What I find isn't working as good as i'd like is the indirect lighting. It seems the ceiling is very dark for having such a reflective surface reflecting all the light back up at it.

          Comment


            #6
            Have you tried using very thin, tube shaped point lights along those light meshes instead of spot lights? The distance between the floor and the ceiling is too far so you may also have to use hidden planes close to the ceiling and facing up for additional bounce.
            FREE VR Drum Kit Project
            FREE Color LUT Collection
            FREE Physics Driven Spacecraft Project
            FREE GTA Style Vehicle Interaction
            Dynamic DoF(Depth of Field)
            Camera Crossfade

            Comment


              #7
              No I haven't could you explain this technique? Also the hidden planes technique? Thanks!

              Comment


                #8
                You can set the length and radius of point lights in details panel > Light. Then set attenuation radius wide enough that it touches the floor. Make sure most of them are set to Static(the cheapest light source, lights only static objects); place a couple of Stationary ones to make up for the lighting of movable objects. Set intensity as you please and give it a try. If it still doesnt please you you can use planes(with an unlit emisive material, emissive mutliplied with 20-30 and make sure Use Emissive for Static Lighting is enabled in those meshes' details) across the light sources. They will give additional direct lighting to the ceiling. A screenshot of how you'll need to set it up:

                I set the plane's color to red for demonstration
                Click image for larger version

Name:	HighresScreenshot00007.png
Views:	1
Size:	110.3 KB
ID:	1074481

                If those lamps in your project are separate meshes you can use them instead of extra planes, just make sure you use an emissive material on them.

                Final result
                Click image for larger version

Name:	HighresScreenshot00005.jpg
Views:	1
Size:	141.7 KB
ID:	1074482

                Then you can improve the quality by tweaking the lightmass settings in World Settings.
                FREE VR Drum Kit Project
                FREE Color LUT Collection
                FREE Physics Driven Spacecraft Project
                FREE GTA Style Vehicle Interaction
                Dynamic DoF(Depth of Field)
                Camera Crossfade

                Comment

                Working...
                X