Announcement

Collapse
No announcement yet.

Navisworks NWD to FBX Conversion (Prep for FBX import into UDK4)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Navisworks NWD to FBX Conversion (Prep for FBX import into UDK4)

    Hey there,

    I have an NWD file of a customers plant. It's quite detailed and I would like to import into UDK4 to manipulate further.
    I do have a trial copy of Navisworks Manage 2015, of which will convert the 3D model into FBX format.
    I have tried many times getting the settings right and it seems to fail every time.
    Would any of you know out there, what's the best way to accomplish this?

    Thank you and kind regards,

    Smudgy67.

    In addition please find attached a screenshot showing 3D model that is required and with it the FBX export options.

    Click image for larger version

Name:	Navisworks Manage 2015 - FBX Export Options.png
Views:	1
Size:	398.6 KB
ID:	1143352
    Last edited by smudgy67; 01-26-2015, 05:28 AM. Reason: Extra Info

    #2
    Update

    Originally posted by smudgy67 View Post
    Hey there,

    I have an NWD file of a customers plant. It's quite detailed and I would like to import into UDK4 to manipulate further.
    I do have a trial copy of Navisworks Manage 2015, of which will convert the 3D model into FBX format.
    I have tried many times getting the settings right and it seems to fail every time.
    Would any of you know out there, what's the best way to accomplish this?

    Thank you and kind regards,

    Smudgy67.

    In addition please find attached a screenshot showing 3D model that is required and with it the FBX export options.

    [ATTACH=CONFIG]23456[/ATTACH]

    Hey All,

    I noticed this has got 67 views, however, unfortunately, out of those views, no one could help me out.

    Being as the original nwd file was created in 2012, I set the FBX export settings to suit the year. Still wasn't sure of the other settings. Was rather hoping someone out there may know?!

    Anyway, imported the FBX, and although it gave a few errors, it came into UDK4. However, the mesh is very small.

    Any help on this would be much appreciated, I'm even willing to pay someone to get this model properly into UDK4, in the meantime I'll carry on tweaking settings until I get a better result.

    I would like the model to be scaled correctly and also have accurate collision implemented. I need a character to walk through the scene, climb the stairs, ladders, etc, in order to search for items installed on the plant.

    In essence, please help... anyone!

    Comment


      #3
      What problems are you having, is it just the wrong scale when you import or is there anything else?
      Are you trying to export and import as one mesh or are you splitting it?

      Comment


        #4
        Hey there,

        Thank you the reply.

        I'd like to import the mesh just as it is in the screenshot, preferably with the material colours. However, this seems not possible.
        I cannot split the mesh up prior to export as Navisworks Manage does not allow me to do this. So it's only imported as a whole mesh of which I want to manipulate further in UDK4.

        The scaling is very small in the original nwd file as when 'realism' (Third person) is set the model has to be scaled up. I can't find anywhere in the package to change the default units from 'mm' to 'metres'.

        Comment


          #5
          It is possible to include the colour in the export, if you check to import materials in Unreal. I'm not sure if that works from Navisworks, but it does from 3DS max for example

          You are going to have a lot more problems if you keep it as one mesh, you would have to create the collision manually using blocking volumes and the lightmaps will be very bad etc. Have you tried unchecking, "Combine Meshes" on import in Unreal?
          I notice there is a drop down menu on export for units, have you tried those? There is also a scale setting on import into Unreal

          Comment


            #6
            Hey there,

            I have changed the nwd export settings to change the units from mm to metres.
            Also, I have unchecked the 'Combine Meshes', however, in doing so lost the whole model as anticipated. To reconstruct this would take an age.
            I will endeavour to import the entire model again.

            Comment


              #7
              If you want to be able to walk around this as an interactive environment, it really is going to need to be separate meshes.

              If they are all separate in the content browser after unchecking Combine Meshes, you can just select all of them, and drag them into the viewport. This way the keep their locations and you don't have to place everything individually. I've not used Navisworks, but I'd imagine it works similarly to exporting from max, where an object's pivot is 0,0,0 in the max scene. So when you import, it keeps the offset.
              Last edited by Mosel3y; 01-28-2015, 07:13 AM.

              Comment


                #8
                Hey I combined meshes earlier and it gave me 7ish different ones.
                The ones I did have, I tried to drag to scene and took positions of wherever I placed them.
                A walk around would be what I'm looking for but to reconstruct this would take forever and a day.
                I haven't got a copy of 3D max but the Navisworks Manage can export as a DWF, however, I wouldn't be exactly sure what settings to utilise.
                Do you know any companies out there that could obtain the result I'm looking for?

                Comment


                  #9
                  Would you be able to send me the exported .fbx so I can see exactly what is happening?

                  I've done visualization type projects that involved a lot of assets, and I exported them in that way - one .fbx with all the meshes, unchecked combine on import. It's not a great way of doing it, but it does work.

                  Comment


                    #10
                    I've exported the fbx file many times with different settings.
                    Please see screenshot for available settings, maybe you could advise please.
                    The first file I exported was 223Mb, the others around 32Mb.

                    Comment


                      #11
                      FBX Export Options:

                      Click image for larger version

Name:	Navisworks Manage 2015 - FBX Export Options_1.png
Views:	1
Size:	32.3 KB
ID:	1065705

                      Comment


                        #12
                        The ones I did have, I tried to drag to scene and took positions of wherever I placed them.
                        After dragging all your objects into the scene, you can click the yellow "return" arrow next to the Location in the Details panel to reset all your objects to the world origin. If they were all exported in their proper orientation, they should be oriented correctly in Unreal if they are set to the 0,0,0 coordinate. That way you don't have to re-place them by hand.

                        Regarding export settings, forgive me if you've already tried this. As far as I know, the ASCII version of FBX 2013 is the officially supported FBX type for Unreal, so change the File version and Format to those.

                        Unreal works in centimeters, so have you tried exporting as that? Some programs treat units a little weird, but I would assume that if you "Convert To" cm that it should be right. If not, have you tried the other units?
                        Last edited by StephaBon; 01-29-2015, 12:01 AM. Reason: extra clarifying words
                        Theia Interactive makes immersive VR experiences in collaboration with the world’s leading companies and creatives, leveraging this bleeding edge technology to pioneer the next generation of entertainment, storytelling, and customer engagement.

                        Comment


                          #13
                          Hey StephaBon,

                          Thank you for your reply.
                          I've retried the fbx export facility and set up as you suggested.

                          UDK Import:
                          1st Try...
                          1 mesh, 600 materials.

                          2nd Try...
                          14 meshes, 2000+ materials.


                          Both file imports state they have 2096 objects, however, there are alot of messages during import stating "PolyFace_Mesh has degenerate tangent bases and will result in incorrect shading",...
                          E.G. CYNR002_-_Client_Review_Model_29_06_12_-_007_KS_SHAPE has degenerate tangent bases which will result in incorrect shading.

                          Unfortunately I haven't got the original CAD file, just a view file in nwd format.

                          Thank you for your help anyway.

                          Comment


                            #14
                            I am currently doing something similar

                            The model I have is very complicated...(complete project in the 5Gbyte range)

                            Exported from Navis came to about 1.8Gbytes FBX

                            I am currently importing into 3Dmax...but 3 hours later and still waiting (32G RAM full...already..now ) - this is on a fast Machine as well...

                            Not sure I will get it to load...just too complicated...

                            Navis Works doesnt seem to have a compromise for the Output !!!

                            Comment


                              #15
                              The "degenerate tangent" error is not critical since UE4 can fix it automatically. As for the scaling, 1 uu (unreal unit) = 1 cm. And don't use combine meshes option in UE4 FBX Importer. Other stuff that can block you from walking inside the 3D model is the mesh collision model. By default UE4 will generate this collision model automatically during import (you can turn this option off but then you need to create the collision model manually inside UE4). Just leave it as it is, however, in the static mesh editor you need to change the collision complexity to "Use Complex Collision As Simple" (under static mesh setting). I usually do this since I'm too lazy to create the collision model
                              Swarm Agent and Lightmass Troubleshooting

                              Comment

                              Working...
                              X