Announcement

Collapse
No announcement yet.

Invalid Lightmap settings?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Invalid Lightmap settings?

    Hello everyone,

    This is my first post here, I'm new to Unreal Engine, and I'm getting a few errors. I've looked up solutions for this both on youtube as well as here in the Unreal Engine forums. I was able to find similar posts but the solutions applied to older versions of Unreal.

    I am running Unreal Engine 4.6.1. I have a few objects in my scene, and I'm getting 3 errors for each of those objects.

    The errors are:
    1) Object has wrapping UVs.
    2) Object has overlapping UVs.
    3) Lightmap UV are overlapping by 33.6% Please adjust content - Enable Error Coloring to Visualize.

    Here are some images that might help-
    UV Channel 1:
    http://i.imgur.com/De1NZpm.png

    UV Channel 2:
    http://i.imgur.com/vADUfAi.png

    and i'm also getting this error across some of my objects "Invalid Lightmap settings:
    http://i.imgur.com/GLpUo7h.jpg

    Any help would be greatly appreciated.
    Jeff

    #2
    1/2/3. You have to create a proper lightmap -> http://www.worldofleveldesign.com/ca...el-in-maya.php, http://www.worldofleveldesign.com/ca...-lightmaps.php
    4. just do a double click onto the mesh and in the right properties window you have to choose a lightmap resolution 32,64,128,....

    Comment


      #3
      you should also set your "lighmap coordinate index" to 1 so its using the correct UV, right now yours is set to 0.

      Comment


        #4
        Hi Jeff,

        Looking at your first image I can see that while you've got the two UVs the wrong one is assigned to the lightmap coordinate index. Right now it is set to 0 when it should be set to 1 to make use of the second UV channel.

        Lightmap Coordinate Index will be located under the details panel in the mesh editor > Static mesh Settings > Advanced Tab drop down > Lightmap Coordinate Index

        Let me know if you have any other issues with this and I can help clarify.

        Tim

        Edit:

        @Smokey13: Man, you beat me by a few second.
        Tim Hobson | Learning Resources | Epic Games
        UE4 Documentation

        Comment

        Working...
        X