Announcement

Collapse
No announcement yet.

HDRI backdrop stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HDRI backdrop stopped working

    Hello,

    My HDRi backdrop stopped working and it's driving me crazy. All i did was change the material of the Envirodome named HDRI_MID to unlit for a second than back to default lit and now it's white and i cannot get it to work. Its not even working in any other scene/project now. I looked around in the material but i don't under stand anything since i didn't even build it.

    Changing hdri's doesn't work or help it's like something got fryed when i swiched from lit to unlit.

    Any help or tips would be really appreciated.

    Thanks in advance

    #2
    Hi!

    The material does look white! ..could you show the material setup?
    ...have you tried just simply delete the HDRI backdrop a place a new one in the scene?

    Comment


      #3
      Originally posted by Makigirl View Post
      Hi!

      The material does look white! ..could you show the material setup?
      ...have you tried just simply delete the HDRI backdrop a place a new one in the scene?
      Yes ofc tried just deleting this one and bringing in a new one. Problem is it's now the same in all other projects, Sure i will get some material screens. But in all honesty i didn't change anything but trying to switch it from default lit to unlit, like someone said i should do because i got bright movable objects. Tell me if you need anything else for me to show. This is really a mystery to me.
      Attached Files

      Comment


        #4
        Would you be ok with sending me a copy of the HDRi material? I think it has to do with the connections between the BreakMaterialAttributes and HDRi_Projection nodes. Did you change the skybox to Unlit, or the HDRi? If the skybox gets set to Unlit, then the HDRi shouldn't go completely white / light grey. Why would the scene not also go white then?
        Last edited by presto423; 10-13-2020, 10:55 AM.

        Comment


          #5
          Ok, I think I solved the problem. In the two above screenshots for the HDRI_Projection and possible for the HDRI_CenterProjection too, ensure it's set to Default Lit and change the connection wire between BreakMaterialAttributes and HDRI_Projection node from Opacity to EmissiveColor on the left and connect again to Emissive Color.

          Click image for larger version

Name:	HDRi problem 1.PNG
Views:	72
Size:	537.5 KB
ID:	1821876

          Opacity is sending only an opaque value, with no projection of the texture. Emissive color projects the texture, which is how it is for certain other projections in UE.

          Comment


            #6
            Originally posted by presto423 View Post
            Would you be ok with sending me a copy of the HDRi material? I think it has to do with the connections between the BreakMaterialAttributes and HDRi_Projection nodes. Did you change the skybox to Unlit, or the HDRi? If the skybox gets set to Unlit, then the HDRi shouldn't go completely white / light grey. Why would the scene not also go white then?
            Hey that did it! Thanks so much man, i was completlly lost since i didn't make this material and it's now back to normal. I was confused since all of my scenes got broke and i couldn't reference what changed and what went wrong. But was this the correct material you suggested i should turn on to unlit for my moveable objects problem or did i misunderstood that?

            Thanks for your time

            Comment


              #7
              You're welcome. The skysphere was the actor I suggested changing to Unlit in the material, not the HDRi. But I put the HDRi in the same sentence with another suggestion too, so I could understand mixing it up while trying things in the project. Sorry about that. When I tried to recreate the problem, I set the HDRi projection material to Unlit, then to Default Lit, and didn't make it light grey / white. So I looked at the screenshots you had in the thread, and noticed the difference was the Opacity was connected to Emissive Color, rather than Emissive Color to Emissive Color. So I connected Opacity to EC and it caused the problem of a white surface. I then figured that the material is a base material used for HDRi, so that's why it was a problem across your projects, since that base material was applied by default for the initial HDRi material (before you change it). One thing to consider when changing a material that's used as a default or a base / master in the case of a problem occurring across projects again.

              How'd you get the HDRi to appear well-proportioned in its image? I've tried in a new project, and it is always skewed. If I increase the size and modify projection center, the image gets pushed far back from the center and gets semi-hidden by a fog-like effect. I changed a number of properties and couldn't bring it to looking right.

              Comment

              Working...
              X