Announcement

Collapse
No announcement yet.

Movable objects look like not built ( too bright)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Movable objects look like not built ( too bright)

    Hello, I need some help with my ArchViz project. I wanted to setup mesh swaps in my walkthrough. All of the models that i wanted to be made switchable or moveable are looking really off (like they aren't built).
    The models are set to moveable, skylight is statonary. I am using 4.25 version with gpu lightmass plug in. The light was built. I tried almost everything ''light as if static'' works until the object moves or switches. I have tried setting my models to stationary and played a lot with world/lightmass. But nothing worked.

    Any help would really help. Thanks

    Attached Files

    #2
    A few possible causes:

    1. Reflection capture brightness is too high in conjunction with the dynamic lighting of those meshes (since they're movable)
    2. The meshes' materials have an incorrect setting / node problem / texture settings issue
    3. Skybox is not set to Unlit, or the HDRI is too bright / not set correctly for the scene

    With the HDRI, it comes with a dynamic skylight (not stationary), so if a stationary skylight was added after or before the HDRI was, then the lighting for movable meshes could be getting multiplied. It's suggested in the doc page for HDRI to not add a second skylight, though I think it depends on the scene and the settings. Thus, I would check to see what happens to the meshes' lighting when deleting or simply changing the stationary skylight to not visible. If changing it to not visible (by unchecking Visible), then it still calculates and applies Lightmass indirect lighting for the skylight, while direct lighting wouldn't be there. It's the direct lighting that'd seem to be contributing to the brightness if that's the case.

    Indirect intensity can also be scaled in materials details panel, as well as in the lights of the level. Perhaps lowering it would offset the brightening and render at the intended shading.

    Certain settings in the textures of a material/mesh can also generate incorrect values or effects. Too high of compression, or perhaps no compression combined with a high texture resolution for movable meshes could conceivably do it. Parameters such as Brightness, RGB Curve, Brightness Curve, and Saturation are possible, but not as likely I think...though adjusting one or two could adapt it to the lighting better. If using HDR textures, sRGB is supposedly required to be unchecked, and this is a problem that's best to research further if other attempts at fixing don't work. I simply suspect it because I've read a number of posts / articles concerning how HDR is not always conducive to a particular color mode / depth in getting the optimal result (eg, there's almost half a dozen 'standards' in use for different scenarios).

    Comment


      #3
      You may have to go fully dynamic for a project like this. Get the free example project from the LEARN tab of the Epic Games Launcher. It is called Arch Viz Interior and has fully dynamic lighting. It looks pretty good. There is also a video on youtube that explains how they did the lighting in there. Google it. I can't remember the name.
      www.s-dot.de/viz
      ArchViz User Interface :: UE4 Marketplace.

      Comment


        #4
        Hi!

        All you have to do is lower your Volumetric Lightmap Detail Cell Size under your lightmass settings (and highly possible you'll need to go higher with the brick memory) and those will look like as they have built/static lighting too!!

        Comment


          #5
          Originally posted by Makigirl View Post
          Hi!

          All you have to do is lower your Volumetric Lightmap Detail Cell Size under your lightmass settings (and highly possible you'll need to go higher with the brick memory) and those will look like as they have built/static lighting too!!
          Thanks for your anwser. How low would you go with it? Right now i think i have it at 200.

          Comment


            #6
            Originally posted by S-Dot View Post
            You may have to go fully dynamic for a project like this. Get the free example project from the LEARN tab of the Epic Games Launcher. It is called Arch Viz Interior and has fully dynamic lighting. It looks pretty good. There is also a video on youtube that explains how they did the lighting in there. Google it. I can't remember the name.
            Yes i have it already. Thanks for the advice

            Comment


              #7
              Originally posted by presto423 View Post
              A few possible causes:

              1. Reflection capture brightness is too high in conjunction with the dynamic lighting of those meshes (since they're movable)
              2. The meshes' materials have an incorrect setting / node problem / texture settings issue
              3. Skybox is not set to Unlit, or the HDRI is too bright / not set correctly for the scene

              With the HDRI, it comes with a dynamic skylight (not stationary), so if a stationary skylight was added after or before the HDRI was, then the lighting for movable meshes could be getting multiplied. It's suggested in the doc page for HDRI to not add a second skylight, though I think it depends on the scene and the settings. Thus, I would check to see what happens to the meshes' lighting when deleting or simply changing the stationary skylight to not visible. If changing it to not visible (by unchecking Visible), then it still calculates and applies Lightmass indirect lighting for the skylight, while direct lighting wouldn't be there. It's the direct lighting that'd seem to be contributing to the brightness if that's the case.

              Indirect intensity can also be scaled in materials details panel, as well as in the lights of the level. Perhaps lowering it would offset the brightening and render at the intended shading.

              Certain settings in the textures of a material/mesh can also generate incorrect values or effects. Too high of compression, or perhaps no compression combined with a high texture resolution for movable meshes could conceivably do it. Parameters such as Brightness, RGB Curve, Brightness Curve, and Saturation are possible, but not as likely I think...though adjusting one or two could adapt it to the lighting better. If using HDR textures, sRGB is supposedly required to be unchecked, and this is a problem that's best to research further if other attempts at fixing don't work. I simply suspect it because I've read a number of posts / articles concerning how HDR is not always conducive to a particular color mode / depth in getting the optimal result (eg, there's almost half a dozen 'standards' in use for different scenarios).
              Thanks for your thorough anwser. I will check all of your reccomendations. But i am 100% sure it's not the materials since it happens to all movable object and i tried using different materials on these objects.

              Comment


                #8
                Originally posted by DrLopata88 View Post

                Thanks for your anwser. How low would you go with it? Right now i think i have it at 200.
                Depends what quality you're after... If I remember well it's in cm... So right now you have samples every 2 meters!! This is why the lighting is inaccurate! You can go very low (let's say 5) if you want similar result than the baked lighting! But this can raise building time and memory usage so as I've said before you'll need to go higher with brick memory!!
                Try with a 100 if you like or 50 and you'll see the result...

                Comment


                  #9
                  One setting that might be worth trying to change is Auto Exposure Bias in Rendering under Project Settings. Lower it to 0 or close to 0 (.1 or lower) and see if it changes those movable meshes to a more normal lighting level.

                  Comment


                    #10
                    Originally posted by Makigirl View Post

                    Depends what quality you're after... If I remember well it's in cm... So right now you have samples every 2 meters!! This is why the lighting is inaccurate! You can go very low (let's say 5) if you want similar result than the baked lighting! But this can raise building time and memory usage so as I've said before you'll need to go higher with brick memory!!
                    Try with a 100 if you like or 50 and you'll see the result...
                    Thanks man, will build today and get back to you

                    Comment


                      #11
                      Originally posted by presto423 View Post
                      One setting that might be worth trying to change is Auto Exposure Bias in Rendering under Project Settings. Lower it to 0 or close to 0 (.1 or lower) and see if it changes those movable meshes to a more normal lighting level.
                      Thank you for your anwser. I will try that

                      Comment

                      Working...
                      X