Announcement

Collapse
No announcement yet.

Raytracing. No GI on mirror raytraced reflections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Raytracing. No GI on mirror raytraced reflections

    Hi there. I don't know if I'm missing something in my workflow, but I can't find a workaround to make reflections look how they should on mirrored surfaces.
    I'm working in a project with some clean mirrors, It seems that Raytraced Global Illumination is not working within the reflection, whatever tweaks I made on the material, post-process or Lighting elements.
    Everything seems to be right, but i only see direct lighting in the mirrors, not GI at all. Am I doing anything wrong?
    The issue can be seen in the picture below. The mirror reflects the walls black, while in the scene are lit by the GI. You can find the post-process rendering features setup as well.
    The lighting of the scene is made through Sun & Sky + Rect Lights on windows. All them with Cast ray tracing shadows, affect ray tracing reflections and affect ray tracing Global Illumination enabled. The only thing I tweaked was the skylight intensity to 0, as far as it was bleeding a terrible blue color all around, reflections included, It looked like a fake raster effect. I post as well a picture of how it looks with skylight turned on (1). Is there any work around on a per-object or per-material basis?. Maybe through Console Commands or DX12 tweaking?.
    We love the new raytracing features in Unreal, but this kind of issue makes us doubt about it's production use for archviz where pure plane reflections are often used.
    Any help would be appreciated.
    Thanks in advance
    Attached Files

    #2
    Did you find a solution to this? I'm having same issue in 4.26 preview 5
    Click image for larger version

Name:	screenRT.jpg
Views:	95
Size:	59.4 KB
ID:	1827823

    no gi/lightmaps in reflections
    my behance and instagram

    Comment


      #3
      r.RayTracing.GlobalIllumination.EvalSkylight 1
      In BP_SkySphere, enable / disable "Visible in Ray Tracing"
      Adjust the console variable MaxRayDistance for RT (r.RayTracing.*)
      r.RayTracing.GlobalIllumination.ScreenPercentage

      The blue coloration of skylight could be it capturing the color in the surrounding level, or the specified cubemap if it has lots of blue in it. I had the same problem and changed the mode in the skylight to specified cubemap, selected a lesser blue cubemap to extract lighting from, and it removed the bluing. If it's still an issue after doing that, try seeing if the Atmospheric Fog and / or the Enviro Color in World Settings have any of their color settings blue, which would be captured by the skylight and added to the scene.

      Not sure if aware...typing a console variable in and a "?" after outputs the current value plus a brief description of its function in the Output Log.

      Comment

      Working...
      X