Announcement

Collapse
No announcement yet.

Megascans Grass Getting weird shading and not responding to lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Megascans Grass Getting weird shading and not responding to lighting

    Hey there people, i've been trying to learn a little bit About UE4 lately, and mostly i've gotten good results (in interiors at least), in this scene i've tried using some of the grass clumps from megascans, but they get this weird lighting, it seems like the material has emissive but it is not the case, also i've noticed that it gets even brighter at the distance (as seen in the image below)

    The grass was painted with the foliage tool, it's set to movable, i've bake lighting with the GPU lightmass plugin, i'm working on UE4.25.1, and i've tried manipulating the Dynamic shadow distance for stationary lights to no better results, it's like the grass isn't receiving shadows (and the shadow it drops is just ambient occlusion, i've gotten no results activating and deactivating the "cast dynamic shadow" checkbox.

    Is there something am i missing? some kind of setting i'm unaware of? thanks in advance for any comments

    Click image for larger version

Name:	AnotaciĆ³n 2020-07-04 142511.jpg
Views:	178
Size:	148.2 KB
ID:	1784354

    #2
    Did you set the grass to movable in the foliage painting tool? Also make sure that cast dynamic shadow is ticked and static shadow is unticked. - Obviously the directional light must have a dynamic shadow distance set to larger than 0.0.

    It's quite bright in the scene. Are you using an HDRI in the skylight. Some are not working very well so maybe try to disable it or set the lighting intensity to less in the skylight.

    But having a closer look I think your LOD distances in the grass mesh are set too close. Looks like the grass already switched to the billboard in the middle of the scene. You can change the LOD distances for the grass mesh in the mesh browser. You have to untick the auto distance box. Then set the distances for the LODs to something like 0.1 for LOD0, 0.01 LOD1, 0.001 for LOD2 and so on for a start to see if that is the problem. I personally never use the auto lod distance feature as it is very aggressive to get the lowest LOD in as soon as possible.
    www.s-dot.de/viz
    ArchViz User Interface :: UE4 Marketplace.

    Comment


      #3
      Has S-Dot said it seams that the grass is set to movable, you will have to change it to static under the grass parameters.

      I am making a Kickstarter for a course on Photorealism for Unreal Engine 4. If you guys are interested in please share or support it!
      https://www.kickstarter.com/projects...?ref=user_menu

      Comment

      Working...
      X