Announcement

Collapse
No announcement yet.

Lightmap Baking problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmap Baking problem

    Hello
    I'm pretty new to unreal and I exported a model from Modo to unreal. Everything looks ok until I try to bake the lightmaps, Then this is what I get, a black zone on the bottom of my building. I have 2 uvs: 1_Texture where the uv overlap, used for texture image and: 2_LM that I use only for baking the LM. h numbers in front of the UV names ensure that the UV channels come in the right order in Unreal. The fbx comes with 15 layers so that specific layers uvs have enough resolution. Any idea why I'm getting those dark zones? Thank you.


    #2
    First be sure that you are using production option in light baking, then double click in the geometry and check that Unreal is reading the correct channel for the lightmaps.
    Also check your lightmass density AKA the size of your lightmap, by default it may be 64, this is not enough for most ArchViz scenes, try 1024 for walls.
    I am guessing there are not uv overlaps and not double geometry.

    Comment


      #3
      All the light map UVs need to be in the same channel. You cannot have more than 1 channel for the light map UVs
      www.s-dot.de/viz
      ArchViz User Interface :: UE4 Marketplace.

      Comment


        #4
        UVs are incorrect if they're overlapping, as far as I know. One cause could be the skylight and/or directional light aren't bouncing off what is below that scene, then hitting the underside of the base. Try putting a basic piece of floor (rectangular mesh with a basic UV map) in the scene near the building and check to see if it has the same darkening. It could help narrowing down the issue more.

        Comment


          #5
          Thank you for your help, LM size was indeed the problem.

          Comment

          Working...
          X