Announcement

Collapse
No announcement yet.

Default lights not showing in ArchViz Template

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Default lights not showing in ArchViz Template

    Hi I'm trialing UE4 for the first time.

    I've just used the new ArchViz template to get me started and I'm unable to get the default lights to work.

    They work fine in the game templates, so I'm wondering what's different or what needs to be done in the ArchViz template to get these to light the scene?

    Scene is lit
    Maxed out intensity
    Rebuilt Lighting


    Edit: I figured out if I set the intensity to 20000 it will show up as preview Lighting but when I attempt to build this lighting it takes 1 second (seems to fail) and then the preview lighting goes dark again.

    Thanks for your help.
    Last edited by patharding88; 02-25-2020, 07:05 AM.

    #2
    Are the light set to static??
    By default, the Archviz template is designed to be mobile.
    Also, the intensities should be very high

    Comment


      #3
      Ah, Thanks for your answer!

      I suppose baking lights is not really the priority here because it's not a designed for gaming.

      - I had boosted to 20,000 as above, but per your recommendation I bumped it up to 1,000,000 and now and I'm getting light after baking on the internal scene

      I'm still getting an error while baking in the external scene (As in the baking doesn't even start) I guess this is as per your comment that ArchViz is meant to be dynamic. I would still like to know how to change this and allow static lighting if I want to go from external to internal and reduce load.. Maybe I just don't know enough about the program yet to make these assumptions.

      Observations:
      - It certainly wouldn't hurt to bump the lighting up in 500k increments
      - Baking really softens the light, anything under 100k would not likely be visible in a scene like this with SunSky already present.

      Attached Files

      Comment


        #4
        Well, Unreal 4 is not for the faint of heart, that's for sure, many moving parts so you need to take your time and try to learn the software, it won't work just clicking here and see how it goes.
        I am the same as you, new to this software, spent many hours already trying to learn this beast.

        The Architectural template by default it is preset of Dynamic lighting, there are many reasons for this, but if you just need a fresh start you can start from the Arch viz clean template.

        If you need to bake lights in this Architectural template first, go to the menu Edit >Project settings > on the left menu, look for Rendering then on the right window look for Lighting, and be sure that the option Allow Static lighting is enabled.
        Then go to your World settings windows, under Lightmass scroll to the bottom there is a little arrow click on that one and uncheck the box 'Force No Precomputing Lighting' this will stop Unreal to calculate any static lights.

        Then be sure all your geometry is Static, no movable unless of course, you need to move it, but in that case, it won't bake any light on them.
        Then select your lights and make them Static or Stationary. with all that you should be able to bake your lighting.


        Also, you need to use a post-processing volume, and here is where you need to play with Exposure values and Light intensity, The latest version of Unreal is using a different scale for lighting (lux) They are trying to organize lighting values to something more Arch Viz friendly, real-world values. Because of this, the Sun intensity on this template is really hight so any other light in your scene should be at least the same or higher to show unless of course you are inside and no sunlight is affecting your scene.

        Again is up to you to leave these values or adjust your exposure and readjust the light values until you get the results you need.

        All mentioned above is not taking into consideration Raytracing LOL but I Would strongly forget about that for now, just concentrate on getting a simple scene going, then turn on Raytracing and knock your self out.

        Hope this clarifies a little more.

        Comment

        Working...
        X