Announcement

Collapse
No announcement yet.

Pixelated artifacts in lightmaps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Yea I am using BSP for the initial blockout. I wanted to highlight the fact that it affects both types of geometry; though it's most noticeable on meshes. It appears on the starter content meshes (Cube, etc), so I do not believe it's caused by my mesh or UVs. I've been using this workflow for years without issue.

    I only started getting these corrupted lightmaps once I moved from 4.15 to 4.24. Was there a significant update to Lightmass in between those builds?

    Comment


      #17
      There were a ton of updates to Lightmass between those versions. And it could've shown up as an issue despite you not experiencing it before with BSP or imported meshes. I've encountered it in one project, and not in another, and only was using starter content meshes. So, I think you could be limiting your perspective there in terms of troubleshooting. Not saying it's what I referred to precisely, since it could be something else. But I'm thinking that it's one way to narrow down the possible causes. Distance field shadows can apparently cause weird blob-like shadows due to the distance field being insufficient to completely render an accurate shadow, so the distance field representation of the object of which a shadow is being cast. Distance Field Resolution, in the Build settings of a mesh, increases the accuracy of the representation for the mesh's shadow. You probably already know about that, though.

      It could also be the shadow is not the shadow of the wall, but a less lit area of the corridor that is not fully processing the lighting. It's just a guess, and probably isn't what it is. I'm no expert, just trying to help.

      Comment


        #18
        I'll look into the Distance Field shadows. I appreciate the help! It seems like an obscure problem because there aren't many other posts about it. Luckily I have GPU Lightmass that I can use to get around it.

        Thanks again

        Comment


          #19
          Troubleshooting is a neurotic process sometimes, especially with helpful information scattered around the Unreal web site and other sources. I also wouldn't put it past it to be something simple...but that's just another hypothetical.

          Comment


            #20
            Having the same problem. Using 4.24.3 version. Is this resolved with 4.25? Been trying to find something about this bug for the last three days, this is the only thread talking about it.

            Comment


              #21
              Originally posted by Oliahim View Post
              Having the same problem. Using 4.24.3 version. Is this resolved with 4.25? Been trying to find something about this bug for the last three days, this is the only thread talking about it.
              Probably some lightmap optimization. It looks like the ivy doesn't let enough light through so lightmass thinks it is 100% covering the wall there. You may have to work around that problem by painting the wall black or something similar. I have these squares behind pictures that hang on a wall for example. Areas you would normally not see.
              www.s-dot.de/viz
              ArchViz User Interface :: UE4 Marketplace.

              Comment


                #22
                I found a solution with this issue using Loushuang's GPULightmass

                I was currently running into this issue with versions 4.25.4 and 4.26 preview 7.

                I changed all my materials with a mid grey shader, deleted my post process, deleted my reflection cube, It was a simple scene with a few walls, ground plane, handful of assets nothing big or crazy. I contained the scene with a light box and I had a small opening in the ceiling to let light in.

                I have two lights both set to stationary - directional and a sky light with a sky atmosphere.

                My light map density was nice and green, just 10 maps total at 2048 with compression turned off.

                I played with all my lightmass settings and nothing would change the artifacting as mentioned in other posts in this thread.

                using that the GPU lightmass did the trick!

                with 4.26 it does look like GPU lightmass is built in now. HOWEVER, currently with preview build you need an RTX card to use it...so that is a big draw back to the current 3rd party solution.

                This guy was having a similar issue he found a different solution and I just want to post it here for anyone else that is running into this.
                https://forums.unrealengine.com/deve...ight-artifacts

                Comment

                Working...
                X