Announcement

Collapse
No announcement yet.

Pixelated artifacts in lightmaps

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Pixelated artifacts in lightmaps

    Hello, I am trying to bake a bedroom scene. I have already done it in 4.23 and it was pretty fine. In 4.24 it gives me some bright pixel artifacts in areas that should normally be shadowed. It happens not in every shadow but mostly on places that are almost completely covered by something and should be really dark. I uploaded some pictures. One is under the bed, one is behind the curtains and in one i hid the vanity mirror so that you see how the wall behind it is pixelated and bright instead of black.

    lightmass settings are pretty high 0,1 scale, 10 and 10 both bounces, 4 quality, 1 smoothness. The meshes it happens on are simple walls or floor which means the unwrap is easy and lightmap res is 1024x1024. Anyway if it works in 4.23 why those artifacts in 4.24?
    Attached Files

    #2
    By the size of the pixels it looks like it might be something else. Some pixels are larger than others. That wouldn't happen as far as I know. Have you tried to check Detail Lighting and Lighting Only modes to see if it actually is a lighting problem?
    www.s-dot.de/viz
    ArchViz User Interface :: UE4 Marketplace.

    Comment


      #3
      Yes, it is exactly the same in Detail Lighting and Lighting Only view modes. Searching on the web I found another post in the forums having a similar problem. A scene that baked fine in 4.23, upgraded to 4.24 and had issues. https://forums.unrealengine.com/deve...build-lighting

      Something similar to this post happens to my wardrobe. Look at the pictures 4.23 clean lightmaps, 4.24 dirty lightmpas, on the same mesh, with the same unwrap. Just in 4.24 I have removed many objects for the scene as I was wasting hours testing and testing again thinking that I might fix it by changing various settings, only to find out it was the engine version that is responsible. Unless someone enlightens me with some sort of trick I didn't know that can fix it.
      Attached Files

      Comment


        #4
        Is there any update on this issue? as a marketplace creator this is becoming a big issue, should we downgrade to 4.23 in order to bake our scenes and put it in the marketplace?

        Comment


          #5
          Have you tried to create a new project in 4.24 and then migrate everything from 4.23 to the new project?

          I didn't have any problems moving from 4.23 to 4.24 so it might be something project specific. I would try to migrate and leave everything at default for the first lighting build. See if the problem occurs. If it doesn't then start making your project specific changes until it happens again.
          www.s-dot.de/viz
          ArchViz User Interface :: UE4 Marketplace.

          Comment


            #6
            Are there stationary or movable lights in the scene? If so, what are the settings? What are Volumetric Lightmap settings in World>Lightmass?

            Comment


              #7
              Were you able to resolve this issue? I recently moved to 4.24 and I'm running into the exact same problem with baked lightmaps. In areas with enough light, the lightmaps look acceptable. But in darker or fully darkened areas the maps look pixelated and corrupted like yours.

              Comment


                #8
                I think this looks like a place where a mesh has been placed and then removed after building the lighting. Is there something in the scene that blocked light but is currently not visible? Press Ctrl+H to make all meshes visible. - Just a guess. Sorry if that sounds a bit silly but I made that mistake before multiple times
                www.s-dot.de/viz
                ArchViz User Interface :: UE4 Marketplace.

                Comment


                  #9
                  I hit the same sort of artifact - was fixed by unchecking "Cast Shadow" on a sky dome static mesh surrounding the scene, even though the mesh had an unlit material and shouldn't have affected static lighting.

                  Comment


                    #10
                    Even an unlit material can have emissive when there's at least a skylight in the scene. It could be a result of the skylight bouncing off the skydome and contributing its emissive to the light bake, resulting in those artifacts. Not sure if it's really the cause, or a part of it potentially.

                    Comment


                      #11
                      Did it work when you disable the shadows of your sky dome?

                      If not have you tried to change the FireflyClamping?

                      Go to your engine instalation and under "\UE_YourVersion\Engine\Config" you will find a file named "BaseLightmass.ini". At the very end you should have FireflyClamping, change it for a bit less and build the light once again if it doesnt work move it up a little bit more and see what it happens (Change 500 less and then if it doesnt work change to 500 more than it was before)

                      The other 2 parameters will help your project too but thats another topic and dont go too big on those, also I have seen in the comments for you to change in the world settings but the only parameter that will work with GPU lightmass is the "Num Indirect Lighting Bouce" the secound option.

                      I am making a Kickstarter for a course on Photorealism for Unreal Engine 4. If you guys are interested in please share or support it!
                      https://www.kickstarter.com/projects...?ref=user_menu

                      Comment


                        #12
                        Hey all, thanks for the help. I apologize for not responding, I subscribed to this thread but must have done it wrong and never got any email notifications. After this post, I found GPU Lightmass and gave that a try. Using the GPU did not result in these corrupted lightmaps. The GPU tool is more complex to use, but I believe I can make that work and get good results.

                        Since then, I moved from 4.24 to 4.25. Created a brand new map, and using standard/CPU lightmass, I ended up with the same corrupted lightmaps. The skysphere mesh has cast shadow disabled by default, so that was not the culprit. There are also oddities like spots where it looks like an invisible object is casting a shadow, but I am certain there is no object there. Here's a picture:












                        This is a fresh map with mostly BSP. I am 100% sure nothing is there, haha

                        Some part of me wants to blame my specific CPU. I have a relatively old Haswell-E 8 core i7-5960x. For now I will be relying on GPULightmass. I also have other team members that can build my lighting for production if need be. I'm still open to solutions or ideas for testing if anyone can think of anything. Thanks again!
                        Last edited by tidu; 07-27-2020, 08:50 PM.

                        Comment


                          #13
                          Since then, I moved from 4.24 to 4.25. Created a brand new map, and using standard/CPU lightmass, I ended up with the same corrupted lightmaps. The skysphere mesh has cast shadow disabled by default, so that was not the culprit. There are also oddities like spots where it looks like an invisible object is casting a shadow, but I am certain there is no object there. Here's a picture:
                          That shadow looks like it's a cast of the wall it's next to, but a really bad one. Is the floor there the default tile material from the starter content? I think it may be a part of the problem. Open it in the mesh editor and check settings under LOD 0 > Build, and the other lighting settings. Is "Generate Mesh Distance Fields" enabled in the project settings? If not, try enabling it, and then for that wall mesh in the picture, go to the mesh editor and change Distance Field Resolution to 2, click Apply if it lights up.

                          Comment


                            #14
                            I think you're right, that black mark is the shadow caused by the wall and the second point light that can be seen in the background. I verified by deleting that point light and rebuilding, which erased that artifact.

                            Unfortunately all the geometry seen in the picture is BSP, not static mesh.

                            Comment


                              #15
                              You say you are using BSP? I haven't used it for a long time. It can cause problems like that. Try to build geometry. In the past you had to build geometry every time you made a change to the BSP.

                              Are you building lighting by "Build Lighting Only"? Click on the main icon "Build" instead. That will build everything necessary. You should always do that. I would never build lighting only. You don't really save any time doing that unless you have a huge game scene with lots of navigation in it or you specifically do not want to build something like navigation (so it doesn't change).
                              www.s-dot.de/viz
                              ArchViz User Interface :: UE4 Marketplace.

                              Comment

                              Working...
                              X