Announcement

Collapse
No announcement yet.

why I cant use pixel streaming in UE4 4.24 verson.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    why I cant use pixel streaming in UE4 4.24 verson.

    i cant find any WebRTC files in verson 4.24 ,so how to run pixel streaming .

    #2
    It's still in beta. So maybe post your question in the 4.24 preview threat or wait till the first real version comes out. Those features often only get implemented at the end.
    www.s-dot.de/viz
    ArchViz User Interface :: UE4 Marketplace.

    Comment


      #3
      Originally posted by S-Dot View Post
      It's still in beta. So maybe post your question in the 4.24 preview threat or wait till the first real version comes out. Those features often only get implemented at the end.
      thanks,maybe you are right.

      Comment


        #4
        Now it's out of beta and I still can't run Pixel Streaming. Documentation says that WEBRTC aren't needed anymore, but when I run the pixelstreaming demo, I get to the screen with "click to start". but when I click, nothing happens. Both on mobile and desktop, using local connection.

        Comment


          #5
          Based the feedback I got from Andriy from dev team.
          “WebRTC Proxy was removed in 4.24. Documentation is still not updated. Now to enable streaming you need to provide additional command-line args: "-PixelStreamingIP=localhost -PixelStreamingPort=8888" ("localhost" points at Signalling Server location)”

          Comment


            #6
            Hi,

            Indeed, there have been some changes with Pixel Streaming in the new 4.24 version.

            The WebRTC Proxy has now been removed.

            The SignallingWebServer has moved and I now find mine in the location: C:\Program Files\Epic Games\UE_4.24\Engine\Source\Programs\PixelStreaming\WebServers\SignallingWebServer

            You need two additional command line parameters to be added to your UE4 application; for example, if I am doing a basic local test (with everything running on the same machine) then I would add:

            -PixelStreamingIP=localhost -PixelStreamingPort=8888

            If you make these changes then you should be able to connect via Pixel Streaming again.

            Thanks, Stuart.

            Comment


              #7
              Originally posted by Stuart.Hill2 View Post
              Hi,

              Indeed, there have been some changes with Pixel Streaming in the new 4.24 version.

              The WebRTC Proxy has now been removed.

              The SignallingWebServer has moved and I now find mine in the location: C:\Program Files\Epic Games\UE_4.24\Engine\Source\Programs\PixelStreaming\WebServers\SignallingWebServer

              You need two additional command line parameters to be added to your UE4 application; for example, if I am doing a basic local test (with everything running on the same machine) then I would add:

              -PixelStreamingIP=localhost -PixelStreamingPort=8888

              If you make these changes then you should be able to connect via Pixel Streaming again.

              Thanks, Stuart.
              Where do I have to add that two additional command lines parameters? In the signallyingWebServer file? In the pre-compiled project? Or after open all the server files and run out my UE4 application opening the console commands?
              Last edited by noted1; 12-18-2019, 04:36 AM.

              Comment


                #8
                The command line parameters are for UE4, so when I am running a test then I run:

                UE4Editor.exe ..\..\..\Collaboration\Samples\PixelStreamingInput\PixelStreamingInput.uproject -game -RenderOffScreen -PixelStreamingIP=localhost -PixelStreamingPort=8888

                Or if you are running via Play-in-Editor (Standalone Game) then you would add these options in the Advanced Settings:

                Click image for larger version

Name:	PlayInEditorPixelStreaming.jpg
Views:	393
Size:	59.6 KB
ID:	1699695

                The Signalling Web Server can just be run with the run.bat script in the C:\Program Files\Epic Games\UE_4.24\Engine\Source\Programs\PixelStreaming\WebServers\SignallingWebServer directory. You don't need to change that script normally.

                Comment


                  #9
                  Hello,
                  The above solution of adding a command-line parameter didn't make any difference for me. I still can't run Pixel Streaming.
                  please let me know if there is any alternative.

                  Thank you

                  Comment


                    #10
                    Hello:

                    Free server open for anyone like to connet and show your UE4 project., easily just setup Parameters from

                    Unreal Editor, Under the Level Editor > Play category, find the Additional Launch Parameters setting, and set its value to -AudioMixer -PixelStreamingIP=65.52.189.204 -PixelStreamingPort=8889.

                    Click image for larger version

Name:	ue4_editor_preferences_play.jpg
Views:	264
Size:	121.2 KB
ID:	1711192
                    More detail please check step how to connect free server
                    http://renderstreaming.com/connect

                    follow us https://forums.unrealengine.com/comm...gin-developing

                    Comment

                    Working...
                    X