Announcement

Collapse
No announcement yet.

Cant solve the strange ‍shadows in Unreal

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • started a topic Cant solve the strange ‍shadows in Unreal

    Cant solve the strange ‍shadows in Unreal

    Hello,
    Trying to remove the strange shadows in unreal using Different settings in lightmass also using Production Build quality. But No Hope!. Please Help!
    Please see the attached screenshots.


    Thanks
    Lightmass Settings Scene Density

  • replied
    I think it's better to keep the number of bouncer under 20-10... higher values might cause lighting errors...
    I don't really see where you have the problematic shadows...
    Your lightmaps are not ideal: they still contain faces that won't be visible + some of the maps 30% is empty! So if I'm right you're keeping the side and the bottom faces of the floor on the uv map: they won't be visible at any time! /so if you set 1024 lightmap to this mesh all you get is like 25% = 256!!!/ Keep just the top part, scale it up as much as possible (don't have to be uniformly!!) ...same for the rest of the meshes!

    Leave a comment:


  • replied
    Sorry, I Forget to mention you Makigirl to my reply.
    the second para is the reply of your comments.

    Leave a comment:


  • replied
    cwm83 I am just trying your method hope it works, but not totally removed the shadows.

    Yes! you're right I'am testing the scene for archviz. I am trying to achieve the best possible quality. I've to Change lightmap resolution to higher value 1024. also I've deleted the top faces from all the walls for avoiding overlapping faces. Made few changes on lightmasssettings which I got from another post of this forum. It's pretty nice now but you may noticed if you see the screenshot there the right side wall still have strong shadows.

    thanks
    Lightmass Settings

    Leave a comment:


  • replied
    Hi!

    By the settings I'm guessing you're after archviz quality?
    If so your lightmap resolutions are very low!! If you want better quality, more details, realistic results: you'll need to go with a lot higher resolution (512< per wall)! ...just like any texture!
    Also if your walls are not corner/edge snapped you'll have overlapping faces... if you exclude them from your lightmap uvs it's all fine! But if not you'll need to be lucky to have all lightmaps lining up correctly and not get a shadow "bleed"!
    This is what happening here: where two of your walls meet the ligthmap texel row is "cut" in the middle so it will produce an in-between result...

    Leave a comment:


  • replied
    You might be getting some bleeding of the shadow from the top of the wall onto the front. This can happen when the islands in the lightmap UV channel are too close together. The solution I've found is a bit counter-intuitive. Try lowering the 'Min Lightmap Resolution' (to 32 or maybe even 16). This should force the lightmap generation to make larger gaps between the islands. You can keep the actual lightmap resolution at 128 or higher.

    If that doesn't work, you might need to go back and manually edit the lightmap UVs in whatever software the geometry came from originally.

    Leave a comment:


  • replied
    Hello, I have just uploaded screenshots for a single wall for sorting the problem, but strange shadows also appearing on the all other walls. I have changed Light Map coordinate index of this wall to 1 before it was 2. I've uploaded screenshots for both UV of this wall. Building light using Production quality. Unfortunately, these does not work. Still appearing the strange shadows.

    Leave a comment:


  • replied
    By default, UE4 is set to auto generate lightmap UV's when importing meshes and then use that new UV channel for the lightmap, so you can see in the screenshots that each mesh has a third UV channel, which is likely the channel that was auto generated for the lightmap, you'll need to check that and make sure it's not messed up there or change the lightmap coordinate index value to set a different UV channel for the lightmap.

    Leave a comment:

Working...
X