Announcement

Collapse
No announcement yet.

Ray Tracing Overview - Unreal Engine 4.22 Preview

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by thejturner View Post
    I submitted a bug report and project to EPIC. I just made a blank project and made a simple scene with a sphere and the FirstPersonCharacter. I added a keyboard input event so I can increase/decrease the FOV while playing. Default editor workspace and sizing on a 4k monitor.

    Here's screenshots of the scene at 90 FOV and then zoomed in. You can see pretty aggressive stairstepping on all edges but it almost appears as if you are looking through a glass window. Where each square cell is slightly offsetting and refracting the image behind it (the squares don't move, they seem a fixed pattern). Curious to know what's going on. Whether it's just a fixed limitation or something we can mitigate?
    I'm also getting aggressive stairstepping. It seems related to scene scale as zooming out in a huge scene results in massive pixels where the entire scene becomes a few dozen squares (on 4.22.1)

    Leave a comment:


  • replied
    That halo/outline is exactly what I was seeing in my test project. If it helps at all I have no idea what caused it, but I still have the project and it still happens.

    Leave a comment:


  • replied
    etiles I agree that your findings are weird indeed, anyway I think the main point is a truly representation on the gradient embracing the meaning = extremes (black and white good) and gradient (gray are bad - sort of). Looking at an entire scene at least, it makes sense.

    I wouldn't call it a bug, but someone didn't just consider that there was another visualization for roughness (someone sloppy maybe), so for coherence it should be the same, I hope someone see our comments and check this, I wouldn't make a bug submission report just for that.

    Leave a comment:


  • replied
    Thank you Nilson. I thought it was something more complex like the "PBR validate" from substance or something like that.
    By yhe way, I notice something strange that i don't understand.
    When ray tracing is enabled, values that are read are those in the RayTracing buffer visualization, right? But I guess values are supposed to be the same : a value of roughness=0.5 is the same whatever if raytracing is enabled or not.
    Here is what the roughness value is for the same material. Traditionnal buffer on the left, and RayTracing buffer on the right. Why thereis a so huge difference between both?
    I checked other value as BaseColor, Specularity, Metallic, and values seems to be the same. Difference is noticeable only with roughness.
    Mmm... Is it a bug?

    Click image for larger version

Name:	RtxRoughnessValues.jpg
Views:	1
Size:	109.5 KB
ID:	1609007

    Leave a comment:


  • replied
    etiles When you are at the editor, at the viewport click on the Lit menu, then take a look at Ray Tracing Debug options. If you choose Roughness, it will be basically the same as Sjoerd De Jong showed at GDC, but in grayscale. The diagnostic for the scene is the same, with Black color meaning fully reflective and White color fully Rough, so you need to check the intermediate of those gray shades.

    Leave a comment:


  • replied
    Originally posted by etiles View Post
    Hello all,
    Is it possible to have more information in order to recreate the "post process ray expense" material of which talks Sjoerd De Jong about in his GDC conference?
    You can see it at 22'00 in the video.
    https://www.youtube.com/watch?v=EekCn4wed1E

    Thanks,
    I think that postprocess material just use the SceneTexture node selecting Roughness and giving a different color grade for each roughness value range, nothing too fancy.

    Leave a comment:


  • replied
    Hello all,
    Is it possible to have more information in order to recreate the "post process ray expense" material of which talks Sjoerd De Jong about in his GDC conference?
    You can see it at 22'00 in the video.
    https://www.youtube.com/watch?v=EekCn4wed1E

    Thanks,
    Last edited by etiles; 04-17-2019, 04:46 AM.

    Leave a comment:


  • replied
    Originally posted by SonKim View Post

    Are you lighting your scene with a HDRI or skylight? Are you using RTGI? I had similar issue with skylight + RTGI, you'll get halos and other artifacts...so I disable skylight.

    Try isolating the rendering features and light to see what is causing the problem. Try lighting with lights, turn off everything else(RTGI,reflection,AO,post process).

    edit: I think it's related to the RTGI(it's really experimental feature). See my attached pics. The one with the black arrow is RTGI = ON, the other one is RTGI = OFF.

    Click image for larger version Name:	RTGI_OFF.jpg Views:	1 Size:	276.5 KB ID:	1608151Click image for larger version Name:	RTGI_ON.jpg Views:	1 Size:	278.5 KB ID:	1608152
    Thanks for your answer, I tested all the functions, the loop disappears when the GI turns off and when I turn off the shadows. I attached a video for understanding. I do not use HDRI in my stage and there is no glass, quality changes do not affect this loop. You have visible artifacts on your image, they are visible when I move the camera
    https://youtu.be/MnoXrQ2U2Uk

    Leave a comment:


  • replied
    Originally posted by Dimax3dd View Post
    Good day! I perform raytracing tests on the RTX 2070, managed to get rid of the noise, but in no way could I get rid of the glow around some objects ((can they tell me how to cope with this? What would I not change PTX settings, nothing helps
    Are you lighting your scene with a HDRI or skylight? Are you using RTGI? I had similar issue with skylight + RTGI, you'll get halos and other artifacts...so I disable skylight.

    Try isolating the rendering features and light to see what is causing the problem. Try lighting with lights, turn off everything else(RTGI,reflection,AO,post process).

    edit: I think it's related to the RTGI(it's really experimental feature). See my attached pics. The one with the black arrow is RTGI = ON, the other one is RTGI = OFF.

    Click image for larger version  Name:	RTGI_OFF.jpg Views:	1 Size:	276.5 KB ID:	1608151Click image for larger version  Name:	RTGI_ON.jpg Views:	1 Size:	278.5 KB ID:	1608152
    Last edited by SonKim; 04-15-2019, 03:14 PM.

    Leave a comment:


  • replied
    Originally posted by Czaja91 View Post
    At the current state of development is it possible to achieve good looking pathtraced still images? I'm using GTX 1070 and my simple test scene can't get any further than that (white spots won't go away).
    Hey Czaja91. My English is bad. So I'm sorry, please. Path tracing is active with 1070 graphics cards. But even though I have made all the instructions, he's not active. How can I do that. ?

    Leave a comment:


  • replied
    Good day! I perform raytracing tests on the RTX 2070, managed to get rid of the noise, but in no way could I get rid of the glow around some objects ((can they tell me how to cope with this? What would I not change PTX settings, nothing helps

    Leave a comment:


  • replied
    Originally posted by Antidamage View Post
    If you're actually using the render as an asset can you take it into photoshop and run Dust & Scratches on it?
    Dust & Scratches and some additional photoshop denoising can improve quality, but still, it would be rather bad quality, especially with textures on, when you can't go aggressive on blurring.

    Originally posted by Farshid View Post

    how you achieve this with 1070
    my 1060 has two much noise
    are you using skylight for this scene or something else ?
    I used only default set of UE lights - directional ligh and skylight.

    Leave a comment:


  • replied
    If you're getting lots of noise turn up your light sources and adjust the result with auto-exposure. All of the tricks you use to improve path tracing will work with RTX.

    Leave a comment:


  • replied
    Originally posted by Czaja91 View Post
    At the current state of development is it possible to achieve good looking pathtraced still images? I'm using GTX 1070 and my simple test scene can't get any further than that (white spots won't go away).
    how you achieve this with 1070
    my 1060 has two much noise
    are you using skylight for this scene or something else ?

    Leave a comment:


  • replied
    Originally posted by Antidamage View Post
    1. Static Meshes definitely cast shadows.

    2. That's how unbiased, progressive path tracing looks. You need to ramp up the samples and sit back and wait for several hours to get a smooth result.

    3. I agree here, it should. Keep in mind that path tracing in UE is an afterthought for reference renders, probably someone's pet project. I imagine some amazing stuff is going to be built the community on the back of it, but for now it's not their focus.

    4. Yeah, that'd be nice. I actually want to see a hybrid solution that uses baked lighting in the distance and replaces it with a raytrace pass up close, if there's any performance gain from that.

    5. That's really unrealistic. GPU raytracing outstrips the speed of CPU raytracing by several orders of magnitude. You'd never even notice that the CPU was contributing.

    7. Still too slow to be considered useful for real-time applications. Fully usable real-time path tracing is a generation or two away.
    thanks for your answer

    Leave a comment:

Working...
X