Announcement

Collapse
No announcement yet.

when I build lights, the side of the mesh turns blue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    when I build lights, the side of the mesh turns blue

    Hi everyone, Im having some problems when i build lights, Its turn blue only in one side of the mesh and I dont know why. My skylight is static, the directional light is movable, i have lightmas importance volume, if i move the object the blue disappear... so if someone could help me, i would appreciate it.
    Last edited by El_hugue; 10-05-2018, 09:43 AM. Reason: lightmaps, build light, blue side, mesh

    #2
    It looks like it is getting indirect light from the skylight? Did you maybe turn off shadows for the ceiling and the skylight is coming through?

    Comment


      #3
      Have you added some reflection spheres?
      www.s-dot.de/viz
      ArchViz User Interface :: UE4 Marketplace.

      Comment


        #4
        Originally posted by cwm83 View Post
        It looks like it is getting indirect light from the skylight? Did you maybe turn off shadows for the ceiling and the skylight is coming through?
        mmm no, the ceiling is casting shadow. It only affects that side, if you see the wall behind it also has the blue color in the wall.

        The entire building is one mesh, it could be something with the lightmap? because it happens when i build lights.

        Comment


          #5
          Originally posted by S-Dot View Post
          Have you added some reflection spheres?
          no, i added box reflection. I deleted it and build reflection captures and it doesnt change :/

          I dont know what could be

          Comment


            #6
            Originally posted by El_hugue View Post

            mmm no, the ceiling is casting shadow. It only affects that side, if you see the wall behind it also has the blue color in the wall.

            The entire building is one mesh, it could be something with the lightmap? because it happens when i build lights.
            I guess that is the reason: what you see is not an accurate lighting information but a blurred out "nothing"... Could you post a lightmap density screenshot?
            ...also you might have problems with normals... faces might be flipped...

            Comment


              #7
              Originally posted by Makigirl View Post

              I guess that is the reason: what you see is not an accurate lighting information but a blurred out "nothing"... Could you post a lightmap density screenshot?
              ...also you might have problems with normals... faces might be flipped...
              well aparently it was the lightmap. I create the structure from 0 and i made the lightmap again and the problem dissapear.

              Thanks for your time people!!!

              Comment


                #8

                Hi everyone! My problem is similar, I suspect it comes from skylight. When I build the light, white faces appear on some meshes, not all. When I turn off the skylight and build the light again, the white faces disappear. Anyone know the reason? Thanks in advance
                Attached Files

                Comment

                Working...
                X