Announcement

Collapse
No announcement yet.

Skylight Radiosity !!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by Makigirl View Post
    It will be something else then... maybe your lightmap resolutions are too high... what resolutions you use (from small objects to walls)? Are you using HDRI for the skylight? How many bounces have you set for the skylight?

    Just another idea... I had a very similar scene than yours! It took me I think 12-16 hours to build the lighting... There is an experimental GPU lightmass for 4.19 which gives a lot nicer results (imo) in like 10 times faster!!
    - mostly 512 - 1024 and 2048 for walls floor ceiling and for few big ornament
    - and yes i am using HDRI
    Click image for larger version

Name:	20180811_164426.jpg
Views:	1
Size:	37.0 KB
ID:	1514112
    - and if u are talking about Luoshuang GPU i made some tests a week ago and yes it is fast not 10 times ....about 2 - 3 for (me 1080 vs swam Ryzen 1800x * 2 ) but i got some shadow problems .... for me CPU render was nicer ..... but i did not test it on this scene

    Comment


      #17
      Well I don't know how many meshes you have in the scene... what is separate and what is not... but if you have thousands of objects and all of them has lightmap resolution between 512 and 2048: it's a LOT!!
      If this is not the case and you set the smaller objects accordingly... you'll have to break up the meshes that have 2048 lightmap resolution: it's faster to calculate more meshes with lower lightmap resolution than one mesh with a high one!
      Just one idea if you haven't tried yet: try to clean the cache in swarm agent!
      ...and I wouldn't touch the indirect lighting intensity but leave it on the default: you'll get enough radiosity with proper settings!

      Yes that is the one! If it didn't do the job for you then stick with the default CPU one!

      Comment


        #18
        just decrease Num Sky Lighting Bounces in World Settings

        Comment


          #19
          Once you built your lighting you can check how much time each asset took to build. There is a statistic feature in the editor: Build -> Lighting Info -> Lighting Static Mesh Info. Then in there use the drop down menu for more detail. You can also sort the columns.
          www.s-dot.de/viz
          ArchViz User Interface :: UE4 Marketplace.

          Comment


            #20
            Originally posted by ammarshow View Post
            thank u guys for all the suggestion
            i tried :
            removing portal ........ same result

            deleting skylight and install spot light on window ( as i saw in tutorial ) ...... same result

            Click image for larger version

Name:	20180811_004346.jpg
Views:	1
Size:	235.3 KB
ID:	1513904
            i gave every test about 24 hour and unreal still stuck at radiosity
            is there a way around this radiosity option or this is a must calculation


            i am ok with that and i can render with one pc but i just want it to start render

            well i did all of that and try it on other pc ..... same result
            and i bought some scenes an tested them and they worked fine
            and yes sure i have lighmass importance volume


            i can give it a shot but the whole idea of me choosing very large scene is to test unreal capabilities for arch viz





            Try rect light or want use skylight, set smootness 0,6

            Comment

            Working...
            X