Announcement

Collapse
No announcement yet.

Wall, room, house workflow

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • started a topic Wall, room, house workflow

    Wall, room, house workflow

    Hi, after some attempts to get something good, I'm here to ask for your help with some best practices with workflow.

    i can't find a workflow to build some real and existing apartment or house without issues in lightmap baking.

    For example "my grandma house" (WIP) is one big static mesh made with walls/ceilings/floors in one group and stairs/windows and details grouped apart.

    I suppose that isn't the right way to achieve what i expect in UE4.

    First of all yeah... i came from Sketchup, i' ve done something nearly OK in past with UE4 but it was one room and on a one single floor (my home, image 3).

    I can't find a way to group and organize my rooms without going crazy,.
    My goal is a playable walktrough from the street to the house, so i've to bake light even in the external wall.

    Should i group faces inside every room and group external faces in another group(img 4) or suggest to keep solid mesh ?



    My grandma house section my house

  • replied
    This is the Part 2 of Speed Modeling a House in 3ds Max for Unreal Engine.
    It covers polygon count reduction, UV-ing, and importing into Unreal Engine.
    Please, comment



    Visit www.cgsharenet.com for Digital Art, 3D Models, Tutorials, Reviews and more.

    Leave a comment:


  • replied
    Originally posted by Makigirl View Post


    Cool!
    ...maybe it's good for games but sadly it's not ideal for achviz: all your walls are one single mesh! :S You can't set a high enough lightmap resolution to achieve detailed, realistic results!
    Thank you! Good to know that! I'm going to break that apart then.

    Leave a comment:


  • replied
    Originally posted by Khayyam View Post
    This is how I modeled a house in 3DS Max to use in UE4. Please, comment



    Cool!
    ...maybe it's good for games but sadly it's not ideal for achviz: all your walls are one single mesh! :S You can't set a high enough lightmap resolution to achieve detailed, realistic results!

    Leave a comment:


  • replied
    This is how I modeled a house in 3DS Max to use in UE4. Please, comment



    Visit www.cgsharenet.com for Digital Art, 3D Models, Tutorials, Reviews and more.
    Last edited by Khayyam; 03-28-2018, 04:35 AM.

    Leave a comment:


  • replied
    Finally i figured out how to fix my first problem, jaggered shadows.
    You must have your uv island at 90 degrees.
    i don't know why Steamroller script has turned my uv at ~30°.

    I had to Flappen Mappings manually to have nice shadow in my ceilings


    BEFORE
    Click image for larger version  Name:	Cattura2.PNG Views:	1 Size:	17.6 KB ID:	1373736

    AFTER
    Click image for larger version  Name:	Cattura2.PNG Views:	1 Size:	14.8 KB ID:	1373737

    RESULT
    Click image for larger version  Name:	Cattura2.PNG Views:	2 Size:	151.2 KB ID:	1373739
    Attached Files
    Last edited by Torakiki; 10-22-2017, 06:19 PM.

    Leave a comment:


  • replied
    Very usefull topic! I have the same problem with Revit, like you can see there:

    https://forums.unrealengine.com/deve...-edges-shadows

    Leave a comment:


  • replied
    Hi, i've one stationary directional light, One static skylikght hdri and One BP_SkySphere. Walls, floor and ceiling are all single planes in different meshes. I've alredy tried to push lightmap size up to 1024 for walls and ceiling, with no results. The weird thing is that in other rooms my shadows are all a soft straight line.

    I'm using multibounce skylight lightmass.exe (4.17 version) for light baking.

    My Indirect lighting smoothness is set to 1.2 and every windows have a light portal on it.
    Maybe i could change UV island's padding...
    Last edited by Torakiki; 10-20-2017, 01:52 AM.

    Leave a comment:


  • replied
    I would try to adjust indirect Lighting smoothness. Its in your world settings.
    You can also make sure your directional light is set to stationary.
    Then if your not satisfied look at your lightmap resolution in your mesh settings.
    It should help. The ceiling is a combined mesh with your walls?

    Leave a comment:


  • replied
    Thank you guys, i'm really excited by results obtained so far. I've other question, maybe borderline for this topic. Now i'm stuck with jagged shadow on some meshes edge.

    Like this:

    Click image for larger version

Name:	Immagine3.jpg
Views:	2
Size:	69.7 KB
ID:	1372301

    And why here is ok?? (same side of apartment)
    Click image for larger version

Name:	Immagine2.jpg
Views:	1
Size:	107.2 KB
ID:	1372302


    And what is going on with this furniture reflection/light bounce? It seems like an emissive material but is only a rough (0.85) wooden mesh
    Click image for larger version

Name:	Immagine.jpg
Views:	1
Size:	129.7 KB
ID:	1372300


    Jagged shadows

    Leave a comment:


  • replied
    Originally posted by danimal8361 View Post
    In 3ds max, click on Units Setup under the Customize tab. Under display units scale choose Millimeters. Click the button at the top that says System Unit Setup. In the new window 1 Unit should = 1 Centimeter.
    System Unit Setup button made my day. Thanks a lot!!

    Leave a comment:


  • replied
    In UE4, the default units is not the cm ?

    Leave a comment:


  • replied
    In 3ds max, click on Units Setup under the Customize tab. Under display units scale choose Millimeters. Click the button at the top that says System Unit Setup. In the new window 1 Unit should = 1 Centimeter.

    Leave a comment:


  • replied
    Oh... now i have weird behavior in export from 3ds max 2018 to fbx... from sketchup i'm saving file in sketchup 8 skp format (i work with millimeters), import in max with Units setup (millimeters) and it's all right. But when i export in fbx it doesn't matter which choice i do in units tab.... it will always is REAAAAAALLY big (it seems like 10 times) ...

    Leave a comment:


  • replied
    I manually unwrap UV channel 1 (texture/ normal channel) and steamroll UV channel 2 (lightmap channel). If a texture looks good on your mesh, then the flattened UV channel 2 will be fine in UE4.

    Leave a comment:

Working...
X