Announcement

Collapse
No announcement yet.

Why does my foliage almost disappear when I move further away?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Why does my foliage almost disappear when I move further away?

    I'm doing a fly-through render and when I render far away from these Evermotion trees they lose detail -
    My cinecamera has an LOD drop down with low-medium-high settings but it doesn't appear to make a difference. I also turned off 'auto compute LODs' and set the LOD screen space on all meshes to 1, no difference, the trees themselves only seem to have LOD '0'. In the foliage painter there is a cull setting but that makes no difference either.
    I've looked into LODs for the meshes, material settings and 'Dithered LOD Transition' supposedly when it's not checked the instances will not fade out. Then I've read it's down to the fact I've used the foliage painter which doesn't read the 'dithered LOD transition', so I placed a separate tree without using the foliage tool and that also loses detail when I zoom out, but to a lesser extent than the foliage painted trees... I've looked into the World settings and rendering tab which has 'default max distance', 'global distance field', I've looked at cull settings in the foliage painter, as well as cull volumes, I've looked over my skylight and dynamic light settings... all to no avail...ARRGGHHHHHHH!!!!!... can anyone please help?..



    #2
    You are mixing up a few things here and there are other settings that can affect how the tree looks from the distance. I hope I get this right:

    1) Check the mesh properties (not in the detail panel). If there are no settings for LOD1, LOD2 and so on then there are no LODs for this mesh. In the LOD section check "Number of LODs". If it is 1 then there are no LODs. If it is 2 means one additional LOD1. If you want to disable this LOD1 you could set the Number back to 1.

    2) The screen Size of 1 means 100% of screens space covered. If you set that to a lower value like 0.1 = 10% it will LOD to the next lower mesh available when the size on screen is less than 10%. To be able to change those settings you need to untick "Auto Compute LOD Distances". So setting every LOD to 1 (if that is even possible) will probably make it worse. You need to have the values lower to have less LODing. eg LOD0=0.1, LOD1=0.01, LOD2=0.001

    3) Foliage has it's own system of culling but that doesn't keep the tree from LODing. It removes the tree completely after it is further away than the distance you set, but it will still LOD before the distance is reached.

    4) If the leave material of the tree uses opacity or is translucent then the "opacity mask" in the material will probably let it disappear after a certain distance. Try to change the value from the default. I don't actually understand how exactly it works but it makes a big difference what the value is from the distance viewed.

    All those changes will affect the performance of your level. Hope that helps. Check out the unreal 4 tutorials from Epic. There is a lot of useful information.
    www.s-dot.de/viz
    ArchViz User Interface :: UE4 Marketplace.

    Comment


      #3
      Originally posted by S-Dot View Post
      You are mixing up a few things here and there are other settings that can affect how the tree looks from the distance. I hope I get this right:

      1) Check the mesh properties (not in the detail panel). If there are no settings for LOD1, LOD2 and so on then there are no LODs for this mesh. In the LOD section check "Number of LODs". If it is 1 then there are no LODs. If it is 2 means one additional LOD1. If you want to disable this LOD1 you could set the Number back to 1.

      2) The screen Size of 1 means 100% of screens space covered. If you set that to a lower value like 0.1 = 10% it will LOD to the next lower mesh available when the size on screen is less than 10%. To be able to change those settings you need to untick "Auto Compute LOD Distances". So setting every LOD to 1 (if that is even possible) will probably make it worse. You need to have the values lower to have less LODing. eg LOD0=0.1, LOD1=0.01, LOD2=0.001

      3) Foliage has it's own system of culling but that doesn't keep the tree from LODing. It removes the tree completely after it is further away than the distance you set, but it will still LOD before the distance is reached.

      4) If the leave material of the tree uses opacity or is translucent then the "opacity mask" in the material will probably let it disappear after a certain distance. Try to change the value from the default. I don't actually understand how exactly it works but it makes a big difference what the value is from the distance viewed.

      All those changes will affect the performance of your level. Hope that helps. Check out the unreal 4 tutorials from Epic. There is a lot of useful information.

      - I am having the same issue , and I found it that my Opacity is causing it , making my grass foliage disappear in short distance.
      And looking for solution online and Boom !!! here I am. I found Yours , having same issue.

      Can anyone please explain , How am I going to tweak the Opacity?

      I do also have translucent Map , But its not causing the Issue.
      Only the Opacity Map , when I link it to "Opacity Mark" Network.

      Comment


        #4
        Originally posted by R3DNiX View Post


        - I am having the same issue , and I found it that my Opacity is causing it , making my grass foliage disappear in short distance.
        And looking for solution online and Boom !!! here I am. I found Yours , having same issue.

        Can anyone please explain , How am I going to tweak the Opacity?

        I do also have translucent Map , But its not causing the Issue.
        Only the Opacity Map , when I link it to "Opacity Mark" Network.
        Hello, to change The opacity «thickness» :

        instead of putting The opacity map directly to The opacity mask slot you have to make a scalar parameter And set The Max value to 100 And then make a multipy node And plug your opacity map to «A» And scalar parameter to «B». Then plug The multipy node to The opacity mask slot. After this create a material instance from The material And in there you can adjust The parameter.

        !!!: setting The value Too high will cause your Foliage to look thick And wierd.

        Comment


          #5
          You can do that in the material or material instance itself. Click on an empty space (not on a node) to get the material properties. In the details panel is a "Material" section. Expand the advanced settings by clicking on the arrow at the bottom of that section.

          Change the "Opacity Dynamic Clip Value" which is 0.3333 per default. I think increasing the value will make it more visible. 1.0 would be totally opaque.

          This works per instance so you could make a few instances and change just this value to test it. Or you have two instances, one for close by and one for further away.
          www.s-dot.de/viz
          ArchViz User Interface :: UE4 Marketplace.

          Comment


            #6
            Originally posted by R3DNiX View Post

            I do also have translucent Map , But its not causing the Issue.
            Only the Opacity Map , when I link it to "Opacity Mark" Network.
            Translucency is for half see through objects like glass. You don't want to use a translucent material for foliage. Use a masked material instead. Translucency is quite expensive to render and masked would be the same in your case but cheaper.
            www.s-dot.de/viz
            ArchViz User Interface :: UE4 Marketplace.

            Comment


              #7
              Originally posted by Marnie_4 View Post

              Hello, to change The opacity «thickness» :

              instead of putting The opacity map directly to The opacity mask slot you have to make a scalar parameter And set The Max value to 100 And then make a multipy node And plug your opacity map to «A» And scalar parameter to «B». Then plug The multipy node to The opacity mask slot. After this create a material instance from The material And in there you can adjust The parameter.

              !!!: setting The value Too high will cause your Foliage to look thick And wierd.
              Hi man, just wanted to say thank you because this was solution to my problem! I tried changing cull, lods, and some other stuff but it didn't crossed my mind that going over that top with opacity can fix the problem. Thanks again you saved me from frustration!

              Comment

              Working...
              X