Announcement

Collapse
No announcement yet.

Dark corners no matter what I do :(

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Dark corners no matter what I do :(

    Hello guys, I'm fairly new to UE4, I was practicing to make a photo realistic interior, with the goal of getting a quality as close as the renders produced by Vray & corona ...

    The problem I'm always experiencing is with AO and strange artifacts in the wall corners, of course if they have a colored texture it won't be noticeable but for a white wall it's not.

    I've tried maximizing the lightmap resolution for the geometry up to 2048, tweaked the lightmass settings for maximum quality (very long build times), I've also played with lightmass.ini according to some tutorials on youtube, it helped and the results were much better, but it never get completely rid of the blackness around the corners as you can see in this screenshot.

    I believe my UVs are correct, I've even made each face of the interior wall separate so it exploits all of the lightmap size. what I think is causing the problem is the SSAO but I don't find the option to disable it in world settings?
    reducing AO in post process volume and increasing GI made it look better , but it's still there...

    so what are your experiences on this problem ? did you find a way over it or is this the maximum quality it can get?

    Click image for larger version

Name:	2017-08-18.png
Views:	1
Size:	959.2 KB
ID:	1226953

    #2
    SSAO is in post processing since it's a screen space technique.

    Make sure the walls match up perfectly and don't intersect.

    Make sure you are using portals for the windows and doors.

    Try the multi bounce skylight (there's a forum thread about it in rendering).

    Shouldn't need to change the ini settings if you try all those things.

    Comment


      #3
      Originally posted by ZacD View Post
      SSAO is in post processing since it's a screen space technique.

      Make sure the walls match up perfectly and don't intersect.

      Make sure you are using portals for the windows and doors.

      Try the multi bounce skylight (there's a forum thread about it in rendering).

      Shouldn't need to change the ini settings if you try all those things.
      Indeed the walls are intersecting one another! that's probably the problem, I'm going to snap the vertices to each end of wall and post an update.

      I've never used portals or multi bounce skylight, they must be new additions, I'm currently doing the research
      for lightmass I was following old posts trying to replicate the same configuration of some users, but after these numerous UE4 updates it seems like there's no more need to tweak lightmass.ini in order to achieve high quality visuals?

      Thank you so much for providing me with information looks like I have plenty of pages to read and a few weeks of testing to get most out of it

      Comment


        #4
        Originally posted by karnage94 View Post
        Indeed the walls are intersecting one another! that's probably the problem, I'm going to snap the vertices to each end of wall and post an update.

        I've never used portals or multi bounce skylight, they must be new additions, I'm currently doing the research
        for lightmass I was following old posts trying to replicate the same configuration of some users, but after these numerous UE4 updates it seems like there's no more need to tweak lightmass.ini in order to achieve high quality visuals?

        Thank you so much for providing me with information looks like I have plenty of pages to read and a few weeks of testing to get most out of it
        I bet the intersection was causing most of the problem, when a lightmap bleeds from pure black to well lit, it doesn't do a good job at of hiding that transition.

        I wouldn't start with tweaking the .ini files, I consider it more of last resort.

        https://forums.unrealengine.com/show...d-sky-lighting (there's a link for 4.17 on the last page).

        Comment


          #5
          Problem solved!
          you were right fixing the geometry has solved lighting problems, I also reverted back to the original lightmass.ini file. build took few minutes only and it's getting close to Vray,
          the shade in the corners is almost unnoticeable




          for multi bounce, I've downloaded the file for 4.17, replaced unreallightmass.exe , when I bake the light I get this error message:


          Click image for larger version

Name:	Capture.JPG
Views:	1
Size:	53.7 KB
ID:	1132621
          Attached Files

          Comment


            #6
            I found this of you have adark room with little light coming in.

            https://answers.unrealengine.com/que...-light-so.html

            Comment


              #7
              Worth turning off "Compress Lightmaps" in world settings too - can pump up your ram usage, but you get much nicer falloff on your shadows and corner GI behaves a lot more predictably too.

              Comment


                #8
                @karnag what was your lightmass setting for this scene? what was full scene setup if you can give overview like what you have used(lights+postprocessvol+or anything) also please let me know did you tweak baselightmass ini?

                Comment


                  #9
                  Originally posted by karnage94 View Post

                  Indeed the walls are intersecting one another! that's probably the problem, I'm going to snap the vertices to each end of wall and post an update.

                  I've never used portals or multi bounce skylight, they must be new additions, I'm currently doing the research
                  for lightmass I was following old posts trying to replicate the same configuration of some users, but after these numerous UE4 updates it seems like there's no more need to tweak lightmass.ini in order to achieve high quality visuals?

                  Thank you so much for providing me with information looks like I have plenty of pages to read and a few weeks of testing to get most out of it
                  How to snap the vertz within 3dsmax?

                  Comment


                    #10
                    Also if u move and sew your edges in your uv lightmap it can help a lot.

                    Comment


                      #11
                      the shadow in the corner looks like just on the left wall. if you combine the 2 walls into one mesh, you should not have unequal seems/shadows.

                      Comment

                      Working...
                      X