Announcement

Collapse
No announcement yet.

Lightmap Issues after Light Build

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lightmap Issues after Light Build

    I have my object's UVs unwrapped, but once I build my lighting, I am getting these weird patterns on my objects. I am getting no overlapping errors, and I raised the resolution of my maps, but that didn't seem to affect it. I can't seem to figure out what is causing the weird lighting on the walls and doors.
    Attached Files

    #2
    Your lightmap resolution is too low--the second picture shows the pixel size of the lightmap which you can see is quite large on some objects. Also, for the walls/ceiling/floor make sure that they don't extend beyond the corners or shadow and light can possibly bleed inside.

    Comment


      #3
      Ah, ok. I'm new to the light building aspect. I was never sure what the proper pixel size should be. Should everything be more int eh green/yellow resolution size like this? I am rebuilding now to see if that helped.Click image for larger version

Name:	Screen Capture.png
Views:	1
Size:	579.1 KB
ID:	1122071

      Comment


        #4
        Green should be fine, but it also depends a bit on how the uv's are laid out, if there is any room for dithering, how much space between uv-islands, and smoothing groups of the meshes.
        I can already tell by the triangles around your door that you could try and improve your mesh its polygons and uv's a little

        Comment


          #5
          I rebuilt my lighting with the higher resolution and it fixed a lot of the issues I was having. But I'm still getting these splotchy patterns on my walls that I can't seem to get rid of. I tried changing lightmass settings but that didn't seem to affect it at all.
          Click image for larger version

Name:	Screen Capture.png
Views:	1
Size:	437.9 KB
ID:	1122110

          Comment


            #6
            Originally posted by DMHokie View Post
            I rebuilt my lighting with the higher resolution and it fixed a lot of the issues I was having. But I'm still getting these splotchy patterns on my walls that I can't seem to get rid of. I tried changing lightmass settings but that didn't seem to affect it at all.
            [ATTACH=CONFIG]126769[/ATTACH]
            Looks like problem with Indirect lighting/bounces. You can play with the Lightmass Settings under World Settings. Try with higher "Num Indirect Light Bounce" and "Indirect Lighting Quality".

            One of the starting point for better results is going through this Unreal doc. This will help you get rid of those spotches on objects.
            https://docs.unrealengine.com/latest...mapUnwrapping/

            Check-out this Twitch stream on Lighting. It helps you solve most of the lighting issues.
            https://forums.unrealengine.com/show...e-From-Epic-HQ!

            Mention your current settings so that people can help you better.

            Comment

            Working...
            X