Announcement

Collapse
No announcement yet.

light leaks?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    light leaks?

    I am in the process of working on my first UE project. Its going slow but I am learning a lot and love the program. Here is my latest build. I am using a skylight with a hdri map along with lightmass portals in the window wall.

    I am getting weird light leaks in areas as you can see by the enclosed images. I also enclosed my light mass settings as well. I have not tweaked my BaseLightmass.ini file.

    What should I be checking to get ride of those leaks?

    Thanks
    Alex
    Attached Files

    #2
    Clip the walls through the floor and ceiling by a like 30cm

    Enclose each side of your scene with a mesh (can use the basic cubes in unreal) this will help block light from the Skylight, dont put them over your window wall obviously!
    My Game Frontier Devblog HERE

    Comment


      #3
      It probably has something to do with your indirect lighting quality setting (0.75). The default of this value is 1, which is an ok value if your static lighting scale is also at the default of 1.
      But as soon as you lower the static lighting scale to a value like 0.2, you will get more light leaks. A higher indirect lighting quality will solve some of the light leaks, I dont exactly know the reason behind this, but its just from my experience.
      I would suggest to bake it again with an indirect lighting quality of about 3-6 (for the final build you might even want to use 10) and it should give you some better results.

      Of course, this is assuming that your meshes are aligned properly.
      Last edited by meijervis; 01-23-2017, 12:09 PM.
      My Porfolio

      Comment


        #4
        Make sure they aren't overlapping, if a surface extends outside then the outside part can receive lighting and the lit pixels can then bleed onto the inside. It also does help if you have an outside surface to block lighting

        Comment


          #5
          Thanks for the suggestions guys. I will double check the overlapping. I am going to try and enclose the scene with a mesh and see if that works. Also will look into the settings. Will post some results.

          Comment


            #6
            I don't know what you are talking about, this looks AMAZING How did you created that light?
            Maybe you can add some ambient occlusion or higher AA




            I'm just a random person that spends his time to help others. You can support me by watching this and show your gratitude thanks a lot:
            https://www.youtube.com/watch?v=2y1NkxlwRWo

            Comment

            Working...
            X