Announcement

Collapse
No announcement yet.

UVW Map overlapping

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UVW Map overlapping

    Hi everybody!

    First, I'm sorry for my english, I'm frensh student and I will be such thanksfull if anybody can help me!

    I work in architecture school on a fictionnal project. I make the 3D model on Rhinoceros software, export differents parts of it in .FBX and add it to the Unreal Engine 4 to make possible a virtual visit of my architectural creation.
    But I encountered a problem with the UVW map because it is overlaping. I saw differents tutorials and read a lots of Threads on the forum but I don't found the anwser to my probleme.

    Firt, when I just add .FBX models and try to built the lights a message tel me that "murs_habitations" and "structure_rouages" UWV maps are overlapping Click image for larger version

Name:	1.JPG
Views:	1
Size:	232.0 KB
ID:	1207583

    For exemple when I double-click on "murs-habitations" and show the UVW map from channel map 0 I see the problem. Click image for larger version

Name:	3.JPG
Views:	1
Size:	373.1 KB
ID:	1207584

    So I check "Generate Lightmap UVs", use the "UV channel 1" and verified that "Light Map Coordinate Index" was put to 1. Then I notice that the UVW map is no more overlapping which was WHAT I NEED!! Click image for larger version

Name:	5.JPG
Views:	1
Size:	281.3 KB
ID:	1207585Click image for larger version

Name:	4.JPG
Views:	1
Size:	283.0 KB
ID:	1207586

    But when I click on save and tryed again to built the lights but the same error message of overlapping UV map appears and when I came back on the "murs_habitations" window I saw that it get back on the UV Channel 0 and don't saved anything.

    If anybody can help me to fix this problem I will be really thanksfull!!!!

    #2
    You should use Steamroller to make your UV maps in 3ds Max (you can choose the UV channel within the tool). Also, don't hesitate to break your model (in 3ds max once again) into parts to avoid using high resolution lightmaps !

    Tu devrais utiliser Steamroller pour faire tes UV dans 3ds Max (tu peux choisir le channel depuis l'outil en question). N'hésites pas à séparer ton modèle 3d en plusieurs meshes pour éviter d'avoir à utiliser une résolution de lightmap trop élevée !
    Antoine Guillo, FR
    Virtual Reality Designer
    https://groupe-legendre.com/

    Comment


      #3
      Thank you very much! I will try to use this script, I'm sure it will help me a lot! But I'm wondering what you mean by "avoid using high resolution lightmaps"?

      Et un grand merci pour ta réponse en français c'est très gentil de ta part

      Comment


        #4
        Lightmaps over 2048 will greatly affect light baking time and eat your memory. Better get 4 models with 512x512 lightmaps than 1 model with a 4096x4096 lightmap. While baking your lighting, if you have a quad core processor, 3 cores will idle while 1 core is calculating everything with a 4k lightmap. On the other side, each core will have something to do with 4x512 and you'll gain some processing time. The joys of parallelization.

        Les lightmaps au delà de 2048 vont augmenter considérablement les temps de calculs de tes lumières statiques et manger toute ta mémoire vidéo. Il vaut mieux avoir 4 modèles utilisant des lightmaps de 512 qu'un modèle avec une lightmap de 4096. Lorsque tu précalcule tes lumières statiques, si tu as un processeur 4 coeurs, 3 coeurs vont se tourner les pouces pendant que le 4ème va suer dur. Si tu utilises 4 lightmaps de 512, chaque coeur va travailler, et tu gagnes du temps. Les joies de la parallélisation.


        Pas de soucis pour la traduction, on est la pour s'aider
        Antoine Guillo, FR
        Virtual Reality Designer
        https://groupe-legendre.com/

        Comment


          #5
          Oh okay!! But, where can I see the lightmaps types (2048; 512; 4096; etc..)? Is that related to the numbers of polygons which constitutes my model?

          Also I wonder if you know why in the screenshots I send the UV channel don't wan't to save? Is this also related to the lightmaps number?

          Last thing, if I have a plan and I want to see the texture on both side, how can I do? Is that even possible? And if it's not, how can I flip the normals of the model?

          Comment


            #6
            Originally posted by Pistachios001 View Post
            Oh okay!! But, where can I see the lightmaps types (2048; 512; 4096; etc..)? Is that related to the numbers of polygons which constitutes my model?

            Also I wonder if you know why in the screenshots I send the UV channel don't wan't to save? Is this also related to the lightmaps number?
            The drop-down box is only for seeing UV's in the channels. To set a particular channel you have to change it in the "Light Map Coordinate Index" under "Static Mesh Settings" of your imported mesh.

            https://www.youtube.com/watch?v=joKnmShAdJE
            (Look at 21:00 for increasing Lightmap size and saving the required Lightmap channel in Unreal)

            You can refer this also for information on Unwraping
            https://docs.unrealengine.com/latest...mapUnwrapping/

            Originally posted by Pistachios001 View Post
            Last thing, if I have a plan and I want to see the texture on both side, how can I do? Is that even possible? And if it's not, how can I flip the normals of the model?
            You can use a 2 sided material. You can make any material 2 sided by checking the "Two Sided" checkbox inside material. You can't flip normals in Unreal. You have to do it in your 3D software

            Comment


              #7
              1) Lightmaps are not related to polygon count. You can edit the lightmap resolution in UE4 in the asset settings, under the "Static Mesh Settings" group.

              2) Lightmaps generated in UE4 aren't that great nor reliable, don't bother with that. Make your unwraps directly in 3ds Max with SteamRoller, its done in a few clicks and is directly saved in your model when exporting the fbx to UE4.

              3) You can use a two sided material on your plan in UE4 (in your material settings).
              Antoine Guillo, FR
              Virtual Reality Designer
              https://groupe-legendre.com/

              Comment


                #8
                I'm stating the obvious because no one mentioned it so far

                1) In your 2nd image under Build Settings your "Min Lightmap Resolution" is set to 64. If you want to have a larger light map then you need to change this value. Start with 1024 for this object, make sure "Generate lightmap" is ticked and then hit [Apply].

                2) In your 3rd image under static mesh settings set the "Light map resolution" to the same value as above. So in this case 1024. Then save the static mesh settings (when closing the window confirm the settings change).

                3) See how it looks after the lighting is rebuilt. The larger you go the longer your lighting build will take but the more detailed your shadows will be. Personally I never went go higher then 2048. It's probably not supported unless you do some changes in the project settings. It might even be caped at 1024. I often use 128 or even 64 for smaller objects like some books. You can always increase the instance of the asset in the scene in it's detail panel.

                Your light maps are not really overlapping but because you choose 64 as your min light map resolution the gaps between your charts are fairly big and they won't leave any space for the polygon charts. Therefor unreal thinks that they are overlapping. After you created a larger light map you will see that the gaps are a lot smaller and there is more space for the actual charts. The message should disappear unless you have overlapping UVs in your source uv channel (uv #1 in 3ds max = uv #0 in unreal).
                Last edited by S-Dot; 01-20-2017, 05:40 AM.
                www.s-dot.de/viz
                ArchViz User Interface :: UE4 Marketplace.

                Comment


                  #9
                  Wow!!! Thank you so much for your help!! That is so cool to see many peoples who want to help you

                  Today I finished all my images in 3ds max and I sarted to create the project in UE4. I encountered others problems of course! But all your advises really help me

                  And thank you S-Dot to say the obvious which is not so obvious for beginners like me!

                  Comment

                  Working...
                  X