Announcement

Collapse
No announcement yet.

Revit to ue4 material problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Revit to ue4 material problems

    Hey community

    I'm trying to optimize my workflow from 3d modeling to Archviz through Revit into UE4 and i'm running to a UV problem where materials look far too small on the mesh imported into UE4.
    My units are all correct and meshes are the correct sizes. I'm having trouble finding what i'm doing wrong.
    My work flow is as follows

    Export FBX from Revit (using simple walls for this example)

    Import to 3Ds Max and unwrap UVs using steamroller script and export FBX (units are in CM)

    Import to UE4 with attached import options.
    As you can see the materials are way to small (comparing to BSB in image)
    Meshes are the correct sizes but materials are not.
    What am i doing wrong/missing?

    Thanks!
    Attached Files

    #2
    Usually what i do is to use the command uv map in all geometries in the channel 1 (not the lightmap channel), with a box shape and a size of 100 in x, y and z. That makes texture sizes equal in unreal. I don´t know a better way to do it.

    Regards

    Comment


      #3
      Originally posted by Koolhass View Post
      Usually what i do is to use the command uv map in all geometries in the channel 1 (not the lightmap channel), with a box shape and a size of 100 in x, y and z. That makes texture sizes equal in unreal. I don´t know a better way to do it.

      Regards
      You can select all the meshes you want to have equal texture sizes and use a MapScaler modifier in 3ds max.

      OP, if you're using steam roller on your first UV channel it'll make the islands as big as it can, which will dictate how big the texture appears on your mesh. You can try using Steamroller on just the lightmap UV channel. Otherwise just use a TextureCoordinate node in UE4 to make it the size you want.
      James Gallagher

      Architectural Technologist, P3Architecture Partnership

      Comment


        #4
        You can either adjust the tiling in the UV's of the object or you can adjust the tiling settings in the material in UE4.

        Comment


          #5
          Originally posted by TKDlachlan View Post
          Hey community
          Meshes are the correct sizes but materials are not.
          I'm also in the process of creating a fast and efficient workflow for heavy Revit files to UE4, and the UVs are indeed too big when assigning materials in the engine. Turns out creating a Material instance and adding U and V scaling parameters in the original material is good enough for this problem.

          0.1 scaling in the material instance is the gold number for most of my exports when using SteamRoller unwraps.

          As suggested by darthviper107 :

          Click image for larger version

Name:	TilingTemplate.PNG
Views:	1
Size:	114.7 KB
ID:	1118879
          Antoine Guillo, FR
          Virtual Reality Designer
          https://groupe-legendre.com/

          Comment


            #6
            https://forums.unrealengine.com/show...th-ScreenShots

            you must use map scaler

            Comment

            Working...
            X