Announcement

Collapse
No announcement yet.

physics asset tool shows my wheels moving all over the place

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    physics asset tool shows my wheels moving all over the place

    https://answers.unrealengine.com/que...sset-tool.html

    any help would be appreciated. I have been working on this issue for 3 weeks! cannot seem to get it to work.

    #2
    ok sort out the orintation of the root bone X=forward Z=up , then you can set the wheels to kinematic

    sometimes posting on the forum will get you more help than the answer hub


    when you create your vehicle bp don't add extra wheels to it, the wheeledvehicle code ONLY works with 4 wheels
    UT40K:The Chosen - Warhammer 40,000 for UE4
    ut40kgeodav - UE4 Tutorials

    Comment


      #3
      Thanks Geodav, I rotated all of my bones to orientate the wheels correctly. Though the issue still persists In the physics asset tool the wheels scramble all over the place, they arenèt trying to get to the master bone, they just scramble everywhere, should I delete the centre bones?

      Comment


        #4
        here is the fbx attachment
        Attached Files

        Comment


          #5
          https://drive.google.com/file/d/0B4v...ew?usp=sharing is the blend file
          Attached Files

          Comment


            #6
            please watch this video https://youtu.be/SZgBJld-KGg?list=PL...rhNnelWpOzGWRI
            as mentioned in the above post your root/base bone MUST be aligned to the correct axis other wise the physics asset will not work , also the root bone MUST be at 0.0.0
            when you export from blender make sure you "untick leaf bones" UE4 does not need them

            please remember that the physics part of the engine the correct alignment of the bones
            UT40K:The Chosen - Warhammer 40,000 for UE4
            ut40kgeodav - UE4 Tutorials

            Comment


              #7
              thanks geodav, its working now but I still have the vert influence warnings, how do i get rid of that? I have all of my vertex groups assigned

              Comment


                #8
                most likely you have a very small triangle some where, not sure how you would find it in blender. could be a part that you thoght you have deleted but missed a tri
                UT40K:The Chosen - Warhammer 40,000 for UE4
                ut40kgeodav - UE4 Tutorials

                Comment


                  #9
                  hey Geodav, it stopped working again. I followed your tutorial exactly but issues still happen.

                  Could you check the image in this post and tell me if something is going wrong, also I have placed the root bone at x:0, y:0 and z:0 in location but I still have problems

                  https://forums.unrealengine.com/show...mature-to-work

                  Comment

                  Working...
                  X