Announcement

Collapse
No announcement yet.

Blender-UE4 FBX Animation Errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Blender-UE4 FBX Animation Errors

    So I made a Guy in blender and imported him to UE4 with no animations and only 2 errors, none of which really got in the way. I tried to give the same guy a walking animation and import that animation to UE4 from blender. His foot got all messed up and for some reason the animation itself was down scaled.
    This is the guy without animations.
    Click image for larger version

Name:	NiceGuy.PNG
Views:	1
Size:	277.9 KB
ID:	1146600

    This is the same guy with a walking animation except now he's 23rd his normal size and inherited a pretty messed up foot.
    Click image for larger version

Name:	Foot.PNG
Views:	1
Size:	195.5 KB
ID:	1146601

    I do receive a couple errors when moving him and the walking animation to UE4.
    Click image for larger version

Name:	UE4Errors.PNG
Views:	1
Size:	59.3 KB
ID:	1146602

    Here's my Blender export settings and my UE4 Import settings.
    Click image for larger version

Name:	BlenderExport.PNG
Views:	1
Size:	43.7 KB
ID:	1146604
    Click image for larger version

Name:	UE4Import.PNG
Views:	1
Size:	78.5 KB
ID:	1146603

    Any help will be appreciated greatly.
    Last edited by SevArktic; 03-23-2015, 07:42 PM.

    #2
    Try to use FBX 6.1 Version exporter, only export the selected mesh, then the selected animations separate. When you import the animations define Animation Name.
    LEGENDS OF EPICA | CS - SPACE ALPHA

    Comment


      #3
      Aight, Lemme try that and get back to you.

      Comment


        #4
        Okay, I really don't know how to express the sheer quantities of joy I am currently experiencing!

        Thank you SO MUCH!!!

        As long as I use the FBX 6.1 exporter and import the animations and the mesh separately into UE4, then everything turns out great!

        EDIT: How do I lock this thread now that the issue has been resolved?

        Comment


          #5
          just edit your first post and add [Solved] to the front of the title
          UT40K:The Chosen - Warhammer 40,000 for UE4
          ut40kgeodav - UE4 Tutorials

          Comment

          Working...
          X