Announcement

Collapse
No announcement yet.

Morph Target Problem in Animation

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Morph Target Problem in Animation

    I've been trying to get an idle animation that was sent to me to use the curves that have been set up, but unless I am editing the animation or set an additive animation it doesn't work. If I do set an additive animation the model collapses in on itself until its invisible.

    Any idea what I might be doing wrong or what setting may be making it not function properly?

    #2
    Personally, I would drive the morphs with the curve by nodes in animbp

    But apparently if the curve name matches the morph target name exactly it should just work.
    https://docs.unrealengine.com/en-US/...ves/index.html

    Comment


      #3
      I have them all named exactly. As seen in the image if I have it set to local space in additive settings it works, but if its set to no additive it stops working. I would use this but it effectively kills the model out of editor.
      Attached Files

      Comment


        #4
        Do the morphs work using the nodes?

        Comment


          #5
          Im not sure how to do that, but ill try it out.

          Comment


            #6
            Basically add an input key, a timeline of 1 second with a value from 0 to 1 and hook it up to play from start / play reverse. Drag the result as the morph target, and see if they work at all with a simple SetMorphTarget.

            Comment

            Working...
            X